-   Linux - Hardware (
-   -   ATI drivers & Xen (

Pearlseattle 10-16-2007 11:35 AM

ATI drivers & Xen
Did anybody manage to make the proprietary ATI drivers work with Xen?
I am using ATI drivers version 8.39.4 with Xen 3.1.0, but each time I try to load the fglrx module I get in dmesg the error message "fglrx: Unknown symbol flush_tlb_page" and the module doesn't load.
I tried to "google" but didn't find anything interesting. Any clue? Thanks... .

Willy Gommel 11-16-2007 06:15 PM

I am a Debian user. In poking through the documents in my FGLRX module area, I find the following notation:

"fglrx-driver (8.28.8-4) unstable; urgency=low

* Add patch 12-CONFIG_X86_XEN to allow building on Xen-enabled kernels;
thanks to Loic Minier.
(Closes: #368802)"

Hope this helps you out.

Pearlseattle 12-27-2007 03:28 PM

I know, but it does not work, sniff sniff...
Anyway, thank you.

mad4linux 09-06-2008 06:38 AM

Issue remains: Etch n half, amd64, Xen, ATI 3D
Still the same problem with Xen Kernels and ati driver.
I'm using this kernel:

and trying to load this fglrx-module:
fglrx-kernel-2.6.18-6-xen-amd64 (8.28.8-4+2.6.18.dfsg.1-22etch2)


mesg | grep fglrx
gives this output:


fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
fglrx: Unknown symbol flush_tlb_page
fglrx: Unknown symbol flush_tlb_page

Does anybody know anything helpful on how to fix this? I need 3D hardware accel for blender. Without i'll have to set up my system again without xen.

I also tried to apply the patch mentioned in this tread before. But it seems, that it is already done. Patch gives me the following output:


patching file firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] n
Apply anyway? [n] n
Skipping patch.
patch: **** malformed patch at line 18:

All times are GMT -5. The time now is 04:24 PM.