LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 04-24-2004, 08:38 AM   #16
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15

Quote:
Originally posted by init
do you have loadable module support built into your kernel ?
yes i have
 
Old 04-24-2004, 11:07 AM   #17
init
Member
 
Registered: Oct 2003
Location: Portland, Maine
Distribution: Gentoo 2004_2 2.6.7r14
Posts: 160

Original Poster
Rep: Reputation: 30
yea man I see you are running a new kernel. I am running 2.4.x I could not get it to work with a newer kernel. Look around on the forums I no there are some post about this and some people have gotten this to work I am not sure what they did though.
 
Old 04-24-2004, 11:29 AM   #18
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 16
Ok what is your CPU? AMD or Intel?
Are you using the ATI 3.2.8 or the 3.7.6 version drivers?
I had to patch the driver to get it to install on my AMD box.
You will need agpgart in your kernel.
You may need to modprobe the above in before you startx.
So, boot into run level 3 (no Xserver but multi-user.)
Try to run the
-CODE-
cd /lib/modules/fglrx
sh make_install.sh
lsmod
-CODE-
If you see fglrx you are cool to run the fglrxconfig and continue w/ the install.
It may let you load the driver this time because X has not loaded it for you.
Post back soon,
L8tr
Feend
 
Old 04-24-2004, 11:45 AM   #19
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 16
Quote:
Originally posted by init
yea man I see you are running a new kernel. I am running 2.4.x I could not get it to work with a newer kernel. Look around on the forums I no there are some post about this and some people have gotten this to work I am not sure what they did though.
Hey if you were getting the vm inconsistancy error you can get around that by hacking the make.sh. Just force the check. It is documented in the script. (sort of)
L8tr
Feend
 
Old 04-24-2004, 02:19 PM   #20
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
look my profile for info -> HERE

ill try the last adivece and post answer later
 
Old 04-24-2004, 04:03 PM   #21
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
didnt help

but didnt get error either :S what to do ?

modprobe fglrx and its loaded but nothin ?

get same error
 
Old 04-24-2004, 04:19 PM   #22
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
bash-2.05b# lsmod
Module Size Used by
fglrx 208228 0
agpgart 29388 0
 
Old 04-24-2004, 04:53 PM   #23
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 16
OK when I built fglrx last, I got the same errors you did and the driver worked. So is your Xserver able to start?

And have you tried the fglrxconfig program to make a XF86Config file?

When you run sh make_install the last thing it does is try to load the fglrx module. If I understand your last post you did not get an error when you ran the sh make_install (from runlevel 3 ) is this correct?
Sorry but I need to get a handle on the state your system is in so I can help you.
L8tr
Feend
 
Old 04-24-2004, 05:02 PM   #24
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
yeah it didnt give me any errors and made fgrlxconfig too -and confed anything like i was told in how-to

get handle - u mean remote desktop ? never done it on slackware

Last edited by IffikaS; 04-24-2004 at 05:04 PM.
 
Old 04-24-2004, 06:28 PM   #25
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 16
So, can you launch X using the XFConfig-4 made by fglrxconfig? ( Check to be certain that /etc/X1/XF86Config points to /etc/X11/XF86Config-4 or Change the etc/X1/XF86Config to a different name.) If you can, run glxinfo and post. If not post your /var /logXFree86.log

I mean (handle) as I am not in front of your terminal so I must ask you questions in order to help.
L8tr
Feend

Last edited by feend; 04-24-2004 at 06:35 PM.
 
Old 04-25-2004, 01:58 AM   #26
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
Quote:
Originally posted by feend
So, can you launch X using the XFConfig-4 made by fglrxconfig? ( Check to be certain that /etc/X1/XF86Config points to /etc/X11/XF86Config-4 or Change the etc/X1/XF86Config to a different name.) If you can, run glxinfo and post. If not post your /var /logXFree86.log

I mean (handle) as I am not in front of your terminal so I must ask you questions in order to help.
L8tr
Feend
X is workinf fine w/ XF86Config-4 .

heres the glxinfo:
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 1 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 1 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 1 0 None
 
Old 04-25-2004, 02:19 AM   #27
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
anyway i looked into XF86Config.0.log and guess what i found ->

I made it smaller so removed crap from file beggining

(II) FireGL8700/8800: Driver for chipset: ATI RV250 Id (R9000),
ATI RV250 Ie (R9000), ATI RV250 If (R9000), ATI RV250 Ig (R9000),
ATI RV250 Ld (M9), ATI RV250 Le (M9), ATI RV250 Lf (M9),
ATI RV250 Lg (M9), ATI RV280 5960 (R9200 PRO),
ATI RV280 Ya (R9200LE), ATI RV250SE Yd (R9200SE),
ATI RV250 5C61 (M9+), ATI RV250 5C63 (M9+), ATI R200 QH (R8500),
ATI R200 QL (R8500), ATI R200 QM (R9100), ATI R200 QT (R8500),
ATI R200 QU (R9100), ATI R200 BB (R8500), ATI RV350 AP (R9600),
ATI RV350SE AQ (R9600SE), ATI RV350 AR (R9600 PRO),
ATI RV350 NP (M10), ATI R300 AD (R9500), ATI R300 AE (R9500),
ATI R300 AF (R9500), ATI R300 AG (Fire GL Z1/X1),
ATI R300 ND (R9700 PRO), ATI R300 NE (R9700/R9500 PRO),
ATI R300 NF (R9600 TX), ATI R300 NG (Fire GL X1),
ATI R350SE AH (R9800SE), ATI R350 AK (Fire GL unknown),
ATI RV350 AT (Fire GL T2), ATI RV350 AU (Fire GL T2),
ATI RV350 AV (Fire GL T2), ATI RV350 AW (Fire GL T2),
ATI R350 NH (R9800), ATI R350LE NI (R9800LE), ATI R350 NJ (R9800),
ATI R350 NK (Fire GL X2), ATI RV350 NT (WS/M10)
(II) Primary Device is: PCI 01:00:0
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset ATI RV250 If (R9000) found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe6002000 - 0xe60020ff (0x100) MX[B]
[6] -1 0 0xe6001000 - 0xe6001fff (0x1000) MX[B]
[7] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[8] -1 0 0xe5010000 - 0xe501ffff (0x10000) MX[B](B)
[9] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[10] -1 0 0xe5000000 - 0xe500ffff (0x10000) MX[B](B)
[11] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[12] -1 0 0xe6000000 - 0xe6000fff (0x1000) MX[B](B)
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[16] -1 0 0x0000e400 - 0x0000e403 (0x4) IX[B]
[17] -1 0 0x0000e000 - 0x0000e003 (0x4) IX[B]
[18] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[19] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[20] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[21] -1 0 0x0000d000 - 0x0000d00f (0x10) IX[B]
[22] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
(II) fglrx(0): pEnt->device->identifier=0x82009b0
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe6002000 - 0xe60020ff (0x100) MX[B]
[6] -1 0 0xe6001000 - 0xe6001fff (0x1000) MX[B]
[7] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[8] -1 0 0xe5010000 - 0xe501ffff (0x10000) MX[B](B)
[9] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[10] -1 0 0xe5000000 - 0xe500ffff (0x10000) MX[B](B)
[11] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[12] -1 0 0xe6000000 - 0xe6000fff (0x1000) MX[B](B)
[13] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[14] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[15] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[17] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[18] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[19] -1 0 0x0000e400 - 0x0000e403 (0x4) IX[B]
[20] -1 0 0x0000e000 - 0x0000e003 (0x4) IX[B]
[21] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[22] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[23] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[24] -1 0 0x0000d000 - 0x0000d00f (0x10) IX[B]
[25] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
[26] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[27] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) fglrx(0): === [R200PreInit] === begin, [s]
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) fglrx(0): PCI bus 1 card 0 func 0
(**) fglrx(0): Depth 24, (--) framebuffer bpp 32
(II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) fglrx(0): Default visual is TrueColor
(**) fglrx(0): Option "NoAccel" "no"
(**) fglrx(0): Option "NoDRI" "no"
(**) fglrx(0): Option "Capabilities" "0x00000000"
(**) fglrx(0): Option "GammaCorrectionI" "0x00000000"
(**) fglrx(0): Option "GammaCorrectionII" "0x00000000"
(**) fglrx(0): Option "OpenGLOverlay" "off"
(**) fglrx(0): Option "VideoOverlay" "on"
(**) fglrx(0): Option "DesktopSetup" "0x00000000"
(**) fglrx(0): Option "MonitorLayout" "AUTO, AUTO"
(**) fglrx(0): Option "HSync2" "unspecified"
(**) fglrx(0): Option "VRefresh2" "unspecified"
(**) fglrx(0): Option "ScreenOverlap" "0"
(**) fglrx(0): Option "IgnoreEDID" "off"
(**) fglrx(0): Option "UseInternalAGPGART" "no"
(**) fglrx(0): Option "Stereo" "off"
(**) fglrx(0): Option "StereoSyncEnable" "1"
(**) fglrx(0): Option "UseFastTLS" "0"
(**) fglrx(0): Option "BlockSignalsOnLock" "on"
(**) fglrx(0): Option "ForceGenericCPU" "no"
(**) fglrx(0): Option "CenterMode" "off"
(**) fglrx(0): Option "FSAAScale" "1"
(**) fglrx(0): Option "FSAAEnable" "no"
(**) fglrx(0): Option "FSAADisableGamma" "no"
(**) fglrx(0): Option "FSAACustomizeMSPos" "no"
(**) fglrx(0): Option "FSAAMSPosX0" "0.000000"
(**) fglrx(0): Option "FSAAMSPosY0" "0.000000"
(**) fglrx(0): Option "FSAAMSPosX1" "0.000000"
(**) fglrx(0): Option "FSAAMSPosY1" "0.000000"
(**) fglrx(0): Option "FSAAMSPosX2" "0.000000"
(**) fglrx(0): Option "FSAAMSPosY2" "0.000000"
(**) fglrx(0): Option "FSAAMSPosX3" "0.000000"
(**) fglrx(0): Option "FSAAMSPosY3" "0.000000"
(**) fglrx(0): Option "FSAAMSPosX4" "0.000000"
(**) fglrx(0): Option "FSAAMSPosY4" "0.000000"
(**) fglrx(0): Option "FSAAMSPosX5" "0.000000"
(**) fglrx(0): Option "FSAAMSPosY5" "0.000000"
(**) fglrx(0): Option "NoTV" "yes"
(**) fglrx(0): Option "TVStandard" "NTSC-M"
(**) fglrx(0): Option "TVHSizeAdj" "0"
(**) fglrx(0): Option "TVVSizeAdj" "0"
(**) fglrx(0): Option "TVHPosAdj" "0"
(**) fglrx(0): Option "TVVPosAdj" "0"
(**) fglrx(0): Option "TVHStartAdj" "0"
(**) fglrx(0): Option "TVColorAdj" "0"
(**) fglrx(0): Option "PseudoColorVisuals" "off"
(**) fglrx(0): Qbs disabled
(==) fglrx(0): RGB weight 888
(II) fglrx(0): Using 8 bits per RGB (8 bit DAC)
(**) fglrx(0): Gamma Correction for I is 0x00000000
(**) fglrx(0): Gamma Correction for II is 0x00000000
(==) fglrx(0): Buffer Tiling is ON
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) fglrx(0): initializing int10
(II) fglrx(0): Primary V_BIOS segment is: 0xc000
(**) fglrx(0): Option "mtrr" "off"
(--) fglrx(0): Chipset: "ATI RV250 If (R9000)" (Chipset = 0x4966)
(--) fglrx(0): (PciSubVendor = 0x1458, PciSubDevice = 0x4010)
(--) fglrx(0): board vendor info: third party grafics adapter - NOT original ATI
(--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
(--) fglrx(0): MMIO registers at 0xe5000000
(--) fglrx(0): ChipExtRevID = 0x01
(--) fglrx(0): ChipIntRevID = 0x00
(--) fglrx(0): VideoRAM: 131072 kByte (64-bit DDR SDRAM)
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.2.0
ABI class: XFree86 Video Driver, version 0.6
(II) fglrx(0): I2C bus "DDC" initialized.
(II) fglrx(0): Connector Layout from BIOS --------
(II) fglrx(0): Connector1: DDCType-3, DACType-0, TMDSType--1, ConnectorType-2
(II) fglrx(0): Connector0: DDCType-2, DACType-1, TMDSType-0, ConnectorType-3
(**) fglrx(0): MonitorLayout Option:
Monitor1--Type AUTO, Monitor2--Type AUTO

(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): DDC detected on DDCType 2 with Monitor Type 0
(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): DDC detected on DDCType 3 with Monitor Type 1
(II) fglrx(0): Primary head:
Monitor -- NONE
Connector -- DVI-I
DAC Type -- TVDAC/ExtDAC
TMDS Type -- Internal
DDC Type -- DVI_DDC
(II) fglrx(0): Secondary head:
Monitor -- CRT
Connector -- VGA
DAC Type -- Primary
TMDS Type -- NONE
DDC Type -- VGA_DDC
(II) fglrx(0): EDID data from the display on Secondary head ---------------------------
(II) fglrx(0): Manufacturer: HTC Model: b004 Serial#: 13074
(II) fglrx(0): Year: 1999 Week: 41
(II) fglrx(0): EDID Version: 1.1
(II) fglrx(0): Analog Display Input, Input Voltage Level: 0.700/0.300 V
(II) fglrx(0): Sync: Separate Composite
(II) fglrx(0): Max H-Image Size [cm]: horiz.: 33 vert.: 25
(II) fglrx(0): Gamma: 2.10
(II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) fglrx(0): redX: 0.625 redY: 0.340 greenX: 0.285 greenY: 0.600
(II) fglrx(0): blueX: 0.150 blueY: 0.065 whiteX: 0.283 whiteY: 0.298
(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 720x400@70Hz
(II) fglrx(0): 720x400@88Hz
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 640x480@67Hz
(II) fglrx(0): 640x480@72Hz
(II) fglrx(0): 640x480@75Hz
(II) fglrx(0): 800x600@56Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 800x600@72Hz
(II) fglrx(0): 800x600@75Hz
(II) fglrx(0): 832x624@75Hz
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): 1024x768@70Hz
(II) fglrx(0): 1024x768@75Hz
(II) fglrx(0): 1152x870@75Hz
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
(II) fglrx(0): #1: hsize: 1024 vsize 768 refresh: 85 vid: 22881
(II) fglrx(0): #2: hsize: 1024 vsize 768 refresh: 75 vid: 20321
(II) fglrx(0): #3: hsize: 800 vsize 600 refresh: 85 vid: 22853
(II) fglrx(0): #4: hsize: 1152 vsize 864 refresh: 75 vid: 20337
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 94.5 MHz Image Size: 305 x 230 mm
(II) fglrx(0): h_active: 1024 h_sync: 1072 h_sync_end 1168 h_blank_end 1376 h_border: 0
(II) fglrx(0): v_active: 768 v_sync: 769 v_sync_end 772 v_blanking: 808 v_border: 0
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 31.5 MHz Image Size: 305 x 230 mm
(II) fglrx(0): h_active: 640 h_sync: 672 h_sync_end 736 h_blank_end 832 h_border: 0
(II) fglrx(0): v_active: 400 v_sync: 401 v_sync_end 404 v_blanking: 445 v_border: 0
(II) fglrx(0): Ranges: V min: 50 V max: 130 Hz, H min: 31 H max: 69 kHz, PixClock max 110 MHz
(II) fglrx(0): Monitor name: CM650
(II) fglrx(0):
(II) fglrx(0): DesktopSetup 0x0000
(**) fglrx(0): PseudoColor visuals disabled
(**) fglrx(0): Overlay disabled
(**) fglrx(0): Overlay disabled
(II) fglrx(0): PLL parameters: rf=2700 rd=12 min=20000 max=40000; xclk=25000
(==) fglrx(0): Using gamma correction (1.0, 1.0, 1.0)
(**) fglrx(0): Center Mode is disabled
(==) fglrx(0): TMDS coherent mode is enabled
(II) fglrx(0): Total 5 valid mode(s) found.
(--) fglrx(0): Virtual size is 1024x768 (pitch 1024)
(**) fglrx(0): *Default mode "1024x768": 94.5 MHz (scaled from 0.0 MHz), 68.7 kHz, 85.0 Hz
(II) fglrx(0): Modeline "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808
(**) fglrx(0): Default mode "832x624": 57.3 MHz (scaled from 0.0 MHz), 49.7 kHz, 74.6 Hz
(II) fglrx(0): Modeline "832x624" 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync
(**) fglrx(0): Default mode "800x600": 56.3 MHz (scaled from 0.0 MHz), 53.7 kHz, 85.1 Hz
(II) fglrx(0): Modeline "800x600" 56.30 800 832 896 1048 600 601 604 631 +hsync +vsync
(**) fglrx(0): Default mode "640x480": 31.5 MHz (scaled from 0.0 MHz), 37.5 kHz, 75.0 Hz
(II) fglrx(0): Modeline "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
(**) fglrx(0): Default mode "640x400": 31.5 MHz (scaled from 0.0 MHz), 37.9 kHz, 85.1 Hz
(II) fglrx(0): Modeline "640x400" 31.50 640 672 736 832 400 401 404 445
(--) fglrx(0): Display dimensions: (330, 250) mm
(--) fglrx(0): DPI set to (78, 78)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) fglrx(0): NoAccel = NO
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(==) fglrx(0): HPV inactive
(==) fglrx(0): FSAA enabled: NO
(**) fglrx(0): FSAA Gamma enabled
(**) fglrx(0): FSAA Multisample Position is fix
(**) fglrx(0): NoDRI = NO
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/X11R6/lib/modules/linux/libfglrxdrm.a
(II) Module fglrxdrm: vendor="Fire GL - ATI Research GmbH, Germany"
compiled for 4.3.0.1, module version = 3.7.6
ABI class: XFree86 Server Extension, version 0.2
(II) fglrx(0): Depth moves disabled by default
(**) fglrx(0): Capabilities: 0x00000000
(**) fglrx(0): cpuFlags: 0x8000000d
(**) fglrx(0): cpuSpeedMHz: 0x0000040b
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
(**) fglrx(0): using built in AGPGART module: no
(**) fglrx(0): UseFastTLS=0
(**) fglrx(0): BlockSignalsOnLock=1
(==) fglrx(0): EnablePrivateBackZ = NO
(II) fglrx(0): using CAIL version [ATI LIB=CAIL.LIB,IA32,2.0024]
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xe5000000 - 0xe500ffff (0x10000) MX[B]
[1] 0 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[2] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[7] -1 0 0xe6002000 - 0xe60020ff (0x100) MX[B]
[8] -1 0 0xe6001000 - 0xe6001fff (0x1000) MX[B]
[9] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[10] -1 0 0xe5010000 - 0xe501ffff (0x10000) MX[B](B)
[11] -1 0 0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
[12] -1 0 0xe5000000 - 0xe500ffff (0x10000) MX[B](B)
[13] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[14] -1 0 0xe6000000 - 0xe6000fff (0x1000) MX[B](B)
[15] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[16] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[17] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[18] 0 0 0x0000c000 - 0x0000c0ff (0x100) IX[B]
[19] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[20] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[21] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[22] -1 0 0x0000e400 - 0x0000e403 (0x4) IX[B]
[23] -1 0 0x0000e000 - 0x0000e003 (0x4) IX[B]
[24] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[25] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[26] -1 0 0x0000d400 - 0x0000d41f (0x20) IX[B]
[27] -1 0 0x0000d000 - 0x0000d00f (0x10) IX[B]
[28] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B](B)
[29] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[30] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) fglrx(0): UMM area: 0xd0500000 (size=0x07b00000)
(II) fglrx(0): driver needs XFree86 version: 4.3.x
(II) fglrx(0): detected XFree86 version: 4.3.0
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xd0000000 FBMappedSize: 0x08000000
(II) fglrx(0): FBMM initialized for area (0,0)-(1024,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1024,768) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(II) fglrx(0): Using hardware cursor (scanline 768)
(II) fglrx(0): Largest offscreen area available: 1024 x 7419
(**) Option "dpms"
(**) fglrx(0): DPMS enabled
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid Horizontal and Vertical Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): Direct rendering disabled
(II) Loading extension FGLRXEXTENSION
(II) Loading extension ATITVOUT
(==) RandR enabled
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMalloc from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMalloc from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMalloc from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMalloc from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmFree from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMalloc from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol drmMalloc from module /usr/X11R6/lib/modules/linux/libfglrxdrm.a is unresolved!
Symbol DRIGetDrawableInfo from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpBase from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpSize from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpEnable from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpRelease from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpDeviceId from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpVendorId from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmAgpGetMode from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol DRIGetDeviceInfo from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmMap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol drmUnmap from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(**) Option "Protocol" "ImPS/2"
(**) Mouse1: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/psaux"
(**) Option "Emulate3Buttons"
(**) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse1: ZAxisMapping: buttons 4 and 5
(**) Mouse1: Buttons: 5
(II) Keyboard "Keyboard1" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) Mouse1: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 0
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 0
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 0
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 0
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 0
GetModeLine - scrn: 0 clock: 94500
GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 0
 
Old 04-25-2004, 08:18 AM   #28
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
noone ?
 
Old 04-25-2004, 09:09 AM   #29
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 16
(**) fglrx(0): using built in AGPGART module: no
You can try using the bult in agpmodule by running fglrxconfig and selecting use external agpgart no. Or just edit the line in your XF86Config-4.
The problem right now is your still using mesa not Fgl.

OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:

(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

First try the internal gart and post back.

If that does not work we will look at you kernel config, you may need to recompile. I will look for my list of things to have and not have in the kernel for fglrx to run.
L8tr
Feend
 
Old 04-25-2004, 09:46 AM   #30
IffikaS
Member
 
Registered: Sep 2003
Location: ESTONIA -Tallinn
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
changed the gart but still nothin :S btw i have agpgart built as a module in my kernel and chosed a ATI schipset but does it need motherboard chipset or the VGA chipset ?

BTW- DRI was outcommented @ start of XF86Config - i now enabled it

PS- do u have MSN - it would be easier to communicate -< ivarkylma@hotmail.com

Last edited by IffikaS; 04-25-2004 at 09:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A little success, and a lesson (ATI, Radeon fb) mimithebrain LinuxQuestions.org Member Success Stories 2 11-11-2005 06:11 PM
ATI Radeon 9800XT... Success! svinka Linux - Hardware 2 07-20-2005 09:11 AM
ATI Success stories xanas3712 Linux - Newbie 5 09-20-2004 12:57 PM
Any success with hw accel on ATI Radeon 7000?? emcoder Linux - Hardware 0 06-21-2004 12:42 AM
SiS655 chipset and ATI drivers - Success anyone? Rav Linux - Hardware 1 09-06-2003 07:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration