LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-22-2004, 06:37 PM   #76
cjcrook
LQ Newbie
 
Registered: Feb 2004
Location: BF Texas
Distribution: Suse 9.0 Pro
Posts: 8

Rep: Reputation: 0

Wow, what a trip. I finally got it all to work by bastardizing the Suse procedure with sirra's.

I went fully through Suse's procedure. X windows wouldn't start after rebooting when done with Suse's procedure. I then had to go back through the make cloneconfig and make dep from sirra's procedure and followed through step six. When I finished up with sirra's procedure, I rebooted again. Viola! here wear are now.



Boo-ya. I'm nailing 4800 fps in glxgears now. (bout friggin time!)

Last edited by cjcrook; 02-23-2004 at 08:22 AM.
 
Old 02-23-2004, 06:20 PM   #77
cjcrook
LQ Newbie
 
Registered: Feb 2004
Location: BF Texas
Distribution: Suse 9.0 Pro
Posts: 8

Rep: Reputation: 0
I have to laugh just a little too, because the wheel on my mouse started working now that the graphics drivers are working too, lol.
 
Old 02-27-2004, 12:16 PM   #78
LowLife
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
Hi,

I'm a n00b in linux and tried to install the drivers with this tutorial for my ati 9700. Everything went fine. After reboot kde is starting and I test it wth glxgears in console(in kde). I get an error message: no display null or something. When I go out the graphical interface I get de same error. What's wrong. The file boot.local is good, I think I have make the line at the bottom of the document.

Sorry for bad english

Greetingz
LowLife
 
Old 02-29-2004, 04:25 PM   #79
aplc0r
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Rep: Reputation: 0
Quote:
Cannot get agpgart to load, tried all of the details as above: comes up with the info below when insmod agpgart is run, any ideas?

Using /lib/modules/2.4.21-166-default/kernel/drivers/char/agp/agpgart.o
/lib/modules/2.4.21-166-default/kernel/drivers/char/agp/agpgart.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg

fglrx is loading fine, and agpgart tries to load but fails as above when the system is booted. I am a newbie, so this may be something straight forward. The apgart.o file is present as well in the correct folder above.

I also have the same problem with my 9700 pro on Suse 9.0
Been trying for about a week now =( help please, seminewbie

fglrxinfo outputs:
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

dmesg contains these errors:
[fglrx] Maximum main memory to use for locked dma buffers: 554 MBytes.
[fglrx] module loaded - fglrx 3.2.8 [Sep 21 2003] on minor 0
mtrr: 0xd0000000,0x8000000 overlaps existing 0xd0000000,0x1000000
[fglrx:firegl_addmap] *ERROR* mtrr allocation failed (-22)
[fglrx:firegl_unlock] *ERROR* Process 2105 using kernel context 0

Last edited by aplc0r; 02-29-2004 at 11:02 PM.
 
Old 03-01-2004, 04:05 AM   #80
picard
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Rep: Reputation: 0
Mesa...

Had the same problem and could resolve it by (re)moving the MESA (Software) OpenGL library, located in:

/usr/lib/libGL.so.1.5.060000 ('some' version number). When this library and a corresponding soft-link are in place, XFRee86 uses software 3D rendering instead of the ATI hardware rendering. If you've correctly configured the XF86Config file and remove the mentioned library hardware accelleration should work! (well, works for me..)
 
Old 03-01-2004, 04:09 AM   #81
Valgar
Member
 
Registered: Feb 2004
Posts: 65

Rep: Reputation: 15
What type of motherboard you have?
It's a kt400 o a nforce or other?
It's important know the board type...
 
Old 03-01-2004, 05:17 AM   #82
picard
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Rep: Reputation: 0
motherboard

motherboard is not THAT important... enabling MTRR under Processor Features in your Kernel configuration is......
 
Old 03-01-2004, 06:05 AM   #83
Valgar
Member
 
Registered: Feb 2004
Posts: 65

Rep: Reputation: 15
If you have a kt400 is vital if you change a string in a config file,else the gfx card won't work at all.
Is important,for me it was vital.
If you want i redirect you to where i have read all this.
 
Old 03-01-2004, 06:13 AM   #84
Valgar
Member
 
Registered: Feb 2004
Posts: 65

Rep: Reputation: 15
Try changing the /lib/modules/fglrx/build_mod/agpgart_be.c ; near the line (in driver 3.2.8...i use 3.7.0 and is similar...)6073 change the "via_generic_setup },// AGP v2 "
to " via_kt400_setup },// AGP v2 ".
I tell this because i have a radeon 9700 pro that i have installed in mandrake 9.1 and in suse 9.0,all with kernel 2.4.21 .
If don't work i tell you the whole procedure.
 
Old 03-01-2004, 08:20 AM   #85
aplc0r
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Rep: Reputation: 0
I removed the mesa libs and reconfigured my XF86Config, but agpgart still won't load. I'm getting the same exact errors. These libs also were created in usr/lib libGL.a and libGLCore.so.1. My mobo is a VIA P4PB
 
Old 03-01-2004, 09:10 AM   #86
picard
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Rep: Reputation: 0
My mistake, got confused by your glxrinfo output (it shows the Mesa libs being used instead of hardware OpenGL rendering. This is obvious as you're not getting the driver loaded......)
However, you do not need an external agpgart module to be loaded. The ATI drivers should use it's own INTERNAL AGP stuff. First verify your kernel is configured with correct parameters:

Processor Type and features --->
<*> MTRR (Memory Type Range Register) support
Device Drivers --->
Character devices --->
<M> Enhanced Real Time Clock Support
...
<M> /dev/agpgart (AGP Support)
< > ALI chipset support
< > ATI chipset support
< > AMD Irongate, 761, and 762 chipset support
< > AMD Opteron/Athlon64 on-CPU GART support
<M> Intel 440LX/BX/GX, I8xx and E7x05 chipset support
< > NVIDIA nForce/nForce2 chipset support
< > SiS chipset support
< > Serverworks LE/HE chipset support
<M > VIA chipset support [*] Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)
< > 3dfx Banshee/Voodoo3+
< > 3dlabs GMX 2000
< > ATI Rage 128
< > ATI Radeon
< > Intel I810
< > Intel 830M, 845G, 852GM, 855GM, 865G
< > Matrox g200/g400
<> SiS video cards

In above example kernel-config extraction I've marked the VIA chipset support as 'M' (Loadable Module)
 
Old 03-01-2004, 09:58 AM   #87
Valgar
Member
 
Registered: Feb 2004
Posts: 65

Rep: Reputation: 15
Yes the radeon driver must use it's internal agp stuff.
but if you look at the agpgart_be.c (a file that ati driver during compilation of the driver tell various setup of chipsets...) under ALL the via chipset there's a string that specific WHAT chipset....if you look you see "via generic setup"....and it's here the error.
i have to change that "via generic setup"with my chipset name,and if you look under the string "via apollo p4x 400 (the chipset that you have)you see "via generic setup".
i have read that kernel 2.4.21 doesn't support agp v3 (agp 8x)and set under the bios to enable only 4x does't work...but changing that string to your chipset name work!
for me have worked perfectly!
i think that you must change the string
PCI_VENDOR_ID_VIA,
VIA_APOLLO_P4X400,
"Via",
"Apollo P4X400",
via_generic_setup }, // AGP v2

to something similar to:
PCI_VENDOR_ID_VIA,
VIA_APOLLO_P4X400,
"Via",
"Apollo P4X400",
via_P4X400_setup }, // AGP v2

try this.
it cost you only one reboot(i cannot guarantee you that work....for me under mandrake and suse 9 worked).
 
Old 03-01-2004, 11:30 AM   #88
picard
LQ Newbie
 
Registered: Feb 2004
Posts: 7

Rep: Reputation: 0
Yes, looks like that might do the trick. Guess it's up to aplc0r to do some code-hacking and give it a try!
 
Old 03-01-2004, 05:18 PM   #89
aplc0r
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Rep: Reputation: 0
thanks for all the help guys, but I'm still getting the same errors. I edited agpgart_be.c from this:

{ PCI_DEVICE_ID_VIA_8377_0,
PCI_VENDOR_ID_VIA,
VIA_APOLLO_KT400,
"Via",
"Apollo KT400",
via_generic_setup }, // AGP v2
{ PCI_DEVICE_ID_VIA_8754, // == PCI_DEVICE_ID_VIA_P4X333,
PCI_VENDOR_ID_VIA,
VIA_APOLLO_P4X400,
"Via",
"Apollo P4X400",
via_generic_setup }, // AGP v2

into this:

{ PCI_DEVICE_ID_VIA_8377_0,
PCI_VENDOR_ID_VIA,
VIA_APOLLO_KT400,
"Via",
"Apollo KT400",
via_KT400_setup }, // AGP v2
{ PCI_DEVICE_ID_VIA_8754, // == PCI_DEVICE_ID_VIA_P4X333,
PCI_VENDOR_ID_VIA,
VIA_APOLLO_P4X400,
"Via",
"Apollo P4X400",
via_P4X400_setup }, // AGP v2

first of all, did I do that right? Should I change every line that has "via_generic_setup"?, there's a lot of them, I only changed the ones related to the agp(above). And secondly, when I run fglrxconfig, should I answer no to "Do you want to use external AGPGart module?"

When I used Suse's kernel utility, I couldn't find all of those options under Processor Type and Features. I hope I don't have to recompile my kernel X_X

One more question(I have a lot of them, sorry) when I edit the boot.local file, should I add "/sbin/insmod agpgart" on the line with the "#" or the blank line below it?

lsmod shows that fglrx is used by 0 too....
sorry for the long posts, I just am really stressing to get this working. I've installed 3 different distros about twice each and still haven't had any luck =(

Last edited by aplc0r; 03-01-2004 at 05:20 PM.
 
Old 03-01-2004, 05:39 PM   #90
Valgar
Member
 
Registered: Feb 2004
Posts: 65

Rep: Reputation: 15
ok i try to tell you the whole procedure from a fresh install so you can see the various step.
First of all you must use the same kernel that you have the source code,so if you use kernel 2.41 you must have the source of kernel 2.41.
install the rpm using the force option (to override the mesa stuff)
the command is:
rpm -Uhi --force "archive name" (where archive name is the current ati rpm..i personally use the latest)
Now don't run fglrxconfig yet!
First check if the module fglrx is loaded ,use the command : lsmod | grep fglrx
The output should be something similar to : fglrx 160840 173
If the command shows nothing try to load it yourself with: modprobe fglrx,after this repeat the : lsmod | grep fglrx.If not something wrong happened during installation.
After that change the line in the file of the previous post;
via_generic_setup }, // AGP v2
to
via_P4X400_setup}, // AGP v2
(it should be near the line 6083 or similar...)
Save the file anbd recompile the module.
Change to the module directory of fglrx via cd /lib/modules/fglrx/build_mod and run the script make.sh via ./make.sh and pay attention to the output(witch might indicate errors) then cd../ and run ./make_install.sh from there.
If doesn't compile you have definitely problem with kernel source.
Now run the script fglrxconfig.
Respond to the answer and when it comes to "use the internal agp gart" you must choose yes!
Because you must use the internal (of the driver) agp gart (the one you change the string...) and not the one of the kernel.
now reboot or restart the graphical interface again.
If you have done it right the fglrxinfo say the correct version and glxgears run at above 3000 (must depend on the gfx card) fps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Driver in SUSE 9.3?? luthfi Linux - Newbie 1 10-15-2005 01:37 AM
How install ATI driver on SuSE 9.1 Prof fireedo Linux - Newbie 2 02-23-2005 11:46 PM
ATI Driver prob: Black screen after driver install linuxboynz Linux - Laptop and Netbook 2 10-19-2004 03:52 AM
ATI Driver problem on SuSE 9 TheOtaku Linux - Software 3 04-22-2004 05:42 PM
No Screen Found on ATI driver install in SUSE scriptures4life Linux - Hardware 2 07-20-2003 10:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration