LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-22-2007, 01:36 AM   #1
Antares_kchwa
LQ Newbie
 
Registered: Jun 2007
Distribution: Ubuntu Feisty fawn
Posts: 3

Rep: Reputation: 0
Exclamation ATI direct rendering problems xD


hi this is my first post here and i dont know what else could i do
see i have Ubuntu 7.04 installed on my HP laptop and i cant get the
direct rendering work
i already looked in google but i cant find anithing so if someone
knows plz help i tried to put all the necessary information
i think that is something wrong whit the kernell
thx


thingol@laptop:~$ lspci | grep ati
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE)

thingol@laptop:~$ uname -r
2.6.20-16-generic

thingol@laptop:~$ glxinfo | grep direct
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

thingol@laptop:~$ glxinfo | grep OpenGL
OpenGL vendor string: Mesa project: ww w. mesa3d .org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
OpenGL extensions:

II) Module fbdevhw: vendor="X.Org Foundation"
compiled for 7.2.0, module version = 0.0.2
ABI class: X.Org Video Driver, version 1.1
(WW) open /dev/fb0: No such file or directory
(WW) open /dev/fb1: No such file or directory
(WW) open /dev/fb2: No such file or directory
(WW) open /dev/fb3: No such file or directory
(WW) open /dev/fb4: No such file or directory
(WW) open /dev/fb5: No such file or directory
(WW) open /dev/fb6: No such file or directory
(WW) open /dev/fb7: No such file or directory
(EE) Unable to find a valid framebuffer device
(EE) RADEON(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
(you may have to look at the server log to see warnings)
(WW) RADEON(0): fbdevHWInit failed, not using framebuffer device




Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "radeon"
Option "VendorName" "ATI Free Driver"
BusID "PCI:1:5:0"
Option "UseFBDev" "true"
Option "EnablePageFlip" "true"
Option "ColorTiling" "true"
Option "UseInternalAGPGART" "no"
Option "OpenGLOverlay" "on"
Option "VideoOverlay" "on"
# === misc DRI settings ===
# Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
# Option "DesktopSetup" "0x00000100"
# Option "MonitorLayout" "AUTO, NONE"
# Option "IgnoreEDID" "off"
# Option "HSync2" "unspecified"
# Option "VRefresh2" "unspecified"
# Option "ScreenOverlap" "0"
EndSection
Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection
 
Old 06-22-2007, 06:44 PM   #2
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 42
Which driver did you install? Did you install using Ubuntu's package manager or did you download from the ATI/AMD Site ?
 
Old 06-23-2007, 12:54 AM   #3
Antares_kchwa
LQ Newbie
 
Registered: Jun 2007
Distribution: Ubuntu Feisty fawn
Posts: 3

Original Poster
Rep: Reputation: 0
Re:

i used the free ati driver sudo apt-get xorg-driver or something like that. but im pretty sure that is the free driver

i must say that before i had the ati linux propietary drver (fglrx)
but i removed all that used fglrx in the package manager
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon/onboard graphics Direct rendering problems sygin Linux - Hardware 3 07-25-2006 04:06 PM
ATI drivers and direct rendering.. problems deftones Slackware 20 07-18-2006 01:35 AM
Direct Rendering (ATI Radeon) xbuzz Linux - Newbie 8 06-03-2005 06:38 PM
How do i get direct rendering ATI 8500? glenn69 Linux - Newbie 0 10-07-2004 11:25 PM
ATI Radeon Direct Rendering chodviolin Linux - Hardware 0 03-27-2004 03:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration