LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ATI cards - very confused to what I need.... (https://www.linuxquestions.org/questions/linux-hardware-18/ati-cards-very-confused-to-what-i-need-399763/)

djuhl30 01-05-2006 06:06 AM

ATI cards - very confused to what I need....
 
I installed the commercial drivers for ATI.

(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xe19e5000
(II) fglrx(0): [drm] mapped SAREA 0xe19e5000 to 0x4053a000
(II) fglrx(0): [drm] framebuffer handle = 0xc0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.10.19
(II) fglrx(0): Date: Feb 9 2005
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(WW) fglrx(0): Kernel Module version does *not* match driver.
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe19e5000 at 0x4053a000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x03ff0000
(II) fglrx(0): FBMM initialized for area (0,0)-(1280,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using hardware cursor (scanline 1024)
(II) fglrx(0): Largest offscreen area available: 1280 x 7163
(**) Option "dpms"
(**) fglrx(0): DPMS enabled
(WW) fglrx(0): Option "IgnoreEDID" is not used
(WW) fglrx(0): Option "NoTV" is not used
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid Horizontal and Vertical Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
The RPM created the module... So what am I missing here?

Dave

carl0ski 01-06-2006 08:35 AM

Quote:

Originally Posted by djuhl30
I installed the commercial drivers for ATI.

(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xe19e5000
(II) fglrx(0): [drm] mapped SAREA 0xe19e5000 to 0x4053a000
(II) fglrx(0): [drm] framebuffer handle = 0xc0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.10.19
(II) fglrx(0): Date: Feb 9 2005
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(WW) fglrx(0): Kernel Module version does *not* match driver.
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe19e5000 at 0x4053a000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x03ff0000
(II) fglrx(0): FBMM initialized for area (0,0)-(1280,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1024) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using hardware cursor (scanline 1024)
(II) fglrx(0): Largest offscreen area available: 1280 x 7163
(**) Option "dpms"
(**) fglrx(0): DPMS enabled
(WW) fglrx(0): Option "IgnoreEDID" is not used
(WW) fglrx(0): Option "NoTV" is not used
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid Horizontal and Vertical Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
The RPM created the module... So what am I missing here?

Dave


i found the RPMS didnt work for me

fetch the full 50MB .bin driver file from ati instead

43r05p4c3 01-06-2006 11:38 AM

did you check you have the correct agp module? Also, do you have the kernel source installed?
If so, did you force the rpm? because for some reason, if you don't it won't work properly

For a (mostly) full ATI driver installation guide, try this site.

Hope this helps,

Steve

carl0ski 01-06-2006 11:11 PM

Quote:

Originally Posted by 43r05p4c3
did you check you have the correct agp module? Also, do you have the kernel source installed?
If so, did you force the rpm? because for some reason, if you don't it won't work properly

For a (mostly) full ATI driver installation guide, try this site.

Hope this helps,

Steve

since its for suse and redhat maybe why you need to force
i never tried that and personally im not eager to try it.'

but it is an option

UnTamed 01-07-2006 07:42 AM

Quote:

Originally Posted by carl0ski
since its for suse and redhat maybe why you need to force
i never tried that and personally im not eager to try it.'

but it is an option

--force install of the rpm is required and it's how Ati instructs you to install them if you care to read the install instructions they have on their site [...last I checked].

The reason is quite simple actually and the procedure required and totally safe.
rpm doesn't by default overwrite existing files and the driver needs to replace /usr/X11R6/lib/libGL.so.1.2 by it's own version.

...hope this will appease your fears ;)


All times are GMT -5. The time now is 05:42 AM.