LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-17-2007, 04:16 PM   #1
skipjackrc4
LQ Newbie
 
Registered: Aug 2007
Distribution: Suse
Posts: 18

Rep: Reputation: 0
ATI 3d drivers not properly working


I am using Debian and have an ATI Radeon X1650 PCIE. The card itself works, and the drivers (newest version) off of ATI's website installed fine (I can use them to get ATI Big Desktop working), but I have no acceleration. I've had it working on Ubuntu, so I know it's possible, but Debian seems to be different. I'm pretty new to Linux, so please be gentle.

fglgears (or whatever that command is) says that I'm using Mesa for OpenGL rendering, which is the problem. Shouldn't that be fglrx?

xorg.conf:


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 12-17-2007, 06:07 PM   #2
joshfoulk
LQ Newbie
 
Registered: Dec 2007
Posts: 27

Rep: Reputation: 15
Hi,

I've recently went through nearly the same thing with an ATI X1270. Did you install the driver from the .run from ATI, or did you download the drivers from Debian's repos?

I noticed that your xorg.conf was configured by aticonfig (or configati???) If you used the automated fglrx installation from repos, have you tried to do an sax2 -r?

Later,

JF

Edit: How are you trying to get the 3D acceleration working? Through Desktop Effects or something like that? How do you know it's not enabled? And what is the output of "glxinfo"?

Last edited by joshfoulk; 12-17-2007 at 06:08 PM.
 
Old 12-17-2007, 06:57 PM   #3
skipjackrc4
LQ Newbie
 
Registered: Aug 2007
Distribution: Suse
Posts: 18

Original Poster
Rep: Reputation: 0
I used the most recent .run file from ATI's site. I haven't touched the xconf file since I installed Debian, so it was made with whatever Debian defaults with. sax2 doesn't seem to exist, and a Synaptic search didn't turn up anything (is Sax2 a whole Linux-wide thing or just with SuSe, because I know they have it). I know acceleration isn't working because every graphics application that should have acceleration (games, video playback...) goes really slowly, and they shouldn't.

glxinfo:
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.2)

It's not just 3d acceleration, but graphic acceleration in general.

Thanks,
Ben
 
Old 12-18-2007, 11:12 AM   #4
joshfoulk
LQ Newbie
 
Registered: Dec 2007
Posts: 27

Rep: Reputation: 15
It's strange that sax2 doesn't exist. If I remember correctly, I used it with ubunutu, which is Debian based.

Are you trying to get Compiz-Fusion working? I know that the ATI binary drivers have issues with running Xgl for my card, I had to use AIGLX and I had to compile the drivers myself (there are guides on the net to do this).

Just to give you something to compare against for an ATI card using the binary drivers with acceleration enabled, here is my xorg.conf file:

Code:
# /.../
# SaX generated X11 config file
# Created on: 2007-12-17T16:48:48-0700.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "IgnoreABI" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "dri"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "14"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Logitech USB Receiver"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[3]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
  Option       "InputFashion" "Mouse"
  Option       "Name" "Synaptics;Touchpad"
  Option       "Protocol" "explorerps/2"
  Option       "SHMConfig" "on"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  331 207
  HorizSync    30-62
  Identifier   "Monitor[0]"
  ModelName    "SAMSUNG LCD MONITOR"
  Option       "DPMS"
  VendorName   "SEC"
  VertRefresh  43-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x800" "1024x768" "800x600" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "ATI Radeon X1200 Series (RS690 791F)"
  BusID        "1:5:0"
  Driver       "fglrx"
  Identifier   "Device[0]"
  Option       "FSAADisableGamma" "no"
  Option       "CapabilitiesEx" "0x00000000"
  Option       "CenterMode" "off"
  Option       "FSAAMSPosX3" "0.000000"
  Option       "FSAAMSPosX4" "0.000000"
  Option       "mtrr" "off"
  Option       "FSAAMSPosY1" "0.000000"
  Option       "FSAAScale" "1"
  Option       "FSAAMSPosY2" "0.000000"
  Option       "FSAAMSPosX5" "0.000000"
  Option       "ForceGenericCPU" "no"
  Option       "GammaCorrectionI" "0x00000000"
  Option       "FSAAMSPosX0" "0.000000"
  Option       "FSAAMSPosY3" "0.000000"
  Option       "FSAAMSPosY4" "0.000000"
  Option       "no_accel" "no"
  Option       "FSAACustomizeMSPos" "no"
  Option       "FSAAMSPosY5" "0.000000"
  Option       "UseFastTLS" "0"
  Option       "GammaCorrectionII" "0x00000000"
  Option       "BlockSignalsOnLock" "on"
  Option       "FSAAEnable" "no"
  Option       "VideoOverlay" "on"
  Option       "Capabilities" "0x00000000"
  Option       "no_dri" "no"
  Option       "StereoSyncEnable" "1"
  Option       "PseudoColorVisuals" "off"
  Option       "UseInternalAGPGART" "no"
  Option       "FSAAMSPosX1" "0.000000"
  Option       "Stereo" "off"
  Option       "FSAAMSPosX2" "0.000000"
  Option       "OpenGLOverlay" "off"
  Option       "FSAAMSPosY0" "0.000000"
  Option       "ScreenOverlap" "0"
  VendorName   "ATI"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  InputDevice  "Mouse[3]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "DAMAGE" "false"
EndSection
As you can see, it was setup by sax2. You might try this:

dpkg-reconfigure xserver-conf

(as root, probably)

Just found it on the net...

JF

Note: Simply installing the ATI binaries from a repository isn't enough. You have to ensure that your x server knows not only what driver to use ("fglrx"), but it needs to know 'how' to use the driver. You could have the best graphics card possible and still not get any type of acceleration with a broken (or nearly broken) xorg.conf file.

Last edited by joshfoulk; 12-18-2007 at 11:15 AM.
 
Old 12-18-2007, 11:50 AM   #5
joel2001k
Member
 
Registered: Mar 2007
Distribution: GNU/Linux debian unstable main
Posts: 94

Rep: Reputation: 17
gnome dri configuration tool

as you are using debian or ubuntu you're probably running gnome there's a application called `driconf`

I'm having an ati radeon too after default setup with hw acceleration didn't work I started driconf afterwards everything was nice

I'm using debian main unstable
I would use Xorg's driver ... (I'm to lazy to read ati's licence)

so do
# apt-get install driconf
$ driconf
 
Old 12-18-2007, 12:58 PM   #6
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
There is no Sax in Debian.Sax is originally a Suse configuration tool that was open sourced and might be used by whoever but not Debian.

Go to /var/log/xorg.log and paste the lines that look like this with (WW) in front:

(WW) fglrx(0): * no 3D acceleration available *

Especially the ones that say anything like fglrx or dri in the warning.
 
Old 12-18-2007, 09:10 PM   #7
skipjackrc4
LQ Newbie
 
Registered: Aug 2007
Distribution: Suse
Posts: 18

Original Poster
Rep: Reputation: 0
I installed driconf and it says

"Xlib: extension "XFree86-DRI" missing on display ":0.0".
Screen "0" is not direct rendering capable."

There didn't seem to be anything that I could do with it within the program (I use KDE, not gnome but that shoudln't matter).

in /var/log/Xorg.0.log, it says

"(II) Primary Device is: PCI 05:00:0
(II) ATI Proprietary Linux Driver Version Identifier:8.43.2
(II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.433
(II) ATI Proprietary Linux Driver Build Date: Nov 9 2007 21:19:50
(--) Assigning device section with no busID to primary device
(WW) fglrx: No matching Device section for instance (BusID PCI:5:0:1) found"

and

"(WW) fglrx(0): No DRM connection for driver fglrx."
and

"(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(WW) fglrx(0): could not detect X server version (query_status=-3)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *"

and

"(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used" (does that actually matter?)

Seems like there's a few problems there, but I don't know how to fix it. Hopefully someone here does.

Thansk,
Ben
 
Old 12-20-2007, 11:22 AM   #8
joel2001k
Member
 
Registered: Mar 2007
Distribution: GNU/Linux debian unstable main
Posts: 94

Rep: Reputation: 17
re: driconf says screen not direct rendering capable

perhaps `driconf` doesn't support the proprietary ati driver try to uninstall ati's xserver and install the official xserver-xorg

or you should load the necessary kernel driver

# echo "radeonfb lcd progear_bl drm radeon intel-agp radeon-agp" | xargs modprobe

at my opinion use the official xserver-xorg, you may have some advantages that ati's xserver doesn't give you, hey you can also load them manually with `modconf` a nice ncurses application

what you can also try changing boolean value of use kernel framebuffer device interface by

# dpkg-reconfigure xserver-xorg

do you know `radeontool`

# radeontool light off && sleep 3s && radeontool light on

I'm using a self compiled kernel without debian patches (because of bootsplash), I'm not sure if that's the reason but I had to change /etc/acpi/lid.sh that screen turns off light when closing, some notebooks may overheat if lidswitch doesn't do anything

do you know these websites: fsf.org gnu.org

Last edited by joel2001k; 12-20-2007 at 11:35 AM.
 
Old 12-31-2007, 07:45 AM   #9
Lancelot1
Member
 
Registered: Dec 2007
Location: Amsterdam
Distribution: (K)Ubuntu
Posts: 102

Rep: Reputation: 15
Have you tried methode 2 on this site?

http://wiki.cchtml.com/index.php/Ubu...allation_Guide

I had the same problem you have with my kubuntu installation using the ./run methode. Methode 2 worked better for me and it also makes my 3d work fine. It's abit more work but it ensures that all the different parts are installed properly and also configed goed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI drivers not working for 3d pula0r Linux - Hardware 1 06-28-2005 01:26 PM
ATI drivers not working Gero Linux - Hardware 2 04-16-2005 10:08 AM
ATI drivers worx properly, cannot adjust brightness xelt Linux - General 0 04-14-2005 05:24 PM
ATI All in Wonder Rage Pro not working (properly) in FC2 dietrichmd Linux - Hardware 0 10-21-2004 04:11 PM
updated Xfree86, can't install ATI drivers properly. Junior41180 Mandriva 0 09-07-2004 06:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration