-   Linux - Hardware (
-   -   Atheros wireless in openSUSE 11.4 (

Toonses82 05-28-2011 03:29 PM

Atheros wireless in openSUSE 11.4
I recently set up a friend with openSUSE 11.3 on his HP G60 laptop since he was having trouble with Windows Vista. Everything was going great for a few months until suddenly he lost wlan capabilities. Figuring it was software related and an update couldn't kill anybody, I just installed openSUSE 11.4 32-bit for him. However, the wireless still isn't working.

Here's a piece of the output from /sbin/lspci:

02:00.0 Network Controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
uname -r gives me:
When I go to YaST2--> Hardware--> Hardware Information, under Wireless LAN, I'm able to see the following information:

Device Name: wlan0
Device: AR928X Wireless Network Adapter (PCI-Express)
Driver: ath9k
Kernel Driver: ath9k

Obviously that's abbreviated, but that should be the relevant information.

It seems as though the hardware is detected and the correct drivers are installed, but when I use NetworkManager or ifup, neither is able to give me a list of Wifi access points. It's just a blank list, like it needs a driver or something.

Given that this just randomly stopped working prior to the software upgrade, is it possible that the hardware itself is broken? Is there a way to test this? Am I missing something obvious?

Peacedog 05-28-2011 10:27 PM

Hi Toonses82, Have you tried toggling the wifi switch or keystroke? Is the wifi led on?

Good luck. ;-)

Toonses82 05-30-2011 01:27 PM

1 Attachment(s)
This HP G60 has a wifi button next to the power switch just above the keyboard. Pressing the button does nothing; it remains red. (See attachement)

It's my understanding that, with the new kernel, Atheros chipsets should work out of the box. That's why I think maybe something's wrong with the hardware. Besides installing Windows, is there any way to test the hardware?

Peacedog 05-30-2011 04:45 PM

Try issuing the following as root.


# rfkill unblock all
If you don't have it installed, install it and try it. The other option would be checking BIOS to see if it's disabled there. You could also update the BIOS.

Good luck. ;-)

Toonses82 06-01-2011 01:27 AM


Originally Posted by Peacedog (Post 4371362)
Try issuing the following as root.


# rfkill unblock all

That worked! I had to log out and in again, but the wifi button turned blue and I could scan the access points from NetworkManager.

One thing to note, I was checking functionality switching between ifup and NetworkManager, but that broke it again. What ultimately got it working was to run the rfkill, log out and in, and stick with NetworkManger. It doesn't seem to matter how you choose to manage your network connections (ifup or NetworkManager), it only matters that you pick one and stick with it. Otherwise you have to do the rfkill again.


Peacedog 06-01-2011 07:57 PM

Glad you got it sorted!

Good luck. ;-)

mdrums 07-24-2011 02:50 PM

hi, toonses82

my name is Márcio,i born in brazil...
dude, you is a save my day; use the distro opensuse in the
laptop lenovo g460, i don't coud install the wlan...i was giving up when i found this forum...
gave me all right, the wlan worked instantly, thanks!!!!

bye and thanks for the instructions!

All times are GMT -5. The time now is 08:42 AM.