-   Linux - Hardware (
-   -   Atheros AR8112 ethernet driver? - ARRRGH! (

linuxbird 04-09-2010 10:53 AM

Atheros AR8112 ethernet driver? - ARRRGH!
I have a PCCHIPS P47G motherboard, with a Atheros AR8112 ethernet interface (took me a while to even find that out!). The problem is that I can not find a driver for that interface!

I've Googled around for drivers and come up with nothing.

Anyone have any suggestions or ideas?

Is there another driver which works?

Any additional suggestions as to where to look?


linuxbird 04-10-2010 03:59 AM

I tried doing a fresh install onto a spare partition. I was running Slackware 12.2, and tried 13.0, just to see what would happen. It turns out that the atl2 driver, which is on Slack 13.0 works with this interface.

Based upon my reading, and googling, I thought the L2 was specific to gigabit interfaces, and would not be backward compatible. No where is the AR8112 interface name associated with that driver. Nevertheless, it appears to work.

I haven't tried moving backwards, as the drive with 12.2 is failing, and needs to go back to it's creator for replacement. I'll finish the install of 13.0, and move forwards.

Meanwhile, anyone looking for Atheros LAN interface drivers, should consider the atl2 driver as a possible solution. It is also call the l2 as in "L2" driver. There is also a l1 (L1) and some other drivers like atl1c, which I thought might be the right driver for the AR8112 interface. BTW, this was on a PCCHIPS P47G motherboard, which is a low end motherboard. They were cheap ($27) and I tend to by low end motherboards, because for many of my applications they represent a good value.

I hope this helps someone downstream.

All times are GMT -5. The time now is 02:46 AM.