-   Linux - Hardware (
-   -   Asus P4C800 / Intel i875, AGP and stuff (

Mirar 05-28-2003 10:07 AM

Asus P4C800 / Intel i875, AGP and stuff

I just found this forum, in search of answers. I didn't find the ones I were looking for, though, but this place seems nice enough.

Yesterday, I installed a P4 on an Asus P4C800 motherboard, it's one of the i875p motherboards. I have two major issues with it.
If you can help with just anything, I'm very grateful.

1) agpgart; the 2.4.20 doesn't detect the i875. The 2.5.6x+ detects the i875 and seems to run it the same way as an i845, from what I can see. So I patched my 2.4.20 the same way.
But my Radeon 9700 pro either hangs after a little while, showing a white hardware-sprite looking square in the top left corner, or it crashes completely and turns off the monitor signal.
Has anyone got the i875 AGP running? With AGP8x? With an ATI Radeon 9700? Or know what I should do to get it to work? Or heard anything about it?
The ATI drivers doesn't compile under 2.5, and what I know there isn't any other drivers for the 9700 (r300). (Tell me if I'm wrong.)

2) the secondary ide/raid controller, an Promise PDC20378. Linux completely ignores it. I haven't seen any kernel with PDC203xx or PDC20x78 support. Anyone heard anything about that?
I'd like to use the two disks I want to put on it.

The P4C800/i875 has SATA controllers too, but I don't need those, so I don't have to ask anything about them not working. :cool:


PcClone 05-30-2003 05:30 AM

I also have a
P4C800 Asus M/b
P4 2.4(ht,fsb800)
Ati 9700pro 128mb
1gig 400ddr

but with a seagate barrucda 120g sata150 hd

I`am trying to install mandrake 9.1,in which i`ve read that it`s supposed to support the sata h/d.

But I can`t get mandrake to find the hd.

the msg is "no valid device found".

If i can get past this then i might be able to help you with your problem.

Mirar 05-30-2003 11:22 AM

My complete setup is

Asus P4C800 motherboard
P4c 2.6GHz/800MHz FSB
Hercules 3d Prophet 9700 pro (same same, just more heatsinks)
2Gb "DDR320" (3x512Mb PC2700 + 512Mb PC3200)
main p-ata 0 m: IBM 180GXP 120Gb
main p-ata 0 s: IBM 180GXP 120Gb
main p-ata 1 m: Plextor 16x CD-R
main p-ata 1 s: Sony CD player
promise p-ata m: IBM 120GXP 80Gb
promise p-ata s: Seagate Barracuda IV 80Gb
main and promise s-ata: nothing
The CPU and the Radeon is watercooled. I also have a waterblock for the chipset in the watercooling system, but it seemed impossible to put it on the i875 without glueing it on, no holes in the mobo... :(

I read something about the SATA and i875, I wonder if it wasn't in the changelog for 2.5.69 or 2.5.70. Check the linux-kernel mailing list. You might need to run a beta kernel. :( (I have no idea how to do that in Mandrake 9.1.) It might be there in the newest patches for 2.4.21 too.

I dual-boot Gentoo Linux and Windows (for games). :cool:


pcdoctor@infine 06-02-2003 02:31 PM

install RH on Asus p4C800-DX
I'm having similar trouble and need to know how just to get the OS installed. I've tried several versions of Linux on the Asus p4C800-dx. RH 8.0 and 9.0 on both cdrom and DVD. I've also tried SUSE 8.0 and 8.1. With RH, installations begins with booting to the cd noramlly, then the normal country and language questions then after that it asks for the location of the linux images. This is where things stop. It gives the option to pick a cdrom drive or a hdd if you have one setup with a readable partition but it claims no images exist anywhere, regardless of what you copied to the hdd or put in the cdrom or dvd.

system specs are as follows:

p4 3ghz/800
asus p4C800 deluxe
2x512mb/400mhx Samsung DDR mem
MSI G-Force Ti4800 128mb DDR
open 52x24x52x cdrw
toshiba 16x dvdrom
2x80gb 7200 rpm wd hdd (no raid, win2k on 1st hdd)

Mirar 06-02-2003 02:37 PM

pcdoctor: is the hdd's on sata or normal (p) ata?

I haven't tried installing the system, but I had no problem getting things to at least boot using Gentoo, but my disks are on old style p-ata, not s-ata.

Oh, and an update: the PDC20378 is also on the FastTrak S150 TX2plus PCI card, I understand. There doesn't seem to be a Linux driver for that either, yet (not even on Promise' site).

pcdoctor@infine 06-02-2003 03:39 PM

installing rh on p4c800
The hdds are regular 80gb western digital 7200rpm hdd. I have tried them on the regular ata and on the promise 20378 contrller. Asus has a redhat and suse driver for the promise controller on there website. with win2k its easy, hit f6 at boot and then load the drivers, but linux? I dunno.

Mirar 06-02-2003 03:50 PM

Where'd you find the drivers? I looked and looked...

I think you need both the disk to install on and the CD on the ICH5 controller (as opposite to the Promise controller) to install. Wanna try Gentoo? It's a bit rough to install, but then it's very nice and configurable.

pcdoctor@infine 06-02-2003 04:23 PM

found the drivers on asus' website

good boards, lousy website, although it's improved over previous versions.

As for Gentoo, I don't know what that is but I'm willing to try it if it means getting linux on this system. I have to do this for a customer that has an upcoming linux class that he has to teach but he doesn't know how to install it.

If I have the hdds on the regular ide during the install it gives me an option to get the linux images from a hdd but of course it doesn't find any there even if I copied all of the cds to the hdd. If I put the hdds on raid controller then it only gives the option to get the linux images from the cdrom, and again doesn't find any there. If it can't find the lousy cdrom then how does it manage to boot to it?

Mirar 06-02-2003 04:37 PM

Hmm, looks great but needs odd 2.4.18 kernels (old RH or Suse, appearantly). :/

Gentoo is a bit special, because it compiles everything and downloads everything over the network. Being in a school with good connection or on broadband this is usually not a problem. You will probably want to install a "stage 3" tarball with the system (some things precompiled, like the compiler). But read about it around There's also an IRC channel (of course) with generally helpful people.

You can have four things on the ICH5 controller, two connectors with two items each. That leaves a lot of room for CD's and IDE disks.
Two disks and a CD player shouldn't be a problem. I can't see why RH or Suse wouldn't install...

Only if you want to use the Promise raid parts or if you have more then 4 items (I have 4 disks and 2 CD-ish units) you need to use the Promise.

rlculver 06-03-2003 12:44 PM

I am thinking of getting one of these new Intel 875P boards....

Shall I hold on for the linux support to get a bit better??????

Mirar 06-03-2003 02:36 PM

Just get one and help us straighten out the issues, will you? :D

If you can wait with getting a new computer for a month or two until the support gets in 2.4.x, I think I'd recommend that right now. :(

Or if you don't need more then the VESA video driver (for instance a console-less server) and you don't need the Promise controller.

alejandro 06-03-2003 03:08 PM


Originally posted by Mirar
/Mirar [/B]
you are crazy man.... but this website rules!!

Mirar 06-03-2003 03:18 PM

Well, it is almost totally silent. :D

Mark Bilk 06-06-2003 09:57 PM

Asus P4C800 Linux Drivers
There are source code (tar file) Linux drivers for the
P4C800 sound, LAN, and Promise ATA controllers, in case
you folks haven't found them yet. Go to, find the P4C800, and click on
"Download" on the upper left area of the page. In the
resulting page, click on the "All" tab, then choose Linux
in the "OtherOS" list. You'll get a table showing the
three drivers.

Using the Opera browser, I had to download each one twice,
as the first attempt yielded a small text file or something.
But eventually you get a zipped tarfile of the specified

The Promise 20378 driver will hopefully make the kernel
recognize the chip. The bit about the kernel not dealing
with the i875 chip is scary.

I might want to get a P4C800 and run SuSE 8.2 on it.
If anyone gets that or any other version of Linux running
well on this motherboard, I'd appreciate knowing about it.


Mark S Bilk

Mirar 06-07-2003 02:13 AM

I can't find any tarballs... :(
I see three zip files,, sound driver, 3com gigabit driver, promise driver

I haven't checked the other two, but the Promise driver is binary only (.o kernel module files for RH 7.3, 8.0 and Suse 8.0, 8.1). Those doesn't exactly fit a kernel new enough to support the i875 AGP... :(

Did you find driver source, or a semi-source driver (like the ones on the promise site, with a .o object file and source glue to link it with the kernel)? Please send it to me...

All times are GMT -5. The time now is 07:06 AM.