LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 07-19-2013, 04:17 AM   #1
dowakeen
LQ Newbie
 
Registered: Apr 2013
Posts: 14

Rep: Reputation: Disabled
Asus nx1101 driver issue


Hi, I have a Ubunutu fileserver that runs Ubuntu server 13.04 and kernel 3.8.0-23-generic. I have a problem that my NX1101 network card wont show up as a Eth0/1. When i do "ifconfid -a" it only shows up my eth0(onboard 100mbps ethernet) and lo. BUt when i do "lspci -v" this shows up:


00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
Subsystem: Realtek Semiconductor Co., Ltd. RTL8169/8110 Family PCI Gigabit Ethernet NIC
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 10
I/O ports at e000 [size=256]
Memory at e3012000 (32-bit, non-prefetchable) [size=256]
[virtual] Expansion ROM at 40000000 [disabled] [size=64K]
Capabilities: <access denied>



--no driver
and this is my eth0:

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
Subsystem: Micro-Star International Co., Ltd. Device 7142
Flags: bus master, medium devsel, latency 32, IRQ 23
I/O ports at ed00 [size=256]
Memory at e3011000 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: via-rhine


--if any1 could help me I would be very thankful
 
Old 07-23-2013, 10:51 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
The RTL8169 should run on any distro out of the box. Have you looked for error messages in the logs and dmesg?
 
Old 07-23-2013, 10:53 AM   #3
dowakeen
LQ Newbie
 
Registered: Apr 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
no, i havent. Can you work me trough?
 
Old 07-23-2013, 10:57 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
Open a terminal, type
Code:
sudo dmesg|less
and press Enter. Look for errors regarding the network in the log that shows up and post them here.
 
Old 07-23-2013, 11:58 AM   #5
dowakeen
LQ Newbie
 
Registered: Apr 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.8.0-23-generic (buildd@aatxe) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) ) #34-Ubuntu SMP Wed May 29 20:24:54 UTC 2013 (Ubuntu 3.8.0-23.34-generic 3.8.11)
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] NSC Geode by NSC
[ 0.000000] Cyrix CyrixInstead
[ 0.000000] Centaur CentaurHauls
[ 0.000000] Transmeta GenuineTMx86
[ 0.000000] Transmeta TransmetaCPU
[ 0.000000] UMC UMC UMC UMC
[ 0.000000] e820: BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009efff] usable
[ 0.000000] BIOS-e820: [mem 0x000000000009f000-0x000000000009ffff] reserved
[ 0.000000] BIOS-e820: [mem 0x00000000000f0000-0x00000000000fffff] reserved
[ 0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000003ffeffff] usable
[ 0.000000] BIOS-e820: [mem 0x000000003fff0000-0x000000003fff2fff] ACPI NVS
[ 0.000000] BIOS-e820: [mem 0x000000003fff3000-0x000000003fffffff] ACPI data
[ 0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
[ 0.000000] BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
[ 0.000000] BIOS-e820: [mem 0x00000000ffff0000-0x00000000ffffffff] reserved
[ 0.000000] NX (Execute Disable) protection: active
[ 0.000000] SMBIOS 2.3 present.
[ 0.000000] DMI: MICRO-STAR INTERNATIONAL CO., LTD MS-7142/MS-7142, BIOS 6.00 PG 06/27/2006
[ 0.000000] e820: update [mem 0x00000000-0x0000ffff] usable ==> reserved
[ 0.000000] e820: remove [mem 0x000a0000-0x000fffff] usable
[ 0.000000] e820: last_pfn = 0x3fff0 max_arch_pfn = 0x1000000
[ 0.000000] MTRR default type: uncachable
[ 0.000000] MTRR fixed ranges enabled:
[ 0.000000] 00000-9FFFF write-back
[ 0.000000] A0000-BFFFF uncachable
[ 0.000000] C0000-C7FFF write-protect
[ 0.000000] C8000-CFFFF uncachable
[ 0.000000] D0000-D7FFF write-back
[ 0.000000] D8000-FFFFF uncachable
[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 0000000000 mask FFC0000000 write-back
[ 0.000000] 1 base 0080000000 mask FFC0000000 write-combining
[ 0.000000] 2 disabled
[ 0.000000] 3 disabled
[ 0.000000] 4 disabled
[ 0.000000] 5 disabled
[ 0.000000] 6 disabled
[ 0.000000] 7 disabled
[ 0.000000] x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
[ 0.000000] found SMP MP-table at [mem 0x000f4e30-0x000f4e3f] mapped at [c00f4e30]
[ 0.000000] initial memory mapped: [mem 0x00000000-0x01ffffff]
[ 0.000000] Base memory trampoline at [c009b000] 9b000 size 16384
[ 0.000000] init_memory_mapping: [mem 0x00000000-0x37bfdfff]
[ 0.000000] [mem 0x00000000-0x001fffff] page 4k
[ 0.000000] [mem 0x00200000-0x379fffff] page 2M
[ 0.000000] [mem 0x37a00000-0x37bfdfff] page 4k
[ 0.000000] kernel direct mapping tables up to 0x37bfdfff @ [mem 0x01ffa000-0x01ffffff]
[ 0.000000] RAMDISK: [mem 0x36040000-0x37017fff]
[ 0.000000] ACPI: RSDP 000f8ca0 00014 (v00 VIAK8M)
[ 0.000000] ACPI: RSDT 3fff3040 0002C (v01 VIAK8M AWRDACPI 42302E31 AWRD 00000000)
[ 0.000000] ACPI: FACP 3fff30c0 00074 (v01 VIAK8M AWRDACPI 42302E31 AWRD 00000000)
:
 
Old 07-23-2013, 12:12 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
Nothing in that excerpt of the log is related to the network or an error. Also, please use code-tags to post output of commands.
 
Old 07-24-2013, 02:17 AM   #7
dowakeen
LQ Newbie
 
Registered: Apr 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
Frustrated

then what to do now?
 
Old 07-24-2013, 06:03 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,880
Blog Entries: 2

Rep: Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805Reputation: 3805
Have you looked in the complete output errors? What you posted was only a small excerpt of it.
 
Old 07-30-2013, 07:20 AM   #9
dowakeen
LQ Newbie
 
Registered: Apr 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
fixed - sort of

I got tired of trying to fix the card.. so i put it in another server that is not set up and reinstalled ubuntu 12.04 and it detected the card and it works completly fine now but smb is still transfering at speeds max 11 mbps... so it sounds that smb is running at just 100mbps... but i checked if the card was setup at 1000mbps and it is... anyone have any idea of why im getting so low speeds?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus nx1101 driver issue dowakeen Linux - Networking 1 07-19-2013 04:25 AM
Asus Eee PC 1000 Netinstall Issue jettwa2001 Linux - Hardware 6 04-10-2009 08:18 AM
Help solve driver issue.RHEL5.-ASUS MCP73 NVIDIA GeForce 7050/nForce 610i motherboard vinodsuresh Linux - Newbie 1 10-28-2008 05:23 AM
Troubles compiling Asus NX1101 driver (Gigabit Network Adapter) on Debian Etch whizz Linux - Hardware 2 05-01-2008 12:03 PM
Audio driver for ASUS board and HP 1150 Laser PRinter Driver ccatindia Linux - Hardware 1 05-11-2004 03:20 AM


All times are GMT -5. The time now is 11:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration