LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-25-2005, 01:11 AM   #1
pkacholia
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
Unable to load my ethernet card onto eth0 or eth1


Im a newbie so forgive me if the following question is stupid. I built a computer with an Asus A8ve Deluxe mobo, AMD64 3000+ and just installed FC4 on it.

I originally had the kernel that came default with FC4 , which did not recognize my on board ethernet card (Marvell 88E8053 chipset).
I did a little reading on the internet, and upgraded my kernel to 2.6.13.-1.1532_FC4.

I did this cuz from what i read , i needed the skge driver as sk98lin would not work.
on booting into linux again i did :

# cd /sbin
# ./modprobe skge

when i typed ./lsmod i could see the skge driver at the top of the list, however my ethernet card was still not configured on eth0.

When i looked at the hardware profile of my computer in GUI mode, under the PCI section it showed the card correctly. (correct chipset etc.)

However i cannot load it onto eth0 or eth1 so i cant use it.

ifconfig says that the required hardware could not be found on eth0.

What am i doing wrong? i feel i must be one step away from something but am not sure what to do.

Thanks in advance

P.S when i type:

./lspci | grep Ethernet

i get the following response

00:07.0 Ethernet controller: Marvell Technology Group Ltd. 88W8310 and 88W8000G [Libertas] 802.11g client chipset (rev 07)
05:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 Gigabit Ethernet Controller (rev 15)

Last edited by pkacholia; 10-25-2005 at 02:09 AM.
 
Old 12-03-2005, 01:42 PM   #2
JonnerR
LQ Newbie
 
Registered: Dec 2005
Posts: 22

Rep: Reputation: 17
You need a newer driver

It's not a stupid question; check out this Gentoo Wiki article for the details. I used the ebuild on my Gentoo system, but you can probably get to work with the installer or kernel patch.

Last edited by JonnerR; 12-03-2005 at 01:47 PM. Reason: adding URL brain-damaged forum setup wouldn't allow earlier
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
COntinued ASUS A7N8X-DLX/SATA Install Problems kpfeif Debian 4 09-15-2005 02:48 PM
Installing FreeBSD 5.3 on ASUS A7N8X Dlx (Sil 3112A) Nemesis001 *BSD 3 04-14-2005 05:48 PM
Network problem on Suse 9.1 (mobo Asus P4C800 dlx with 3com 940 giageo Linux - Newbie 2 06-29-2004 02:50 PM
Asus P4c800-E dLx and Suse 8.2 in Raid setup ierax Linux - Distributions 0 08-31-2003 07:52 AM
ASUS A7N8X onboard ethernet Geoff Bickford Slackware 5 03-11-2003 03:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration