-   Linux - Hardware (
-   -   Asus A7N8X - Lan problem (

Kdiver58 05-20-2003 08:17 PM

Asus A7N8X - Lan problem
I have a new system and I can't get Linux to use the onboard Lan.

Asus A7N8X not the deluxe
Amd 2500+ Barton
1 gig Samsung pc3200
40 and 80 gig hard drive

I have tried Redhat 9.0 and Mandrake 9.1 I have downloaded and installed the Nvidia drivers and if I try to install them again it says " already installed" . One of the strong points of Linux in the past has been the ease with which it connected to the internet and to my Lan. I have Linux running on my Amd- k6-2 450 and it found and connected without me doing anything. I'm sure I'm going to have to go in and change some settings . I hate booting windoze to get on the net to fix Linux problem. Thanks K:Pengy:

finegan 05-21-2003 02:39 PM

The important part is what's the ethernet controller, it'll be listed under:




Kdiver58 05-22-2003 03:36 AM

Unrelated question . I noticed you are in Atlanta
If I wanted to take a few classes on Linux to
get myself further along where would you recommend
I take them ? I just do better when someone shows
me what to do to get started . I keep jumping from
RH 7.2 , 9.0 and Mandrake 9.1 but what I really
need to do is get the command line stuff down .

finegan 05-22-2003 02:48 PM

Classes? wow, the only ones really available locally are the RHCE classes, they're offered at that CompUSA instruction center last I checked, down by Lennox mall, although RH themselves would have better coverage of that. Also there's an instruction center out at Monarch Computers in Tucker. However, honestly if you were to pay for instruction and want it to be on Unix, and I assume this is to get a better resume of sorts, Solaris man, all the way. The best Linux Cert out there, the LPI, doesn't really come with instruction leading up to the cert... its a little weird.

Really though, the O'Reilly guide by Matt Welsch, Running Linux, about 4 or 5 geek friends with a lot of patience, a good irc channel, and at least 2 extra machines that can be in various states of disregard. Also, a couple months down the line, check into building an LFS, there's pretty much no faster way to really learn how a basic Linux system is constructed.



Kdiver58 05-22-2003 07:40 PM

When I type /sbin/lspci/ I get the reply no such directory .

I have 3 computers well 5 if you include my laptop and my
wife and sonís computer that I keep going.

#1 newest and the one that is killing me .
Amd 2500+ Barton core 512 L2 cache
Asus A7N8X motherboard
I have a swap bay in it and have XP on one drive and at this
time Mandrake 9.1 on the other. This is the one I canít get the
LAN to work on. This is attached to the KVM switch, After
looking at the farm ! I think you need a KVM switch.

Amd K6-2 450
Asus P5A motherboard
I have Redhat 9.0 and NT 4.0 on one 40 gig drive .
everything works on this computer and it is also
connected to the KVM switch. This is the one I
use to post on the Internet or surf the Internet
when Iím trying to fix a problem with the other computer

Pentium Pro 200
Super Micro motherboard
5 gig hard drive
Running Linux Redhat 9.0 right now.
This was my old computer that was sitting around for a year and a halfthat started that little voice on my head " hey you donít know anything about Linux why donít you set me up as a Linux box"
Translation : (not enough of your hair is gray or has been pulled out)
Iím thinking of setting this one up as a Linux box (text) to help me
with Linux command line . This computer works just fine but is not
in use any more after I bought the 2500+ because I donít have a
3 way KVM (yet)

None of my geek friends are into Linux and Iím just doing a poor
job of learning on my own. I was looking at way to get me over
the hump with a few classes. I just do better when someone shows me what to do. I'm an old fart and need to be pointed in the right direction first.

finegan 05-22-2003 07:49 PM

Funny you mention that, I just got a KVM, and then got an unholy amount of flak for using one. Among the uber-geek circle if you can't ssh in, you apparently should hang your head in shame as you carry in a monitor and a keyboard for the machine. I just like having 24 ttys on hand. I got a really, I mean really cheap 4-port that would perform like hell if I were running X on any of these kids.

Mandrake changed the name of lspci, its like drakepci or something equally as silly. Really, they have to stop marking their territory by peeing on things like this.

cat /proc/pci

That'll dump the reading right off of the board, just the first line of whatever "Ethernet Controller" is will hammer it out, my suspicion is that its one of the new Broadcom 443x cards that's been appearing a lot lately.



Kdiver58 05-22-2003 11:05 PM

ssh in ?
24 ttys ?

you lost me :confused:

finegan 05-24-2003 07:35 PM

ttys? Terminals, dude, next time you're at your machine, log into a Konsole, xterm, etc. and hit:

init 3

RedHat, on install, calls it console mode, the weenies.

That's normal multi-user mode, where all of the services, mail, apache, whatever are running, but no X-windows. Alt+F1, ALT+F2... F6 are the ttys, the typical arrangement with every distro (about the only thing they agree on), is 6 with X on the 7th. While in X you can get to one with ALT+CTRL+F1 and then back again with ALT+F7.

ssh, secure shell, remote command line access, the encrypted replacement for telnet. Honestly man, "Running Linux", beats the heck out of sitting in a classroom and getting information at the rate necessary for the slowest person there to keep up.



TazLinux 05-29-2003 03:46 PM


I have the same problem with my board!

A7N8X non delux and I cant get my lan to configure.

I just want a linux distro that will configure all of it on installation.

Any ideas?

Kdiver58 05-29-2003 04:20 PM

None of them will do it on install , well none I've tried .
Load RH 9.0 as best as I can tell they have a RPM that will get the onboard stuff to work.

the latest RPM for RH is there .

good luck'll need it:rolleyes:

TazLinux 05-29-2003 04:29 PM

Did you ever get your stuff working?

TazLinux 05-29-2003 04:34 PM

Hey Kdiver,

How about trying a new nic?

Im going to try a few, if they dont work I can always return them.

TazLinux 05-29-2003 04:47 PM

Can Redhat 9 read nfts and also did it config the sound on the board ok?

Kdiver58 05-29-2003 11:28 PM

yes I did
You could disable the onboard LAN and add a NIC if you wished. The sound worked just fine once I installed the rpm. I just added different video card and now I have trouble again ... I just couldn't leave well enough alone :p
This is by far the most work I have had to do with Linux, getting the LAN to work, 99% of the time is just sets everything up. Linux cannot see NTFS drives.

TazLinux 05-29-2003 11:30 PM

Oh yes, Mandrake 9.0 and 9.1 can read ntfs drives and my computer is proof of it.

I did disable the onboard lan, and I have tried to add 2 nics and no prevail.

I guess I am just asking for too much/.

All times are GMT -5. The time now is 08:52 PM.