-   Linux - Hardware (
-   -   ASUS A7N8X install problems on some distros? (

Trucido 12-13-2003 08:48 PM

ASUS A7N8X install problems on some distros?
installation of red hat, Suse, Debian, and slackware all freeze or fail, usually with this message, or a similiar message

VFS: Cannot open root device " or 00:00
Please append a correct "root=" boot option
Kernel Panic: VFS: Unable to mount root fs on 00:00

this was a emssage from red hat, but suse gave me this error also...
only thign i can think of is my hardware. well this is what i have:

AMD Athlon xp 2500+ @ 2.1Ghz
Asus A7N8X Deluxe
ATI Radeon 7000 VE
Maxtor 60 gig 7200rpm IDE drive

i have no clue whats wrong, i have searched on the net, but with no avail.
However Mandrake 9.2 installs fine... problem is, mandrake is giving me a lot of problems... such as "xmessage" not found.. and various other dependency problems.

I dunno what to do. i'd appreciate all the help, thanks

Skyline 12-13-2003 09:16 PM

Does this error message appear after you've installed the distro, and you're on your 1st boot-up or when you're initially booting from the install cd-rom?

Trucido 12-13-2003 09:19 PM

After i select what kind of instal i want, it starts loading the kernel and all, and it justs tops at that message, and i have no choice but to press the reboot button.

Skyline 12-13-2003 09:33 PM

Do Text installs work?

Trucido 12-13-2003 09:38 PM

nope, it still tries to load the kernel, which fails with that kernel panic :(

Skyline 12-13-2003 09:44 PM

There might be something of use in some of these threads?

Trucido 12-13-2003 10:20 PM

didn't see anything there :( i don't wanna give up on Linux... but i dunno what to do.

Trucido 12-13-2003 10:21 PM

unless you saw somethign i didn't see, that link brought me to somethign that said "search results" and then continued with some other threads

tricky_linux 12-27-2003 07:16 PM

try update your bios. i am using the exactly motherboard you are using right now and everything it's fine. never had a problem installing it. try disable SATA and change your maxtor driver to first channel master boot.

Trucido 12-27-2003 07:18 PM

ahh, i did try updating my bios, but i hadn't done any of the other things you mentioned. thanks for the help, i'll try it sometime :)

lee_matheson 12-28-2003 05:33 AM

SuSE-8.2 works for me
I also have the same A7N8X Deluxe motherboard, and the install worked for me. I had to install in text mode, and configure the grahics at the end of the install. Then I installed the nVidia driver (previously dowloaded from their web site):

That was needed to get the nVidia LAN working.

I did have unresolvable problems when I installed the rpm from SuSE (via Yast) with the revised kernel k_athlon_2.4.20-101 "update". I ended up re-installing to solve that. I believe that revised kernel "tweak" is incompatible with the current nVidia drivers (or I screwed up some how - possible as I am very much a newbie when it comes to Linux and SuSE).

I did note that SuSE-9.0 demo worked very well with the A7N8X deluxe motherboard, and a text install is likely NOT necessary with that SuSE distribution version.

Crashed_Again 12-28-2003 05:53 AM

Just to piggy back on this thread, I also use the A7N8X motherboard and I've found that their are a lot of issues with it running Linux. I have it working but the nvidia modules and whatnot are a real pain and with Gentoo I have to re-install Xfree everytime I upgrade the kernel for some reason.

In the future I'd like to stay away from anything with the nvidia chipset. Any suggestions on what motherboards I could get in the future that would make my life much easier?

lee_matheson 12-28-2003 06:43 AM

Is it necessary to re-install XFree with a kernel upgrade?

Originally posted by Crashed_Again
I also use the A7N8X motherboard and I've found that their are a lot of issues with it running Linux. I have it working but the nvidia modules and whatnot are a real pain and with Gentoo I have to re-install Xfree everytime I upgrade the kernel for some reason.
Well, getting back to the thread subject (which is Asus A7N8X install problems), is it REALLY necessary to re-install Xfree with a new Kernel? I am not so sure a re-install is needed.

I confess I am a newbie to Linux, but in the process of researching this a bit, it appears their may be "work arounds" where one de-installs the nVidia driver, and then re-installs the driver, and it will work with the new Kernel. Presumeably no XFree re-installation necessary?

I am still examining this (and I leave the continent for 4-weeks in a few days so I can't spend much time on it for a couple of months). Some links with some hints:
The above is a SuSE page that notes the nvidia installer does not work as long as a Xserver is still running and the nividia kernel module is still loaded. It recommends booting into runlevel 3 (by specifying "3" as kernel boot option, or switching to runlevel 3 ("init 3") and unloading the kernel module ("rmmod nvidia") before running th nvidia installer.
This thread is by a Red Hat user who notes driver problems after kernel upgrades. He notes one has to update the /etc/XF11/XF86Config file after the nVidia driver is installed, and refers to the nVidia file with the specifics:

This is a long read (and I haven't finished yet), but it notes the NVIDIA kernel has a kernel interface layer which must be compiled specifically for the configuration and version of the kernel one is running. NVIDIA distriubutes the source code to this kernel interface layer (as well as precompiled versions for many of the kernels distributed by some popular distributions). When the nvidia installer is run it will determine if it has a precompiled kernel interface for the kernel one is running. If it does not, it will check if there is one on the NVIDIA ftp site and download it. etc ....

That ftp site also gives information on reconfiguring the XF86Config file. Presumeably a reconfigure (and not a re-install) is all that is needed?

This looks like pretty good support to me, albeit it is rather technical.

Anyway, I confess I am a newbie to this (and I have been avoiding kernel updates), but I believe with time it can be figured out. If I wasn't such a newbie, it would probably be pretty obvious as to what is needed.

tricky_linux 12-28-2003 09:05 PM

now, i can't help no more.
i got radeon 9600 pro and it's working great for me.
however, remember always compile your NVIDIA support as M or modules and your chipset support as * or buildin.
good luck

All times are GMT -5. The time now is 08:02 PM.