-   Linux - Hardware (
-   -   ASROCK 775i65GV integrated VGA conflicts with Sparkle GeForce FX 5200 (

sarace 05-24-2005 01:38 PM

[RESOLVED] ASROCK 775i65GV integrated VGA conflicts with Sparkle GeForce FX 5200

I've an Asrock 775i65GV Mainboard with i865 integrated graphic card. It worked fine with my Fedora Core 3 untill I've bought an AGP Sparkle GeForce FX 5200 Graphic card.

My ASROCK has no AGP bus, but an AGI bus, a kind of AGP bus working only with few graphic chipset. My Sparkle VGA card is on compatibility list and has no problem with WinXP.

Using AGP card boot process stop with a segmentation fault when it tries to load modules by modprobe. Unfortunately, in my bios there's no choice to disable onboard VGA, I can only choose which "bus" it'll initialize first (Onboard/AGI/PCI or PCI/AGI/Onboard or AGI/PCI/Onboard).

Choosing Onboard as first Graphic Controller to initialize, Fedora works, but only with standard kernel, if I try a smp version (I've a P4 530 core Prescott @ 3GHz with HT tecnloogy) it reboots a few seconds after starting kernel boot process. But when I used only integrated VGA it worked fine!

Anyone knows some hits to resolve it?


finegan 05-24-2005 08:10 PM

Might want to check your mobo manual to see if you can jumper the onboard VGA out of existence. Aside from that... obvious stuff, a BIOS flash. Try booting with the "noagp" option. Then you can try a hand built kernel. Its working around in software for a hardware bug, there's some bus conflict there that isn't exactly kosher.



sarace 05-26-2005 06:55 AM

Thanks, i've partually resolved smp problem.

Using noagp option finally smp kernel work fine, but only with onboard vga graphic card.

I'm wondering if there's some way to make AGP video card work with this motherboard in linux!


finegan 05-27-2005 01:50 PM

The only other thing I can think of is to compile a kernel with all support for the onboard ripped out, so it will only function as a VGA device and then all the support for the regular AGP bus in and see if that'll boot without going thermal... Sounds like a pretty buggy mobo+video card combination.



sarace 05-31-2005 02:32 PM

I try to use a custom self-made kernel with intel graphic chip support disabled, but i've the same problem.

So I try another distro, Mandriva 2005. Install process work fine, also Geforce FX probing (it starts also X server to test configuration!), but when I reboot the system I obtain the same problem.

It seems like some function makes modprobe crash. It says that the invoked function (but It isn't displayed which function) is needed by 8139too floppy etc modules.

That's boring me!

sarace 06-03-2005 12:42 PM

I installed Gentoo 2005.0 (stage1) and now all works fine!

I love Gentoo! :cool:

Josuke 06-15-2005 03:18 PM

hi, i've the same mb the 775i65GV but i can't activate the agp support in i modprobe the intel_agp module i recive an smp preempt oops and the system freeze if i modporbe the other intel agp module (coldplug modprobe this module for me) nothing happend...i can see in lspci that there isn't any agp chip


0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
and if i run lspci -v | grep agp


pandora ~ # lspci -v | grep agp
pandora ~ #

but in windows i use my radeon 9200 se perfectly...

arobillard 06-26-2005 04:10 PM

Hello All,

I recently installed an ellcheapo 775i65GV motherboard on by PVR machine to replace my old PIII system. It runs MythTV on a Knoppmyth distribution (Debian). Because this box has to output to my TV I needed to add my NVidida FX 5200 (AGP) that has a composite TV out connector.

I pretty much had the same problem as everybody else with modprobe crashing in the boot process with the AGP card beeing the default vga card.

After a little bit of thinking and tweaking, I found a very workable solution that is now my final setup for my PVR application :

1) I left the inboard card as the default (this is the console card)
2) I Installed the NVidia module for XWindows
3) I changed my XF86Config-4, in the device section I uncommented the line that identify the pci busid :
BusID "PCI:1:0:0"
4) Restarted gdm et voila ! MythTV Started on the AGP card.

This is a solution only if you don't want to have access to the console (I don't ) and only work with XWindows (I do)

Hope this will help


All times are GMT -5. The time now is 08:42 AM.