-   Linux - Hardware (
-   -   ar242x chipset detected by ath5k in 2.6.30 but iwlist scan empty. ath5k bug? (

saltthefries 09-16-2009 01:03 PM

ar242x chipset detected by ath5k in 2.6.30 but iwlist scan empty. ath5k bug?
Hello all,
I'm having a problem getting an ar2425 to work under 2.6.30 (the most recent Debian Squeeze / Testing kernel). I'm going to give madwifi a shot in a little bit, but I believe this is a kernel bug in the ath5k module.

ath5k is able to detect the device, shows it in ifconfig / iwconfig, and doesn't seem to complain in dmesg.

Unfortunately, I'm not able to get anywhere with iwlist wlan0 scan or attempts to connect to LANs using wpa_supplicant or wicd.

Has anybody else seen this, and are there any suggestions? I've scoured the internet and not found much useful, other than another person guessing that it's a relatively new bug. I checked the Debian bugs list and's bugzilla. I didn't find anything in the Debian list, but there are a couple unclear bugs in the kernel bugzilla that might be to blame.

I have posted my dmesg, lspci -v, iwconfig, and iwlist wlan0 scan

Thank you.

From dmesg | grep ath

[  60.693179] ath5k 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  60.693190] ath5k 0000:02:00.0: setting latency timer to 64
[  60.693297] ath5k 0000:02:00.0: registered as 'phy0'
[  61.063232] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)

From iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0    IEEE 802.11bg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated 
          Tx-Power=27 dBm 
          Retry min limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

pan0      no wireless extensions.

From iwlist wlan0 scan:

# iwlist wlan0 scan
wlan0    No scan results

From lspci -v

02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
        Subsystem: Device 1a3b:1026
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at f2500000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [60] Express Legacy Endpoint, MSI 00
        Capabilities: [90] MSI-X: Enable- Count=1 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel <?>
        Kernel driver in use: ath5k

business_kid 09-17-2009 06:45 AM

Did you try 'ifconfig wlan0 up' ?

damgar 09-17-2009 09:36 PM

Hi all, I would really appreciate any information on the outcome of this as I have a related, but different issue in that my ath242x uses the ath_pci driver (part of madwifi I believe) and the throughput is atrocious (maybe 20% of the speeds I get when booting the same machine into Vista. This card is the only real issue that I'm having on my laptop, as it also frequently hangs the whole system as well.

Thank You To all in the forums.

damgar 09-18-2009 08:35 AM

closure for my athk242x issue
I finally found the answer to my issues last night regarding the ath242x driver issue. Ndiswrapper with an old xp driver worked perfectly, not only am I now getting full bandwidth, but the card has gone stable as well. It seems to be connecting 100% of the time and staying that way, not to mention that the perceived signal strength has also doubled.

saltthefries 09-19-2009 12:18 AM

I figured out that this problem is specific to my model notebook. The BIOS in the Thinkpad X200 will only accept wireless chipsets that are offered as part of the original configuration. I pulled my Atheros card from another machine, since the laptop came with a Realtek rtl8191, which doesn't seem to have any Linux support whatsoever. The BIOS allowed me to identify the card in the WAN mini pcie slot and power on, but it refused to give power to the radio.

I've ordered an Intel 5100 which should resolve the issue.

damgar, did you try using a newer kernel with the ath5k drivers? You may want to try them out, since this card is pretty well supported with Free drivers.

Electro 09-19-2009 01:02 AM

A lot of computer manufactures uses a whitelist to only let certain devices to be used. I suggest call Lenovo to make sure your notebook does not have a whitelist. If it does, ask them what other devices can be used besides the WiFi NIC that came with it.

Make sure you select the correct firmware version that works with your kernel because Intel WiFi has now been included in the kernel. Using the right firmware have to be known or it will not work. This might be true with your Atheros based WiFi NIC.

damgar 09-20-2009 06:10 PM

No I haven't tried a newer kernel. I'm about 2 weeks into my linux career and finally have most of the wrinkles ironed out as far as everything working and since I'm using the most current kernel from Mandriva's officially available repositories I'm just sitting tight since I am assuming that to go more current would mean compiling my own kernel (which sounds both intriguing and intimidating at the same time). I'm shopping junk bins and classifieds to put an 'experimental' system together so that I can play a little more, but for now I'm playing it a little cautious.

Thanks for posting in the forums. I'd be up a creek in Redmond if it weren't for everyone on here.

saltthefries 09-20-2009 07:23 PM

I did look into it, and Lenovo does have a whitelist. Only the rtl8191se (which I'm stuck with at the moment), iwl5100 and iwl5300 are supported in my Thinkpad X200. I've ordered an iwl5100, since I really can't find much on the Realtek card and can't find a 64 bit driver for ndiswrapper. Until recently, Lenovo had been shipping Atheros chipsets as their "Thinkpad Wireless" instead of this Realtek garbage... my mistake.

damgar, I took a quick look at the Mandriva site, and it looks like the latest version is based on 2.6.29, which should have the ath5k drivers included. You may need to blacklist madwifi to use ath5k, if it's not already done. You can find out the kernel version you're running by running "uname -a" as any user.

All times are GMT -5. The time now is 02:58 AM.