LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   AMD 64 LIVE BOOT CD won't detect my standard IDE hard drives (https://www.linuxquestions.org/questions/linux-hardware-18/amd-64-live-boot-cd-wont-detect-my-standard-ide-hard-drives-221830/)

tk32 08-24-2004 01:15 PM

AMD 64 LIVE BOOT CD won't detect my standard IDE hard drives
 
Greetings Linux world. I'm seeking to get back into this world as much as I can.

I ran into a tree stump and am trying to figure out how to go through or around it.

Here's the deal, I downloaded Gentoo AMD 64 bit Universal LIVE CD. I downloaded the application packages. Wrote both to two different disks. I downloaded and printed a 180 page manual I found online for installation of Gentoo AMD 64.

I then booted off the Off the Universal Live CD per the instructions. I then went to setup my hard drive partitions and to my dismay found no hard drives. /dev/hd* showed nothing.

My DVD Writer showed up and my IDE cd-rw showed up, was able to mount both cd drives, but no hard disk seemed to be detected. I then rebooted and verified windows still worked and it did.

I had a Pprimary master of 80gig and a slave 10gig drive, the slave 10 gig was blank and I tried it with a fat 32 and without a fat 32 partition on it. No detection of the drive at all.

I've rebooted off the live cd several more times and no hard drive detected at all.

My hardware config: ASUS KV8 64 bit Athlon main board. (has EIDE, Serial ATA, and Promise Raid controllers) The serial ATA and Promise Raid Controllers are not being used in any way shape or form. The hard drives and cdrom drives are only using the Primary and secondary EIDE controllers, a relatively basic setup for drives.


I'm running 512 mb of DDR 400mhz memory.
onboard sound.
using d-link wireless network card. (I know special setup is needed for these, just trying to get the install off the live cd to work if nothing else.)
AMD 64bit 3.0 ghz CPU.
Plextor 12x DVDr
Can't remember the brand, but 12x CD-rw drive.
80gig EIDE Maxtor Hard drive
10Gig EIDE Maxtor Hard drive.
ATI Radeon 9600XT AGP vid card.

and I think that's everything. ONboard LAN port is disabled.


Does anyone have any suggestions on what I need to do to get the hard drives seen. One person suggested wiping the BIOS settings. But I don't want to do that as I may have specific settings I setup, but don't remember.

Windows sees the drives fine, so I have to think it's a Hard drive controller driver issue or the LIve cd isn't looking for the hard drives very hard. (no pun intended).



Let me know if you have any ideas or suggestions.

travis.kvanvig@sei-it.com
whitewolf32@cableone.net

musicman_ace 08-24-2004 05:37 PM

I second this
 
Well, I think i'm sort of in the same boat. Here what I've got

My hard drive is being detected as /dev/hdc for some reason. If I try to fdisk it like the websites instructions, I get an error saying "Unable to open /dev/hdc" I'm going to try the 2004.1 cd just in case that will help, but if someone out there has an idea for either one of us, it would be helpful.



Started the install with the 2004.1 minimal CD and everything is going fine, so far. I don't know which CD you are using, but the 2004.2 may have a problem.

tex22 10-03-2004 07:23 PM

same problem
 
I'm having an identical problem installing 2004.2 on a system with a very similar configuration.

When I type "ide_info /dev/hda" it displays my hard drive's information correctly, but when I use "fdisk /dev/hda" it gives me "Unable to open /dev/hda"

I'm going to try 2004.1 and see if that works.

robfisher 10-31-2004 08:20 AM

modprobe ide-disk

I have no idea why you have to do that manually...

Hope this helps,
Rob.


All times are GMT -5. The time now is 01:57 PM.