LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   alsa work with root or sudo but not user (https://www.linuxquestions.org/questions/linux-hardware-18/alsa-work-with-root-or-sudo-but-not-user-375385/)

walterbyrd 10-21-2005 07:16 AM

alsa work with root or sudo but not user
 
Running debian 3.1, testing.

Probably has something to do with the screwed-up way alsa mutes everything by default.

as root, this works fine.
# mpg123 audiofile.mp3

or, as user, this works fine,
$ sudo mpg123 audiofile.mp3

but, as user, this does not work,
$ mpg123 audiofile.mp3

I've tried sudo alsamixer, and it looks like practically everything is set to off, but I don't know how to turn it on.

walterbyrd 10-21-2005 07:25 AM

I figured out how to un-mute everything in alsamixer, but it didn't help. I still get this error when I try to play anything with mpg123:

Can't find a suitable libao driver. (Is device in use?)

Again, everything works just fine as root or sudo.

Q-Fireball 10-21-2005 07:29 AM

Did you add the user to the audio group?
http://gentoo-wiki.com/HOWTO_ALSA_sound_mixer_aka_dmix

walterbyrd 10-21-2005 10:12 AM

I was the groups thing. I knew it had to something simple. Thank you.

Although, whoever makes alsa could certainly do a better job of creating a less user hostil install process. Why do they just assume that people will just know these archaic detials?

walterbyrd 10-24-2005 09:28 AM

alsa is broken, again, as usual
 
I guess I posted too soon. Alsa is broken for users again. I don't know why. I shut down normally, brought the system up normally. And now alsa doesn't work for users.

By the way, can anybody please tell me why alsa is designed to be unusable? Is there some huge security issue with users having access to their own audio? Why is alsa off by default? And why do users have to be added to an audio group? And why isn't this stuff explained during installation?

Frankly, I sometimes wonder if linux bashers aren't partially right.

walterbyrd 10-24-2005 01:53 PM

Nevermind, I got it. Not sure how.


All times are GMT -5. The time now is 11:48 PM.