LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ALSA surround center speaker problems (https://www.linuxquestions.org/questions/linux-hardware-18/alsa-surround-center-speaker-problems-193546/)

LavaDevil94 06-14-2004 07:12 PM

ALSA surround center speaker problems
 
I have a CMedia 8738 (supported by ALSA), and Im using a Surround 5.1 speaker set from creative with it. Everything is fine hardware-wise, connections are in the right place, etc. All my speakers work, except for the center one. Ive done some searching, tried numerous things (like recompiling ALSA with different options, etc.), and none seem to work. However, I did pick up a little info. In the alsamixer, there should be some options called Surround, Center, and Wave that should be turned on. I dont seem to have that in mine. All the ones this has are these (output of amixer scontrols):
Code:

Simple mixer control 'Master',0
Simple mixer control '3D Control - Switch',0
Simple mixer control 'PCM',0
Simple mixer control 'Synth',0
Simple mixer control 'Line',0
Simple mixer control 'Line-In As Bass',0
Simple mixer control 'Line-In As Rear',0
Simple mixer control 'CD',0
Simple mixer control 'Mic',0
Simple mixer control 'Mic As Center/LFE',0
Simple mixer control 'Mic Boost',0
Simple mixer control 'IEC958 5V',0
Simple mixer control 'IEC958 Copyright',0
Simple mixer control 'IEC958 In Monitor',0
Simple mixer control 'IEC958 In Phase Inverse',0
Simple mixer control 'IEC958 In Select',0
Simple mixer control 'IEC958 In Valid',0
Simple mixer control 'IEC958 Loop',0
Simple mixer control 'IEC958 Output',0
Simple mixer control 'PC Speaker',0
Simple mixer control 'Aux',0
Simple mixer control 'Four Channel Mode',0

Does anyone have any ideas?

slackMeUp 06-14-2004 08:58 PM

could you try this:

amixer set Center 100

and tell us what you get?

LavaDevil94 06-14-2004 09:09 PM

It says its unable to find that control. Is there any way to add that control?

slackMeUp 06-14-2004 09:26 PM

Alsa does not think it has such a capability. . .

Have you used this sound card (on-board I am guessing) with full 5.1 before?

if your center is not working then your LFE (subwoofer) channel is out too... can you confirm this?
(note that 5.1 speakers (when connected through the subwoofer will offload low tones to the subwoofer by default. But the subwoofer can't go to loud. If it gets a direct LFE signal it can be a lot louder)

Which version of ALSA are you using?
Some of the drivers are different between the alsa packages for 2.4 and the 2.6 kernel version of alsa. (my audigy for example, sounds like shit with 2.4 and alsa vs. 2.6 with built in alsa (much better. It's a driver issue with hardware mixing.)

LavaDevil94 06-14-2004 09:39 PM

I use ALSA 1.0.5, which I compiled myself (the driver is in 1.0.5a, so I use that. Whats that about hardware mixing?). I havent used this soundcard with any speakers before except 2 older speakers. I have a Mic As Center/LFE option, but nothing else mentioning Center or LFE, although my subwoofer DOES work.

slackMeUp 06-14-2004 09:48 PM

is the 'mic as center/lfe' switch on?

LavaDevil94 06-14-2004 09:55 PM

No, I have that turned off, since I have a free Mic socket in the back of my soundcard.

PS: I forgot to mention that the card is onboard, but has the same capabilities (like 6 channel sound, ALSA has a swtich for 4 channel sound, but no 6 channel...)

slackMeUp 06-14-2004 10:26 PM

Wait. You have it turned off?

How many cables do you have connected to your sound card?
1= 2.1 channel and 2 channel.
2= 4.1 channel and 4 channel.
3= 5.1 channel.

One plug is for front left and right.
One is for back left and right.
One is for center/lfe.

You need all three to get full 5.1 channel sound.
You also need to turn that on.

LavaDevil94 06-14-2004 10:46 PM

I have 3 cables connected, so hardware-wise Im ready for 5.1. Ill try turning on that option and tell you what happens.

LavaDevil94 06-14-2004 10:52 PM

Just turned the option on. Nothing out of the center speaker still. Anything else I can do? Maybe theres a way to turn those Surround/Center options on...

slackMeUp 06-14-2004 11:17 PM

Ok now that it is on... stick the center/lfe cable in the mike jack.

LavaDevil94 06-14-2004 11:30 PM

Oh, ok. Ill try that...

LavaDevil94 06-14-2004 11:31 PM

Nope, still nothing from the center.

slackMeUp 06-14-2004 11:32 PM

Well I give...

only so much you can do over the net.

Good luck.

EDIT:
One last thing... have you checked alsamixer now for a new mixer to set now that you have turned the mic-to-center/lfe on?

LavaDevil94 06-14-2004 11:37 PM

You mean check that alsamixer actually did its job with setting that option to on? I have gnome-alsamixer, and it confirms that its on. Oh well. Thanks for the help, Ill keep searching. And when I find a solution, Ill post a mini-howto :D!


All times are GMT -5. The time now is 05:31 PM.