LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-25-2003, 11:56 AM   #1
Lawful
LQ Newbie
 
Registered: Jul 2003
Distribution: red hat / pink tie
Posts: 20

Rep: Reputation: 0
ALSA muting after reboot


10 I have Recently configured alsa on my redhat install.
20 I ran alsamixer and un-muted chanels and raised volume.
30 I hear sound. (Cool beans).
40 I reboot my machine and........no sound.
50 I run alsamixer and..............everything is muted and volume is all at zero.
60 goto 20

This is nerve racking.
can anyone help?
 
Old 07-28-2003, 04:51 PM   #2
Lawful
LQ Newbie
 
Registered: Jul 2003
Distribution: red hat / pink tie
Posts: 20

Original Poster
Rep: Reputation: 0
Figured it all out

I have found out what I was doing wrong.
Thanks for all the posts....
 
Old 07-28-2003, 05:44 PM   #3
silverfire
LQ Newbie
 
Registered: Jul 2003
Distribution: Kanotix
Posts: 11

Rep: Reputation: 0
I have a similar problem. I'm running Mandrake 9.0, and using a Soundblaster Live! card. When I boot into Gnome or KDE, I have no sound available. With Gnome, I can get to a mixer and move all the sliders up (nothing's muted; just turned all the way down); while in KDE, I can't seem to find a mixer. The Gnome mixer has an option in the prefs to 'restore saved configuration on startup', but has no way to save a configuration.

I've heard that there's a script or something out there that's specifically for this problem, but I can't seem to locate it.

Any help or advice you can offer would be greatly appreciated.
 
Old 07-28-2003, 09:43 PM   #4
Lawful
LQ Newbie
 
Registered: Jul 2003
Distribution: red hat / pink tie
Posts: 20

Original Poster
Rep: Reputation: 0
Smile Use This

Lookup how to use "alsactl" store/restore
This is what did it for me.

Tell me if this helps...
 
Old 07-28-2003, 10:11 PM   #5
Lawful
LQ Newbie
 
Registered: Jul 2003
Distribution: red hat / pink tie
Posts: 20

Original Poster
Rep: Reputation: 0
It is located in...

"alsactl" is located in /usr/sbin .
you need to get your mixer/ volume settings set to your liking. Make sure you hear sound. I used alsamixer to unmute and change settings.
dont close the alsamixer terminal.
Then run alsactl store in another terminal. This saves your mixer settings.
then add "/usr/sbin/alsactl restore" to the beginning of your "/etc/bashrc"
script.

next time you restart your mixer will be at the same point that it was when you ran "alsactl store"

ps. make sure that "/usr/sbin" is in your path.
 
Old 07-29-2003, 03:50 AM   #6
silverfire
LQ Newbie
 
Registered: Jul 2003
Distribution: Kanotix
Posts: 11

Rep: Reputation: 0
Thanks

Thanks for the help, Lawful. While I don't seem to have alsactl, or much of anything else, I did find the program Gnome uses (gnome-volume-control) as a mixer and can access it in KDE through the command line. So that fixes part of my problem. I looked at the only documentation I could find, and saw that the Preferences deal about 'Restore saved settings ...' is supposed to save *and* restore the settings.

Since it's not, and I didn't see any other information on how to force it to, I'm still at a loss on making it so I don't have to keep resetting the volume sliders. Oh well. I'll figure it out sooner or later. I hope.
 
Old 07-29-2003, 06:42 AM   #7
Lawful
LQ Newbie
 
Registered: Jul 2003
Distribution: red hat / pink tie
Posts: 20

Original Poster
Rep: Reputation: 0
ALSA tools

If you install the alsa lib and util packages you will get "alsactl" and other tools for alsa.

I also remember seeing something about alsa that was particular t mandrake. If I can find it again i will link you to it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA Mutes Sound on Reboot radartone Linux - Hardware 3 11-24-2004 07:30 PM
startkde seems to be muting alsa !? qwijibow Linux - General 0 11-07-2004 05:04 PM
alsa settings don't save after a reboot moger Slackware 7 07-19-2004 11:56 AM
alsa messes up after each reboot linuxer222 Slackware 2 10-06-2003 10:20 PM
aumix muting digit Linux - Software 1 07-23-2003 09:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration