LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-15-2004, 12:41 PM   #1
radartone
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
ALSA Mutes Sound on Reboot


I have recently begun using Suse 9.1 and really like it. Unfortunately, my sound mutes every time I reboot my computer and this is getting extremely annoying. I have searched the internet for solutions to my problem and none have completely worked. I tried the suggestion on the SUSE support page for a muted sound card like deleting the kdemultimedia3-mixer and by typing

rcalsasound stop
rm /etc/asound.state
rcalsasound start
alsactl store

in a terminal as root. This fixes the problem for that session but the setting are lost on reboot. If I then type

alsactl restore

as root after a reboot, my sound settings are retrieved. I have also found if I go to YaST and hardware/sound my setting are reloaded. Is there any way to get my sound to stay unmuted? I was thinking of somehow putting "alsactl restore" in a script that runs on startup but don't know how. I imagine some other program is resetting my sound to mute but don't know what. Thanks for the help.

radartone
 
Old 11-15-2004, 01:26 PM   #2
rkef
Member
 
Registered: Mar 2004
Location: bursa
Posts: 110

Rep: Reputation: 15
I don't know how SUSE structures its boot sequence, but in Slackware I just add a line to /ect/rc.d/rc.local, which gets run at each boot. You should have something similar. Put your "alsactl restore" in that.

Now might be a good time to crack open the funny manual.

HTH.

Last edited by rkef; 11-15-2004 at 01:28 PM.
 
Old 11-24-2004, 07:00 PM   #3
Livino
Member
 
Registered: Nov 2004
Location: Belo Horizonte, Brasil
Distribution: Suse Linux 10.0
Posts: 32

Rep: Reputation: 15
That doesn't work with SuSE.
 
Old 11-24-2004, 07:30 PM   #4
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 65
Can it be added to /usr/bin/startkde under echo 'startkde: Starting up...' 1>&2

The only thing I ever did in that script is add a pause line " actually use ping command as a pause command ". I added ping -c20 127.0.0.1 so KDE would pause on shutdown long enough to play a shutdown wav sound file completely before exiting the gui. The wav file lasted longer than normal shutdown and would be cut off before finishing playing.

echo 'startkde: Shutting down...' 1>&2

# Clean up
ping -c20 127.0.0.1
kdeinit_shutdown
dcopserver_shutdown
artsshell -q terminate

Brian1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA, sound always muted after reboot. repe Slackware 5 11-14-2006 02:48 PM
gnome mutes sound deucedlt Fedora 0 08-06-2005 03:14 PM
Sound Mutes itself while bootind kde DirtyDan Slackware 1 10-04-2004 12:51 AM
Sound mutes when X opens :) WTF ? T-u-N-i-X Linux - Software 3 08-21-2004 08:35 PM
Suse9.1/ALSA/Audigy/No Sound/I run alsaconf after reboot(s) to get sound FastFeet Linux - Hardware 23 07-12-2004 06:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration