LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-13-2004, 03:54 AM   #1
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 97
ALSA MAKEDEV.snd 2.6.6


I am unable to find MAKEDEV.snd in the 2.6.6 kernel sources.

I can't get ALSA running without it (I've used this script before on an earlier 2.6 kernel and it worked just fine).

I've looked at the change-log for 2.6.6 and it appears the file has been removed. Does anyone know why? Does anyone have a copy of the script?

Cheers.

Dave
 
Old 05-13-2004, 05:00 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Original Poster
Rep: Reputation: 97
Apologies. Just discovered /dev/MAKEDEV, which does the same job.

Nothing to see here.....

Dave
 
Old 05-13-2004, 05:12 AM   #3
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
I have a copy from the 2.6.5 kernel here if you still want it.


Håkan
 
Old 05-13-2004, 05:59 AM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Original Poster
Rep: Reputation: 97
Hi.

Cheers for the offer.
/dev/MAKEDEV's man page is a bit thin, but after some trial and error it turns out

# /dev/./MAKEDEV snd

creates ALSA devices.

Cheers anyway.

Dave
 
Old 05-20-2004, 03:48 AM   #5
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
same problem.. found under DEV the command MAKEDEV but if u run it it won't do anything... ?!!??!!?!?!?
 
Old 05-20-2004, 03:51 AM   #6
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
update : right now i found how to work with MAKEDEV

i run this : # ./MAKEDEV snd

i got : don't know how to make device "snd"


helppppppppppp
 
Old 05-20-2004, 07:21 PM   #7
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Original Poster
Rep: Reputation: 97
Try a later version of MAKEDEV.

Have you got alsalib installed?

Dave
 
Old 05-21-2004, 02:27 AM   #8
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
where i can get a later version of makedev??

how can i discover if i have alsalib installed?
 
Old 05-21-2004, 02:46 AM   #9
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Original Poster
Rep: Reputation: 97
If you've got a program called 'aserver', then I'd imagine you've got alsa-lib installed.

Try using the script from post no. 3. It does what MAKEDEV snd would do.

Dave
 
Old 05-21-2004, 02:49 AM   #10
kuol3m4
Member
 
Registered: May 2004
Location: Italian Hell
Distribution: Slackware 9.1
Posts: 37

Rep: Reputation: 15
ok i'll try this too!
 
Old 10-27-2006, 10:02 PM   #11
Rhalnz
LQ Newbie
 
Registered: Oct 2006
Posts: 1

Rep: Reputation: 0
About the ./MAKEDEV snd

I think it was supposed to be:

./MAKEDEV sound


and try


./MAKEDEV -v sound


for better understanding .. .. ..

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa & snd-intel8x0 error hayesben Slackware 12 12-26-2004 04:42 PM
ALSA & 2.4.27/2.6.8.1,snd.o KMcD Slackware 2 08-27-2004 07:57 AM
ALSA: modprobe: Can't locate module snd eegeerg Slackware 3 04-25-2004 12:14 AM
alsa : unable to modprobe snd-emu10k1 sanjiv Linux - Hardware 6 11-30-2003 10:31 PM
debian: alsa snd-ens1371 probs el_focco Linux - Newbie 2 09-18-2003 06:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration