LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ALSA install error - 'Can't locate module snd-au8830 (https://www.linuxquestions.org/questions/linux-hardware-18/alsa-install-error-cant-locate-module-snd-au8830-201016/)

Foxy 07-04-2004 11:08 AM

ALSA install error - 'Can't locate module snd-au8830'
 
Hey,

I've been trying to get sound working in Mandrake 9.2 with my Aureal Vortex SQ2500 card. (type AU8830). After a while I found the ALSA site, and I tried to install it. The first time I made a hash of it because I used an old 'how-to' rather than the new instructions on the ALSA site, which I have to say are quite well hidden. :/

I re-tried installation, doing it the proper way. It seemed to go OK until I tried to do the 'modprobe snd-au8830' command (to insert the modules into the kernel). I got an error: 'Can't locate module snd-au8830'. I re-extracted the files and re-installed from a different directory but I got this same error again. :mad: I also tried the old 'snd-card-au8830 to no avail.

Any ideas as to how to fix this? On the install page (http://www.alsa-project.org/alsa-doc...le=au8830#Inst) there are a few 'notes' in the bit after it says about alsamixer but since they don't explain it very well I don't really know whether it's relevant or not.

Kernel version: 2.4.22-10mdk
Contents of sbin/lspci: File not there!
ALSA version: Latest (1.05rc1)

Notes: I did get a couple of errors trying other specific drivers for the sound card, one of which said that there was no sound card there, which is rubbish, since Mandrake detected it.

b0uncer 07-04-2004 04:33 PM

well, if the module should come with the kernel you're running, your kernel obviously lacks it....I don't know if the module should come with kernel or the sources you downloaded. you can of course try to get new kernel sources, recompile the kernel and make sure that you have the appropriate module compiled in or as a module...and: do you have alsa support enabled in kernel? are you sure you do? because you need it...

check out kernel.org for more info on kernel and modules..

Foxy 07-05-2004 11:54 AM

As I understand it the module comes as part of the ALSA drivers (as source, of course, which is what I guess the 'make' and 'make install' is all about). My kernel does have the standard sound module there, as the install instructions said to check that it is there. I dunno about ALSA support, although I would guess that it's there. I will check, if someone can tell me how to! :scratch:

I really don't get what is wrong... I installed the stuff as per instructions and it's just taken objection to this bit. I've only used Linux literally for a few days so I can't really help myself much on this. The only other thing I can remember is that I did kind of screw up the preparation of some kernel source, I think I told it to compile itself when I shouldn't have, lol. :D (I didn't have a clue what was going on, I was just told to 'make menuconfig' without any info as to what it was for. The kernel menu told me to execute this command, which I don't think I should have, lol :p). Maybe this screwed everything up a little. Mind you, the kernel reported properly and nothing else has gone wrong.

Argh... after all the problems I had booting and running the installer, and then Mandrake refusing to use my ISDN connection (STILL unresolved)... now this... :cry:

b0uncer 07-05-2004 02:07 PM

ok, now the "make menuconfig" is just the part that configures the kernel....I dunno if it's that what's wrong. so what did you actually do?

if you should get the module with ALSA drivers, it's ok then...I just checked. but go and do the "make menuconfig" once more (or make xconfig if you're using X) and check your alsa drivers and so on...

Foxy 07-06-2004 10:53 AM

I did 'make menuconfig' and then the kernel menu told me to do something... I reckon it must have been 'make' or similar since a similar kind of thing happened onscreen as when I did 'make' for the ALSA drivers. (I'm doing all this in the CLI btw).

Bleh, maybe I'll try the latest stable ALSA drivers... fat chance of it working, but oh well... :(

b0uncer 07-06-2004 11:35 AM

ok...so you didn't change anything when you did "make menuconfig"?

that is the kernel configuration screen, where you choose what you want to compile in the kernel, and what you want as modules...after that you exit it, save the config and do make (or make all, and perhaps make modules_install) to compile the new kernel that has the options you want..

If I were you, I'd check the menuconfig again and see if there is ALSA support ok and possibly the module you need...then recompile the kernel.

Foxy 07-06-2004 12:15 PM

OK, I think I found out what the problem is, but I still need some help to resolve it. I 'make install'd the stable ALSA driver version and I got a list of errors like this:

Code:

depmod: * Unresolved symbols in * somedirectory/somemodule.something
I think it wasn't putting the modules in the correct kernel directory!!! I had noticed an extra kernel directory or 2 in a specific directory (can't remember where). There was one for the Mandrake kernel, one unknown one and one that had the kernel version number that I told the ALSA installer to use. It seems that the ALSA installer thinks that I have the newer kernel, puts the modules in the new kernel folder, then has a fit because there's nothing else there.

So, obvious solution: use kernel source that Mandrake's kernel is compiled from for compile of ALSA.

But, erm, where do I get the source? I can't find it in the package manager (there's a load of different types but not the correct one). Where could I download it from? Where would Mandrake have put it if it installed it? (There was no /usr/src/linux directory btw).

Gah.

(Also of note: Curiously, see stuff about ALSA in the verbose Mandrake load... :confused: I guess it did put stuff in the config files then.)

b0uncer 07-06-2004 12:23 PM

well normally the sources are in /usr/src/something where "something" is the source-directory's name like linux, linus-2.6.6, linux-myconfig-a.b.c-2 etc. whatever...so you don't have anything in /usr/src?

kernel sources can be obtained from kernel.org website, and then compiled to get a new kernel...I guess you need to make ALSA install the module into the kernel you're using, or it's no use for you :) so either locate your current kerne's module directory (check this below) or then get new sources, compile them and install new kernel - or use some "ready" package. here's one way to check where your kernel modules are:

modprobe -l snd

this should print some soundmodules (whatever...snd just is so common that there's a chance you'll get something at all) with their full path. the path tells you then where the modules of your current kernel are...so you can try that one :)

Foxy 07-06-2004 12:30 PM

There was no existing kernel source in /usr/src. I stuck in the new 2.6.4 version off a magazine CD.

Thanks for the command, but am I right in thinking that the kernel directory with the modules in won't have the kernel source present?

I'm gonna have to find this source, because I don't think recompiling the entire kernel is a very good idea (considering that I'm a Linux n00b with a slightly screwy distro install... :p).

Foxy 07-07-2004 08:08 AM

I think I found the directory. There is a /usr/include/linux directory with the needed version.h file in it. I did the ./configure with '/usr' as the kernel source directory (it puts '/include/linux' on the end of the path I give it) and it went ok I think. However, 'make' generated long lists of errors. With drivers version 1.05a I got 'Error 1' at the end, with drivers version 1.05rc1 I get Error 1, 3 and possibly 2 as well, lol...

Back to square one... :cry:

b0uncer 07-07-2004 11:15 AM

ok...well I don't know about that /usr/include/linux - I have that too, but that's not where my sources are. that just includes some header files I gues....

compiling a brand new kernel isn't that hard but I think it would solve the problem..I'd say if you resolve this one without compiling the kernel, you have what it takes to compile one ;)

well, I don't know if I can say much more to this than that you just seem to lack the sources? I mean, when installing a distro, you don't necessarily get the sources...at least in some RedHat's installations one could choose whether to put the sources too into the HD or not (this was some devel-thing, in the part where you choose which packages you want to install).


All times are GMT -5. The time now is 11:25 AM.