LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   alsa - drivers (https://www.linuxquestions.org/questions/linux-hardware-18/alsa-drivers-146489/)

init 02-15-2004 06:59 PM

alsa - drivers
 
Well I had sound and know I do not.

asla 0.9.8

If I run alsaconf it can not find any cards.

Im using an onboard c-media sound card on a soyo-ultra mobo.

I'm a little new with sound configs, they generally just worked for me. Let me know what logs would be helpful and I will post them.

TIA

init 02-16-2004 10:47 AM

Ok, no help with this. So digging around I noticed that I updated the alsa drivers with slap-get.

slap-get will not let me install the old drivers again ? It claims my username / passwd is incorrect.

slapt-get --install alsa-driver-0.9.6-i486-3
Reading Package Lists... Done
The following NEW packages will be installed:
alsa-driver
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1325K of archives.
After unpacking 2320K of additional disk space will be used.
Downloading ftp://sunsite.cnlab-switch.ch/mirror...slackware-9.1/ alsa-driver 0.9.6-i486-3 [1325K]...Failed to download: the username and/or the password are incorrect

Anyone tell me how to get the old pkg's back again.

Please, Sound is a great thing.

TheOneAndOnlySM 02-16-2004 11:22 AM

become root in a terminal, do pkgtool, remove all 4 alsa packages and then use pkgtool to install the 4 alsa drivers from cd; you can also use the installpkg command to install the files directly without having to use pkgtool

LinFreak! 02-16-2004 11:22 AM

try using wget:

wget -c ftp://ftp.sunet.se/pub/Linux/distrib...packages/*.tgz

this is a good way to get your stuff. I think the password should be blank for ftp transfers from most mirrors.

p.s. the example i just gave will download all the latest updates for slack9.1 into whichever directory you run it from (cd to a new folder first), you will then need to use pkgtool to install whichever ones are useful to you. If you decide to install the newer kernel and its modules you will need to re-compile your kernel:

su - or log in as root then:

cd /usr/src/linux
make menuconfig #or xconfig
make dep
make clean
make bzImage
make
make install
make modules
make modules_install
lilo

reboot!!

init 02-16-2004 12:03 PM

1andonly - I tried that still with the same issues. After I install all alsa* tgz I run the aslaconf and it still can not find my card? In /etc I have a "asound-state" file in it it has info about my sound card must I do anything with this file?

LinFreak - Were can I get a list of mirrors for wget ? Im still a bit new with slack and the update proccess, used R-Hat 7.3 for most of my days. Also can I get the new kernel 2.6 in tgz format and install it as a package? Installing the new kernel is my next step but im a bit nervous. I use to upgrade my kernel with up2date before and it was a walk in the park.

Thanks for the help guys.

LinFreak! 02-17-2004 01:04 PM

The first time I tried wget I started a download using mozilla; in the download window was the full ftp address for that file, so I copied and pasted that into a terminal, put "wget -c" in front of it (stopped the mozilla download) and pressed enter - voila! Try it, even when you close the terminal it keeps on chugging away.
The list of mirrors for slack are on their website: http://www.slackware.com/getslack/ - try browsing using mozilla (or similar) when you find the file(s) you want, copy the url from the navigation toolbar + the name(s) of the file(s) you want - eg.

ftp://gd.tuwien.ac.at/opsys/linux/sl...ches/packages/

then either add the name of the file you want eg.

ftp://gd.tuwien.ac.at/opsys/linux/sl...4-noarch-1.tgz

or just add "*.tgz" to wget them all
then put "wget -c" in front of it all (in a terminal) and press return. (note - "-c" = continue... man wget;~)

edit: try upgrading to kernel 2.4.24 first, it seems to be easier than 2.6 at the moment, follow the instructions in my previous post for compiling the kernel - you will need to:

upgradepkg kernel-source-2.4.24-noarch-1.tgz
upgradepkg kernel-modules-2.4.24-i486-1.tgz
upgradepkg kernel-ide-2.4.24-i486-1.tgz

then compile, then upgradepkg the alsa files in order to have sound again (most importantly alsadrivers as they reside in /lib/modules - have a look at what changes occur there)

good luck!


init 02-17-2004 06:10 PM

cool, thanks for the help man! I went for the gusto last night and compiled 2.6.2 "most" is good, my computer is so much faster. Now I see why a cutom kernel is the way to go. I have yet to get alsa going and also I have not had any succes getting my video card to work with the new kernel (ATI 9700) works fine in 2.4.x. So I shall truck on with sound and video and hope for the best.

Rock on!

TheOneAndOnlySM 02-17-2004 06:49 PM

what is the name of your soundcard specifically?

lspci should be able to tell you

http://www.alsa-project.org/alsa-doc...C-Media#matrix shows a list of c-media cards that are supported

*edit: btw. anything that alsa needs to modprobe will actually be located in /etc/modules.conf

LinFreak! 02-20-2004 07:30 AM

Nice one for getting the new kernel to work!

Just as a footnote: I just upgraded the kernel on my laptop, but after having read THE_BOOK_ I noticed that the upgrade from 2.4.22 to 2.4.24 needs no recompile ie.

su
upgradepkg kernel*.tgz
lilo

reboot!

I will still recompile later to get battery monitor and such - but what a breeze!

(see sig!)


All times are GMT -5. The time now is 06:45 AM.