-   Linux - Hardware (
-   -   ALSA driver problem: Intel HDA card driver (

Digital Watches 04-06-2008 11:35 PM

ALSA driver problem: Intel HDA card driver
Specifically, the HDA card is built into an XFX 680i motherboard, if that helps any. I can't get it to output sound to my linux boot. I've seen instructions for installation on the ALSA project: ( but when I run the ./configure script, a bunch of permission errors come up for creating various files and directories which I can't seem to override by sudoing it. Anyone know what do?

Tons of Fun 04-07-2008 07:06 PM

What distro are you running? I had a lot of problems with my Debian Etch install, and found this Web site that helped me get alsa working:

Even though this article is for Debian, if you install all of the files listed under the multimedia section, it will probably work. I also followed the same instructions you referred to, and I seemed to go backwards.

Hope this helps,


Digital Watches 04-08-2008 07:07 PM

Oh, I'm running Ubuntu, but I'll try that.

Tons of Fun 04-08-2008 07:15 PM

Good luck. Let us know how it goes.

Digital Watches 04-08-2008 10:35 PM

Er... the "Package repository" section doesn't exactly match up well with what I have (presumably since the guide was written for Debian proper and I'm using Ubuntu) and I'm not confident that I'd know what I was doing if I tried to adapt it. Sorry, but any other suggestions?

tommcd 04-09-2008 06:23 AM

You should be able to install the listed packages with apt-get or synaptic. If you don't know how to enable repositories in Ubuntu, see this:
First, have you tried the basics? Open a terminal and run alsamixer. Unmute the volume levels with the "m" key. Move back and forth and adjust the volume levels with the arrow keys. Then see if you have sound. My laptop uses the snd-hda-intel driver and it worked out of the box.
Also, see this Ubuntu sound troubleshooting guide:
EDIT: This may help you also. It discusses snd-hda-intel problems:

Tons of Fun 04-09-2008 08:04 AM

Another thing to check is in the alsamixer. By default, it has external amplifier enabled, but not shown. In the options, select external amplifier, and when it appears, uncheck it.


Digital Watches 04-11-2008 01:45 AM

Oh man. I'm dumb. I hadn't realized that my ALSA drivers are working just fine because I can't get my second monitor to work, and it's the only available speaker. I plugged in headphones to a secondary sound port and they work just fine. Sorry about that.

Tons of Fun 04-11-2008 08:02 AM

It happens, Glad it's working.

All times are GMT -5. The time now is 04:20 PM.