-   Linux - Hardware (
-   -   After upgrade to OpenSuse 11.3, Canon Pixma MP210 prints solid black (

JayBee21 08-09-2010 06:52 AM

After upgrade to OpenSuse 11.3, Canon Pixma MP210 prints solid black
Canon Pixma MP 210 worked fine in OpenSuse 11.2, but after upgrading to 11.3 it prints solid black after the first page of any document. First page is OK.

I have tried reinstalling the printer and the recommended driver ( Pixma 180 CUPS + Gutenprint v. 5.2.4 [en]) without success.

Other questions indicate there is a bug here, but I cannot follow the instructions for fixing it. Can anyone please give me newbie-friendly directions?

business_kid 08-10-2010 06:01 AM

That's as weird as they come.
Raise the issue on SuSE's site, and google for a mention of it
Also check the display of ghostscript. Print a multipage doc to file, and display it
gs /path/to/

It _could_ be ghostscript, and the check is easy. Try also with a2ps, if you have that installed.
Keey an eye on the site. When suse find it, they'll issue an update. Make sure to install updates.

JayBee21 08-14-2010 06:46 AM

Thanks Business Kid

Have posted on Novell site.
What is a2ps?

Ghostscript check produced the following:

GPL Ghostscript 8.70 (2009-07-31)
Copyright (C) 2009 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file COPYING for details.
>>showpage, press <return> to continue<<

XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
after 2433 requests (2429 known processed) with 0 events remaining.

Any clues there?

Thanks again

business_kid 08-15-2010 04:05 AM

You did that from an X terminal, right? If not, do it that way.
a2ps is 'any-to-postscript' printer for text files, etc. It uses ghostscript.
Now I tried to do this the way it should work, but this proved tricky. Xpdf (which uses ghostscript) and printing all work fine here. It would display pdfs, however, and any of x11 the options in the output of 'gs -h' would work, e.g.

gs -sDEVICE=x11rg32x some.pdf
Postscript was a bit fussier and wouldn't operate from the same dir(?) but this worked
gs -sDEVICE=x11 /usr/share/ghostscript/8.15/examples/tiger.eps (A lovely image, btw)
gs -sDEVICE=x11rg32x /usr/doc/gimp-2.2.15/ and anything else I tried with a full path name was fine.

although it didn't work for me from that same dir :-/. You said there was some bug.What have you discovered? Keep your eyes on SuSE's stuff.

JayBee21 08-18-2010 02:00 PM

Bugzilla says this problem is the same as bug 628233 and it's to do with CUPS and should be fixed with an update. Does Xterminal mean from a 'print to file' file? If so, the answer is yes. I'm afraid the rest of the suggestions are beyond me! A newbie, after all.

gs -h produced the following:

GPL Ghostscript 8.70 (2009-07-31)
Copyright (C) 2009 Artifex Software, Inc. All rights reserved.
Usage: gs [switches] [ ...]
Most frequently used switches: (you can use # in place of =)
-dNOPAUSE no pause after page | -q `quiet', fewer messages
-g<width>x<height> page size in pixels | -r<res> pixels/inch resolution
-sDEVICE=<devname> select device | -dBATCH exit after last file
-sOutputFile=<file> select output file: - for stdout, |command for pipe,
embed %d or %ld for page #
Input formats: PostScript PostScriptLevel1 PostScriptLevel2 PostScriptLevel3 PDF
Default output device: x11alpha
Available devices:
alc1900 alc2000 alc4000 alc4100 alc8500 alc8600 alc9100 ap3250 appledmp
atx23 atx24 atx38 bbox bff bit bitcmyk bitrgb bitrgbtags bj10e bj10v
bj10vh bj200 bjc600 bjc800 bjc880j bjccmyk bjccolor bjcgray bjcmono bmp16
bmp16m bmp256 bmp32b bmpgray bmpmono bmpsep1 bmpsep8 ccr cdeskjet cdj1600
cdj500 cdj550 cdj670 cdj850 cdj880 cdj890 cdj970 cdjcolor cdjmono cfax
cgm24 cgm8 cgmmono chp2200 cif cljet5 cljet5c cljet5pr coslw2p coslwxl
cp50 cups declj250 deskjet devicen dfaxhigh dfaxlow display dj505j
djet500 djet500c djet820c dl2100 dmprt dnj650c epl2050 epl2050p epl2120
epl2500 epl2750 epl5800 epl5900 epl6100 epl6200 eps9high eps9mid epson
epsonc epswrite escp escpage escpc faxg3 faxg32d faxg4 fmlbp fmpr fs600
gdi hl1240 hl1250 hl7x0 hpdj hpdj1120c hpdj310 hpdj320 hpdj340 hpdj400
hpdj500 hpdj500c hpdj510 hpdj520 hpdj540 hpdj550c hpdj560c hpdj600
hpdj660c hpdj670c hpdj680c hpdj690c hpdj850c hpdj855c hpdj870c hpdj890c
hpdjplus hpdjportable ibmpro ijs imagen imdi inferno iwhi iwlo iwlq
jetp3852 jj100 jpeg jpegcmyk jpeggray la50 la70 la75 la75plus laserjet
lbp310 lbp320 lbp8 lex2050 lex3200 lex5700 lex7000 lips2p lips3 lips4
lips4v lj250 lj3100sw lj4dith lj4dithp lj5gray lj5mono ljet2p ljet3
ljet3d ljet4 ljet4d ljet4pjl ljetplus ln03 lp1800 lp1900 lp2000 lp2200
lp2400 lp2500 lp2563 lp3000c lp7500 lp7700 lp7900 lp8000 lp8000c lp8100
lp8200c lp8300c lp8300f lp8400f lp8500c lp8600 lp8600f lp8700 lp8800c
lp8900 lp9000b lp9000c lp9100 lp9200b lp9200c lp9300 lp9400 lp9500c
lp9600 lp9600s lp9800c lps4500 lps6500 lq850 lx5000 lxm3200 lxm5700m
m8510 mag16 mag256 md1xMono md2k md50Eco md50Mono md5k mgr4 mgr8 mgrgray2
mgrgray4 mgrgray8 mgrmono miff24 mj500c mj6000c mj700v2c mj8000c ml600
necp6 npdl nullpage oce9050 oki182 oki4w okiibm omni oprp opvp paintjet
pam pbm pbmraw pcl3 pcx16 pcx24b pcx256 pcx256 pcx2up pcxcmyk pcxgray
pcxmono pdfwrite pdfwrite permute pgm pgmraw pgnm pgnmraw photoex
picty180 pj pjetxl pjxl pjxl300 pkm pkmraw pksm pksmraw plan9bm png16
png16m png256 png48 pngalpha pnggray pngmono pnm pnmraw ppm ppmraw pr1000
pr1000_4 pr150 pr201 ps2write psdcmyk psdrgb psgray psmono psrgb pswrite
pxlcolor pxlmono r4081 rinkj rpdl samsunggdi sgirgb sj48 spotcmyk st800
stcolor stp sunhmono svg t4693d2 t4693d4 t4693d8 tek4696 tiff12nc
tiff24nc tiff32nc tiffcrle tiffg3 tiffg32d tiffg4 tiffgray tifflzw
tiffpack tiffsep uniprint wtscmyk wtsimdi x11 x11alpha x11cmyk x11cmyk2
x11cmyk4 x11cmyk8 x11gray2 x11gray4 x11mono xcf xcfcmyk xes
Search path:
/etc/ghostscript/8.70 : /usr/share/ghostscript/Resource :
/usr/share/ghostscript/8.70/Resource/Init :
/usr/share/ghostscript/8.70/lib :
/usr/share/ghostscript/8.70/Resource/Font :
/usr/share/ghostscript/fonts : /usr/share/fonts/truetype :
/usr/share/fonts/Type1 : /usr/share/fonts/CID : /usr/share/fonts/URW

any clues there?

business_kid 08-19-2010 03:34 AM

The rest simplifies to this. Try this exact line in an xterminal

gs -sDEVICE=x11 /usr/share/ghostscript/8.70/examples/tiger.eps

Do0 you see a picture? looks like gs is OK.

JayBee21 08-20-2010 03:22 AM

Yes, I get pic of a tiger. So, I suppose, just wait for the fix?

Thanks for your help

business_kid 08-20-2010 12:19 PM

You could try regressing: install bits from previous version, cups, & ppd for starters

Start with ppds - use anybody's and go for it. Cups own pixma thing would be an idea
Then Cups. I wouldn't try to settle all nagging dependencies - just bang it in for a quick try. I wouldn't worry going backwards.
rpm -ivh --middle-finger :-).

lastly, gs -h lists a pile of drivers and if you fancy it try using them directly. The Canon ones bj*, cbj*, s400* all seem to use the same basic format In a terminal

gs -q -dBATCH -dNOPAUSE -dSAFER -sDEVICE=<your-printer-driver> -sOutputFile=/dev/usb/lp0 <>

Worst that can happen is that it starts spitting ascii, 2 letters of gibberish per page for 50K pages. Switch the printer off if that starts.

All times are GMT -5. The time now is 06:16 PM.