-   Linux - Hardware (
-   -   after update HAL automount doesn't work (

eddiep 02-24-2007 08:02 AM

after update HAL automount doesn't work
[SOLVED: After reinstalling original dbus rpms]

SO: mandriva 2007.0 powerpack

Just made an update from the update sources configured for urpmi. There were lot of updates includeing HAL, avahi, (and dbus I think).

After update, hal, dbus, udev starts with no error, but automount deosn't work anymore.
Klick on Konqueror media:/hdc (my dvd drive) returns this error: "Feature only available with HAL"
After manual mount, like: mount /mnt/cdrom2, I can click and access media:/hdc
Unmount, eject options from Konqueror returns same error.

I tried to insert my linux dvd and do a "rpmi --install --replacepkgs --force /mnt/cdrom2/.../hal...rpm"
This way I replaced (reinstalled) all dbus, hal, avahi packages I could find. Now dbus works, udev works, BUT avahi and hal fails.

Basicly I would like you to help me make a clean reinstall of these packages from the original dvd.

Just for the rekord:
old (original) version of HAL:
new version was (I think):

Please help, I can mount cd's manualy, but others useing my pc .... can't.... :(

neo571 02-26-2007 10:14 AM

I Have the same problem , after the system update, automount don't work.

eddiep 02-26-2007 12:09 PM

Reinstall the original dbus rpm, then remove the new ones. You must install dbus, libdus1, dbus-X11 ... and I think some other files. ... Just install everithing with dbus from the original cd. I installed the packeges from console with this command: rpmi --install --replacepkgs --force <package name>

After this I had the old version installed, but the new (broken) versions too. Soo I went to mandriva control center and removed the newer versions. Note that you can not remove the new version untill you have installed the old version back becouse of some dependency problems.

If this doesn't help, reinstall hal packages too.

neo571 02-26-2007 12:41 PM

where i can find the original package on DVD?

neo571 02-26-2007 02:58 PM

Good Procedure!!!!!!

Thank You!!!

All times are GMT -5. The time now is 07:18 AM.