LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ADI AD1980 Sound not working Mandrake 9.0 (https://www.linuxquestions.org/questions/linux-hardware-18/adi-ad1980-sound-not-working-mandrake-9-0-a-146404/)

Andrew Benton 02-21-2004 08:03 AM

No, I don't think so. When you do xconfig you should enable sound support (I choose y but m should work too) and then choose n for no to everything else on the sound menu.
As for gcc, I suppose it's possible to compile your kernel with gcc-3.2 but the kernel maintainers recommend using gcc-2.9. I would get gcc-2.9 before compiling the kernel. If you do recompile your kernel you may need to reinstall the drivers for your video card so you'll need to look into that. I only know about Nvidia. You should definitely get into rebuilding your kernel. It's hard at first as there are some scary moments, but to fix hardware stuff you have to go into the kernel.
I couldn't get the digital output working on my sound card when I used Mandrake. It was only after doing Linux from Scratch that I learned how to rebuild the kernel and Beyond Linux From Scratch showed me how to install the ALSA drivers. I used to have to use a tiny analog headphone socket which was no good. Now I can record music I download direct from the digital output onto minidisc and it's much better. So stick at it. It's hard work but you'll get there.

Edit - You've set me off now. We still had Mandrake 9.1 on the family computer upstairs so I thought I'd have a go at getting the digital output to work on the soundcard by recompiling the kernel and installing the alsa drivers. What a nightmare. Make menuconfig would crash me back to the command prompt whenever I tried to open the ALSA menu so I opened the mandrake config file with gedit and then ran make oldconfig. That got me through make dep and make bzImage but make modules failed with an error about ambassador.o. So I deleted the Mandrake sources, untared an official kernel and went with a .config file I knew would build. That went fine till I came to reboot and do the Nvidia driver. That failed as it couldn't find a C compiler. It seems it doesn't look for gcc at all and the gcc-2.96 I installed of the mandrake CD's doesn't make a cc symbolic link. So I did that by hand. So I can get back into Gnome again, the alsa stuff installed OK. Or rather I think they did. I've now got to figure out how the Mandrake bootscripts work and apply the supermount patch to the kernel to get the CD's to work so I can install Xmms.
Mandrake is just too weird to me now. Anytime I change something the wheels fall of something else. I've given up and decided to build linux From Scratch on that computer, which is a big nuisance to the rest of the family as it'll take me weeks. Sorry if I've given you false hope about getting Mandrake straightened out. It probably is possible, but is it worth the effort?

Relja 02-22-2004 09:50 AM

Ok, I don't really want to recompile kernel and all that stuff. I'm preety much a Linux Newbee and everything works just fine to me... I think that installing sound won't be so complicated since many people made it...

How do I uninstall ALSA? How do I uninstall anything installed from the sources (I never needed to uninstall anything...)?
I want to wipe ALSA out, and than install it again, since it seemed that ALSA was already installed with Mandrake, and I installed it again from rpm, and than from sources - that could make a lot of mess...

Relja 02-22-2004 01:49 PM

Ok, I reinstalled Mandrake 9.0 (since I had no relevant stuff - I installed it days ago).
Seems like ALSA is installed, I chacked it to start with system.
whereis alsa:
/usr/share/alsa

No sound...

find / -name alsa:
/etc/sysconfig/alsa
/etc/rc.d/init.d/alsa
/usr/share/alsa

So I tried
/etc/rc.d/init.d/./alsa start
No messages. Then I tried
/etc/rc.d/init.d/./alsa stop
Says:
"ALSA driver isn't running."

modprobe snd-intel8x0
Code:

/lib/modules/2.4.19-16mdk/kernel/sound/pci/snd-intel8x0.o.gz: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.19-16mdk/kernel/sound/pci/snd-intel8x0.o.gz failed
modprobe: insmod snd-intel8x0 failed

How can I change IO or IRQ parameters? Where is alsaconf - I can't find?

maroonbaboon 02-23-2004 03:46 AM

Do you know what version of ALSA you are using? I installed 0.9.4 (with 2.4.21 kernel) around August 2003 to get my AD1980 running, and I noticed the intel 810 driver code had been patched very recently to work with this sound chip. So if your distro was put together before that you might expect problems.

If you want to keep trying, in answer to your questions, for alsaconf, mine is at /usr/sbin/alsaconf. You could try running it (probably need to be root). If its not there you can search for it with 'find / -name alsaconf -print'.

For IO and IRQ, I think the PCI protocols take that out of your hands.

Relja 02-23-2004 04:58 AM

Yes, I want to keep trying and thank you for doing so much for me...

I don't know which version is alsa, I know that alsa-utils is 0.9.0-0.6rc2... sh*t....
My kernel is 2.4.19-16mdk. Does it mean that I can't make sound work?

If not, how do completely uninstall alsa (when I run software packages removal and search for alsa, it founds only alsa-utils,libalsa and libalsa2, but not drivers?), so I can tr with your version (do your working version is 0.9.4?)

maroonbaboon 02-23-2004 05:36 AM

I think the various package numbers are synchronised, so if your utils are 0.9.0 then your drivers are likely to be the same.

'Uninstalling' is usually just a matter of figuring out where the sound system gets started and editing a file or two to stop that happening. I think unfortunately this varies from distribution to distribution. e.g. on here ALSA is started by the script /etc/init.d/alsa.

There is an informal convention that 'official' (e.g. Mandrake supplied) packages are installed in /usr/bin, /usr/lib etc., while 'unofficial' additions go in /usr/local/bin etc. So long as you install your new ALSA under /usr/local there is no danger of overwriting files.

Then you just have to change the startup script to look at /usr/local instead of /usr.

Well, maybe it is not quite that simple, and is does depend on the distro. somewhat.


Or you could get an up-to-date distro. Knoppix 3.4 will be out soon (if not already) with 2.6 kernel. You can try it without it touching your hard disk (except it uses the swap if it finds it).

Relja 02-24-2004 04:55 AM

Ok, seems like I'll have to get new kernel... When I installed alsa 0.9.4 there were some unresolved symbols when loading snd-intel8x0.... same old stuff...
Anyway, thank you very much for your effort in this marathonic thread but it just seems like it's making no advance, so I'll have to get something newer...

Relja

Relja 02-28-2004 08:48 AM

I installed Mandrake 9.2 (kernel 2.4.22-10mdk), sound works!
The system automaticaly detected it and starts Alsa on startup...
Not only that, the Intel integrated graphics works great too, with Mandrake 9.0 I couldn't play taxracer and other 3d stuff, now I can...
And it's got some really SMOOTH fonts...

Relja


All times are GMT -5. The time now is 04:06 PM.