-   Linux - Hardware (
-   -   Added new DVD drive, old cd stopped working (

ejennings_98 05-21-2004 11:06 PM

Added new DVD drive, old cd stopped working
I have added a new DVD-RW drive and my existing CD-ROM drive stopped working. I am running Mandrake 10.0.

Mandrake auto recognized the drive when booting up and asked me to re-configure both CD drives. The drives show up as /mnt/cdrom and /mnt/cdrom2, where cdrom is the new DVD drive.

The two drives are on the second IDE controller connection on the motherboard. cdrom is set as master and cdrom2 is set as slave. I have booted into Windows and both drives work fine with the current IDE setup.

Any suggestions how I should mount cdrom2 so that I can get it working?

Thanks Eric

ilikejam 05-21-2004 11:41 PM


Could you post the contents of /etc/fstab


ejennings_98 05-22-2004 12:10 AM


In my previous message I had mixed up order of the cdrom names. cdrom = old CD drive, and cdrom2 = new DVD burner. The burner is LG Super Mulit GSA-4082B if that makes any difference.

Here is the fstab file:

/dev/hda8 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdd /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,ro,exec 0 0
none /mnt/cdrom2 supermount dev=/dev/hdc,fs=auto,ro,exec,--,umask=0,user,iocharset=iso8859-1,codepage=850 0 0 /mnt/xxxxx nfs defaults 0 0
\\xxxx\yyyy /mnt/xxxx/zzzzz smbfs username=% 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,sync,codepage=850,iocharset=iso8859-1,umask=0 0 0 /mnt/bbbb nfs defaults 0 0
/dev/hda4 /mnt/win_c vfat codepage=850,iocharset=iso8859-1,umask=0 0 0
/dev/hda5 /mnt/win_d vfat codepage=850,iocharset=iso8859-1,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0

ilikejam 05-22-2004 07:10 AM


Just to be clear, /dev/cdrom2 (/dev/hdc) works at the moment and /dev/cdrom (/dev/hdd) doesn't yes?

I'm not familiar with supermount, but I would try changing the line that starts with /dev/hdd to:
none /mnt/cdrom supermount dev=/dev/hdd,fs=auto,ro,exec,--,umask=0,user,iocharset=iso8859-1,codepage=850 0 0

so that it's similar to the line for /dev/cdrom2.

If that still doesn't work, then could you post the output from 'ln -l /dev/cdrom*'


ejennings_98 05-22-2004 03:04 PM


You are right, cdrom2 does work. However, after a restart and install of cdrecorder, the recorder software displayed a list of files from cdrom, but could not copy. If I use a file tool such as Nautilus I am not able to access cdrom, only cdrom2.

I was not able to copy the music using cdrecorder as I was missing some other package. I am having problems installing software using the Mandrake tools. I think there is something wrong with the install portion of the distribution. I am still looking into this one.

I tried to do the "ln -l /dev/cdrom", but I got an error stating that "-l" is an invalid option. The man page for ln does not show an -l option. The command you suggested, is it to display the link information?

Thanks for your help, Eric

michaelk 05-22-2004 04:16 PM

The command is:
ls -l /dev/cdrom


ln -l /dev/cdrom

ejennings_98 05-22-2004 07:38 PM

The result of "ls -l /dev/cdrom" is:
lr-xr-xr-x 1 root root 13 May 22 17:31 /dev/cdrom -> cdroms/cdrom0

ilikejam 05-22-2004 07:43 PM

Hi again.

If the lines in /etc/fstab for each cdrom device are the same except for the hdx letter and the mount point, then I can see no reason why both devices shouldn't work.

OK, one last ls output.

What do you get from ls -l /dev/hdc
and ls -l /dev/hdd ?

The permissions *should* be the same.

ejennings_98 05-22-2004 09:25 PM

All seems to work now. Hmmmm, not sure why. I did set the CD options to Supermount, where there is no description of what "Supermount" is.. Anyway, after restarting the system, an additional "CD-ROM" icon appeared on the desktop. Using Nautilus I was able to open files from both cdrom drives.

Next challenge will be to actually burn cd's and then DVD's.

Thanks for your help, Eric

ilikejam 05-22-2004 09:34 PM


Hey, as long as it's working...


All times are GMT -5. The time now is 02:56 PM.