-   Linux - Hardware (
-   -   ACPI power off works with PS/2 keyboard but not with USB keyboard (

mrwaters 12-05-2005 12:18 AM

ACPI power off works with PS/2 keyboard but not with USB keyboard

Motherboard: ASUS A7N266-VM
Linux Distro: MEPIS 3.3
Kernel: 2.6.10
Boot Loader: grub
Keyboard: Logitech wireless USB keyboard & mouse combo

While using a PS/2 keyboard, shutting down the computer works. But when I use my USB keyboard it does not. The shutdown process sits forever at a text line that reads: acpi_power_off called

I have tried adding the following to my kernal boot parameters: acpi=off apm=on

And the last line of text from the shutdown process reads: Power off

What else can I try to resolve the ACPI power off issue?

Andy Alt 03-16-2006 04:07 AM

I have this same problem, but it seems to have started when I switched from a ps/2 mouse to a USB mouse. I do not get the "power off" message though. As a matter of fact, nothing happens at all. It could be something else for me; I'm still trying to troubleshoot the problem.

vbisis 03-16-2006 04:47 AM

Have you tried disbaling power on by usb keyboard/mouse in bios?

Andy Alt 03-17-2006 10:06 PM

I don't have that option in my BIOS. It's from 2000, that may be why.

I disconnected the mouse and rebooted -- no help. Must be some other change I made around the same time, but I haven't been able to nail it down yet.

What's happening more specifically is that using "halt" or shutting down from kdm or kde will power the computer down properly, and turn it off. Pressing the power button does absolutely nothing. I see the socket open for acpid from "netstat -l" and /var/log/acpid shows it's reading "/etc/acpi/events/default" which is just how I've always had it set up. acpi is in memory. Since the BIOS is from 2000, I have to pass the option acpi=force to lilo, which is something that's been working ever since I set it up.

I have upgraded some packages recently, but can't find any in /var/log/removed_packages that could possibly relate to acpi. I'm using Slackware 10.2, updating from slackware-current. I think the next thing I'll try is just installing the 2.6.x kernel series. I have been using the 2.4.x (bareacpi). I don't know what else to try at this point. I do like being able to use that power button though. :)

Andy Alt 03-22-2006 12:20 AM

I tried upgrading to kernel and that didn't do the trick. I suppose I'll forget about it for a while. I tried various combinations in the BIOS regarding power management; no success.

Andy Alt 10-05-2006 05:06 PM

power button now shutting off computer
I finally figured it out last night. I checked my bios, and there were two options enabled:

Assign IRQ to VGA
Assign IRQ to USB

It was an IRQ conflict.

I disabled those two, and now when I press the power button now, my computer shuts off, and it shuts off properly.

All times are GMT -5. The time now is 09:07 AM.