-   Linux - Hardware (
-   -   ACPI causes errors, instability (

Keozon 10-09-2009 05:12 PM

ACPI causes errors, instability
I have a Foxconn A7DA-S mobo with AMI BIOS. I've gone through and flashed it to the most recent version. I also have an LSI SAS3041E-R RAID controller.

Every time I install linux (off the raid, or on) I get errors every time on boot. Sometimes the errors stop the boot process altogether, others they let it continue. The errors I've seen so far have been:

ACPI: Firmware Glitch: POWERNOW-K8 - your bios does not send ACPI-PSS signals in a way linux understands.


ACPI aborted: crc error

There are other errors, like grub simply being unable to mount the volume, error 21 (on grub), but those are fixed by simply restarting.

In general, everything I put on the raid ends up being corrupt. It doesn't matter whether I'm running linux or windows. I've used two different controllers and had the same result. All HDDs pass diags from WD. The HDDs are

Seagate Barracuda 7200.10 ST3250310AS 250GB 7200 RPM SATA 3.0Gb/s

Its bad enough that I essentially can't install linux. Either the install is corrupt, and I can't boot, or I get errors once booted about missing files, etc. Does anyone know how to troubleshoot this? I've tried everything I can think of, but its so low end I'm not sure what else to try.

portamenteff 10-10-2009 12:29 PM

well I had acpi problems too. I just went

sudo gedit /boot/grub/menu.lst
then found the line with the line in the latest kernel and changed "acpi=on" to "acpi=off."
You may have to take the harddrive out and put it in a usb harddrive portable case and plug it into another Linux machine since you can't boot Linux and Windows can't read most linux file systems (again, Linux rules in that department too!)
A permanent solution would be to replace the bios and/or board. This may cost a lot depending on the one that's in there. Is it under warranty? Erase the linux partition if so. These companies often void the warranty if you use Linux.
I hope that helped.

portamenteff 10-10-2009 12:37 PM

one more thing
you may try reverting back to the old bios version. the new one may have a bug. I'd try that before anything else.

All times are GMT -5. The time now is 12:41 AM.