-   Linux - Hardware (
-   -   acer P215H monitor 21.5" widescreen crunchbang horizontal position (

chenderson 09-25-2010 09:45 PM

acer P215H monitor 21.5" widescreen crunchbang horizontal position
I have tried it with several window managers, xfce, gnome, kde, etc...

OK, have tried every thing the monitor its self will let me do (horizontal position, clock) The screen works fine in lower resolutions. It does not work on 1920 x 1080 which is what the monitor says it will do, and it does it just fine under Ubuntu and Fedora as well as winders. I guess basically i just need to know if there are any tricks you all may know or if you can direct me to a place where i may find linux driver for this monitor because im at a loss, BTW it does this on all slackware based distros.

Acer P215H 21.5" Widescreen

rickst29 10-15-2010 03:04 PM

Hi, Chenderson.

If you look at the contents of file "/etc/X11/xorg.conf" while running Ubuntu (or Fedora), versus the one which gets used by Slack, you will find differences within the "Monitor" section. In particular, the "Modeline" specifications for 1920x1080 - it's either wrong, or missing, or not Preferred.

Here's mine- but DO NOT USE THIS DATA!!!, because my monitor is 1920x1200, and it might run a lot "faster" than yours. (It's an LG W2452, running at 1920x1200 -- not 1080. Scanning a less capable monitor at the speeds which mine can take might fry your monitor.)

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "W2452"
HorizSync 30-83
VertRefresh 56-75
Option "PreferredMode" "1920x1200"

# Monitor preferred modeline (60.0 Hz vsync, 74.0 kHz hsync, ratio 16/10, 94 dpi)
ModeLine "1920x1200" 154 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync

Then there's a whole bunch of similar "Modeline" settings, for all of the lower resolutions. So, let me make a short explanation first, then I'll suggest a solution for you ;)

Your question shows some confusion, possibly based on experience with Windows. There is no "driver" for a Linux monitor; the driver is used for the graphics card (or on-board graphics chip). That driver, together with this file, tells X11 how to "run" your monitor through the card. X11 lies underneath your desktop environment- and so, it's no surprise that all of your Window Managers exhibit the same problem.

(Off-topic Terminology quibble: A "Window Manager" runs inside of a "Desktop Environment", you test tried different DEs. Not just different WMs. KDE's default Window Maanger is called "kwin", but I personally use Compiz-Fusion instead. But your test needed to be done, good job!)

Different Distributions use different methods to try and "sniff out" the capabilities of your monitor, so I'm guessing that Slack does a lousy job of this. BUT, the only problem is with those lines affecting 1920x1080 resolution. So, here's my suggestion:

Step 1: Start up using FEDORA, and bring up any Window manager you like.
Step 2: Get into an editor program, and open Fedora's file "/etc/X11/xorg.conf". Save it in your home directory as "fedora_save_xorg.conf".

Step 3: Shut down and start up using SLACK. Again, bring up any Window manager, get into an Editor, and open the file "/etc/X11/xorg.conf".
Step 4: This time, save it in your home directory twice: once as "slack_save_xorg.conf", and again as "test1_xorg.conf".

This is because you want to be absolutely, positively sure that you still have a copy of the original "" if your re-write doesn't work correctly.

Step 5: Edit file "test1_xorg.conf". Copy the "Modeline" for mode 1920x1280 from the "fedora_save" file into the "test1" file. The Slack version in "test1" probably didn't even have a ModeLine for one; but if it did, overwrite that line. Also specify your new ModeLine as the preferred mode for the monitor (the "PreferredMode" option).

Now, further down in the file, there is a section called "Screen". This defines the modes and color depth combinations which the screen can support. So, if it does not yet allow your 1920x1280 Mode, add it to the list in each of the subsections.

Step 6: Save the file. Make absolutely sure that you're saving the "test1" file, and leaving the "fedora_save" file alone.
Step 7: Now initiate a terminal Window, and give it su permissions.

Step 8: Check the permissions of "/etc/X11/xorg.conf", then copy your "test1" file on top of it. Change the permissions (owned at writable by you) to match the original permissions- probably 644 (owned and writable by root; readable by group and anybody).

Step 9: Restart the box. If not successful, then please clip the contents of your ENTIRE Fedora versus Slack files here, and I will create a file for you.

All times are GMT -5. The time now is 04:08 PM.