LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-15-2010, 09:32 AM   #1
Linux31
Member
 
Registered: Aug 2004
Posts: 296

Rep: Reputation: 30
Accessing Second Drive Under Meerkat


I've installed Ubuntu Meerkat on a new build that has two HD's. The installation process saw and setup the first drive but seemed to ignore the second. Using the disk utility under Administration, I formatted and then partitioned the second drive. I then added a line to the fstab.

The disk usage utility under Applications-Accessories sees the increased space, however I don't know how to access it.

Under previous versions of Ubuntu, in this situation all of the hard drives would be visible under Computer and Nautilus but they're not.

I'm not using LVM.

Any suggestions as to how I can access that second drive?

Thanks for any help that you can provide.
 
Old 10-15-2010, 10:56 AM   #2
sylvainsf
LQ Newbie
 
Registered: Aug 2010
Location: San Francisco
Distribution: CentOS
Posts: 7

Rep: Reputation: 1
Not very familiar with the GUI tools but it sounds like while you've added a line to fstab maybe the new partition isn't being mounted? Try running "mount </mnt/mountpoint>" (whatever mount point you set up in fstab.)
 
Old 10-15-2010, 11:33 AM   #3
Linux31
Member
 
Registered: Aug 2004
Posts: 296

Original Poster
Rep: Reputation: 30
Thanks for the feedback.

I went to the disk utility under Administration and it's offering the option to unmount the drive. It shows the mount point as /none which is what is listed in both fstab and mtab.

I should note that the first drive that I'm working off of has a mount point of "/" and also does NOT show up on "Computer". That displays only icons for the DVD and the File System.

If changing the mount point to "/" would help, I don't see how with these GUI tools although they may be there once you start the partitioning process.

I did try that mount command and got errors but I may not have been syntaxing it correctly.

This second drive is /dev/sdb1 if that helps.

Does all this suggest anything?

Thanks for the help.
 
Old 10-16-2010, 01:52 PM   #4
ArisBoch
LQ Newbie
 
Registered: Oct 2010
Posts: 15

Rep: Reputation: 0
When you click on "computer" in the places list you will see a list on the left. The one marked "File system" is / (root drive).

In order to mount your second drive automatically you just need to add an entry to fstab. A good practice is to use UUID's.

As root type: blkid /dev/sdb1 (enter) You should now see an entry something like this:

UUID="71926afe-820e-3ea2-b256-f66a12aebec0" SEC_TYPE="ext2" TYPE="ext3"

Highlight and copy everything in between the inverted commas. Now open fstab by typing: sudo gedit /etc/fstab.

Place your cursor at the end of the entries listed on a new line and add something like this:

UUID=71926afe-820e-3ea2-b256-f66a12aebec0 /media/data ext3 defaults 0 0

Obviously, the above is just an example. You will have to enter the correct UUID by pasting the code you copied earlier.

You will also have to make the data mount point if it does not exist, like: sudo mkdir /media/data.

Enter the correct file system if ext3 is not the file system of the second drive. The remaining entries you can leave. defaults 0 0

When your done, just check to make sure that you have entered everything correctly and save the file.

Now type: sudo mount -a and you should now see your drive mounted and accessible in "computer".
 
Old 10-16-2010, 02:36 PM   #5
Stephannn
Member
 
Registered: Oct 2010
Location: San Francisco, CA
Distribution: Snow Leopard, Ubuntu, RedHat
Posts: 64

Rep: Reputation: 14
What ArisBoch said.

Additionally, you can mount the disk anywhere you'd like in the file system, it needn't be /media/data specifically. You decide where you want that drive to 'live' in your file system; a disk who's job is to serve a web site, for example, could be mounted at /var/www/html/yourwebsite

Also, adjust permissions on the directory you create appropriately, so as to ensure your users (including yourself) can access it, since creating the directory as root will mean only root can access it.
 
Old 10-16-2010, 03:23 PM   #6
ArisBoch
LQ Newbie
 
Registered: Oct 2010
Posts: 15

Rep: Reputation: 0
Yes, as Stephannn said, you can mount the drive anywhere, and there are many options that you could add to the fstab entry, I just wanted to keep things simple for you.

Some options you may consider using in place of defaults or after them are: rw,user Other options can also be added such as nosuid,nodev,noexec depending on your needs.

I would recommend that you read the man pages for both mount and fstab as it will help you understand some of the options you may require.
 
Old 10-17-2010, 05:38 PM   #7
Linux31
Member
 
Registered: Aug 2004
Posts: 296

Original Poster
Rep: Reputation: 30
Thanks, ArisBoch and Stephannn so much for the help. At first, despite following your directions, I still couldn't get it to work but then I thought to comment out the old /dev/sdb and re-did a mount -a and the second drive popped right up under "Computer"

I still don't have an icon for the 1st drive which is mounted at /. Can I repeat the process for it as well? Since it has the OS on it, I didn't want to do anything rash and lock myself out!

Right now, my fstab looks like this:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
#/dev/sda1 / ext4 errors=remount-ro 0 1
/dev/sda5 none swap sw 0 0
#/dev/sdb1 /media/data ext4 errors=remount-ro 0 1
UUID=7a67818c-0522-41dc-ae70-acd4ebd18049 / ext4 defaults 0 0
UUID=b0c91175-4fb6-49ec-973c-bc1016e386d7 /media/data ext4 defaults 0 0

# none /proc/bus/usb usbfs devgid=127,devmode=664 0 0

The mtab looks like this:
/dev/sda1 / ext4 rw,errors=remount-ro,commit=0 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
/none /sys/kernel/debug debugfs rw 0 0
/none /sys/kernel/security securityfs rw 0 0
/none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
/dev/sdb1 /none ext4 rw,errors=remount-ro,commit=0 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/vulcan/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=vulcan 0 0
/dev/sdb1 /media/data ext4 rw 0 0



Thanks again for your help.
 
Old 10-18-2010, 08:35 AM   #8
ArisBoch
LQ Newbie
 
Registered: Oct 2010
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by Linux31 View Post
I still don't have an icon for the 1st drive which is mounted at /.
Most distros if not all of them don't show the root file system as an icon on your desktop by default. In Ubuntu, if you go to -> places -> Computer. This opens up Nautilus.

On the left hand pane you will see a list of drives and partitions etc. You will see one labeled File System. That is your root partition.

You could create a shortcut to it on the desktop, but I don't see any reason why you would want to!
 
Old 10-18-2010, 03:37 PM   #9
Linux31
Member
 
Registered: Aug 2004
Posts: 296

Original Poster
Rep: Reputation: 30
Thanks for the clarification. I was starting to get that idea.
 
  


Reply

Tags
meerkat disk


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
what is accessing my drive bic Linux - General 1 11-28-2009 10:13 AM
Accessing old WinXP C drive? Not shown in 'My Computer' drive list. peteyperson Linux - Newbie 4 02-04-2009 08:59 AM
kernel accessing pata cd rom drive instead of sata OS hard drive for filesystem elaps2007 Linux - Kernel 0 03-19-2008 09:39 AM
Accessing Another Hard Drive? jvanv8 Linux - Hardware 13 03-17-2006 11:56 AM
Accessing Windows XP Drive JamboUK Linux - Newbie 4 04-25-2003 12:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration