LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-31-2004, 03:52 PM   #1
Kane635
Member
 
Registered: Jul 2004
Posts: 36

Rep: Reputation: 15
AC 97 i810_Audio Suddenly Not Working


[kane@localhost kane]$ /sbin/lspci
00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
00:02.0 VGA compatible controller: Intel Corp. 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 01)
00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
01:04.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
01:05.0 Communication controller: Conexant: Unknown device 2f20
01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
[kane@localhost kane]$

Yah, my kernel is: 2.4.22-1.2199.nptl.

It will work... however... I may be talking on AOL instant messenger, and the sound will suddenly stop working. I have no clue what ALSA is, or Does. Trying to compile it before did well, nothing. The sound card shuts off permantely, and I have to reboot the computer to get it to work. It *might* stop when two sounds are played at once, on my observation. Any clues?
 
Old 09-01-2004, 01:52 AM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
You shouldn't be running ALSA, IMO. I had this same issue with my i810 board, and I switched it to aRts.
You can avoid shutting the machine down, but simply killing the ALSA process. (ALSA stands for Advanced Linux Sound Architecture)

Last edited by PenguinPwrdBox; 09-01-2004 at 01:54 AM.
 
Old 09-01-2004, 06:45 AM   #3
class_struggle
Member
 
Registered: Nov 2003
Location: where rock meets hard place
Distribution: 1- Knoppix 2-Gentoo
Posts: 121

Rep: Reputation: 15
Why not the ALSA with that card? Why aRts instead?
 
Old 09-01-2004, 09:18 PM   #4
Kane635
Member
 
Registered: Jul 2004
Posts: 36

Original Poster
Rep: Reputation: 15
O.o I just want it to work... I stated that it worked before...

I stated it worked before. Why would I want to buy hardware over getting free software?
 
Old 09-03-2004, 06:09 AM   #5
baronlynx
Member
 
Registered: Jan 2004
Location: Lille [Fr]
Distribution: SUSE9.3, WinXP on a leech (vmware)
Posts: 62

Rep: Reputation: 15
try 2.6 kernel

hi,

after i have switched to the kernel 2.6 i got mine to work properly and all the time (it is the alsa problem). with kernels 2.4 i tried to configure alsa but never finally got it working ... (alsa is built in the kernels 2.6, so it has to work )

good luck

--baronlynx--
 
Old 09-05-2004, 12:22 AM   #6
Kane635
Member
 
Registered: Jul 2004
Posts: 36

Original Poster
Rep: Reputation: 15
Thank you, I'll give it a shot, I beleive I am running a 2.4.*.*! Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet suddenly stopped working. figster Linux - Newbie 2 08-29-2005 05:18 PM
Azureus suddenly stopped working!! Braveheart1980 Linux - Software 1 02-19-2005 06:22 PM
Wireless Suddenly Not Working Corallis Linux - Laptop and Netbook 2 08-25-2004 04:25 AM
Wireless suddenly not working Corallis Linux - Wireless Networking 0 08-22-2004 06:52 PM
DNS suddenly not working? smiorgian Linux - Networking 4 06-06-2004 05:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration