LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-03-2004, 03:41 AM   #1
phoenix7
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.2(Mandriva), SuSE 9.3, Slackware 9.1, Xandros 3.1, Knoppix 3.9, FreeBSD 5.3, RedHat9
Posts: 122

Rep: Reputation: 15
Cool a problem with arts and mplayer


Hi
when I use mplayer this error occures.
the error message windows title is : ""Error - artsmessage""
and the content is
{
Sound server fatal error:
AudioSubSystem::handleIO: write failed
len = 4092, can_write = 4094, errno = 17 (File exists)
This might be a sound hardware/driver specific problem (see aRts FAQ)
}
what should I do?

Thanks,
Mohammad
 
Old 09-03-2004, 04:02 AM   #2
bestofmed
Member
 
Registered: Jul 2004
Location: Jemna, Tunisia
Posts: 46

Rep: Reputation: 15
I think it's a specific hardware/driver problem as mentioned. but give another try by running it ith diffrent audio output engine.

Code:
mplayer -ao <engine> /your/movie/file
You can get full list of supported engines by running

Code:
mplayer -ao help
e.g.:

Code:
mplayer -ao oss my_movie.avi
mplayer -ao sdl my_movie.avi
mplayer -ao alsa my_movie.avi
mplayer -ao esd my_movie.avi #run esd before by typing 'esd &`

good luck
 
Old 09-04-2004, 10:41 AM   #3
phoenix7
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.2(Mandriva), SuSE 9.3, Slackware 9.1, Xandros 3.1, Knoppix 3.9, FreeBSD 5.3, RedHat9
Posts: 122

Original Poster
Rep: Reputation: 15
That doesn't work

Hi

I ran:
Code:
mplayer -ao oss samplefile.wma
but it shows me the same warning.

Thanks,
Mohammad
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with aRts paul_mat Linux - Newbie 5 01-11-2005 01:17 AM
arts problem jods Linux - Software 12 01-07-2005 10:45 AM
arts freezes! Sound only with mplayer + arts disabled metgorna Mandriva 0 09-18-2004 09:21 AM
mplayer and xmms cannot share arts krussell Linux - Software 2 01-10-2004 12:36 AM
Arts problem zodmaner Slackware 1 05-30-2003 10:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration