LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-22-2005, 12:02 AM   #1
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Rep: Reputation: 0
5.1 Speakers in Debain


Hey guys..
I can't get all my satellites to work properly.
I have the Logitech X-530 70 watts 5.1 Speaker and Foxconn NF4UK8AA-8EKRS Socket 939 NVIDIA nForce4 Ultra ATX AMD Motherboard. I am only getting sound from the side satellites and not from the center or the back satellites as well as not from the subwoofer. Has anyone encountered such problems?
Any kind of help would be greatly apprieciated.
The speakers work fine with WindowsXP.
 
Old 08-22-2005, 04:59 AM   #2
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 426

Rep: Reputation: 99
Re: 5.1 Speakers in Debain

Quote:
Originally posted by sakya_trips
Hey guys..
I can't get all my satellites to work properly.
I have the Logitech X-530 70 watts 5.1 Speaker and Foxconn NF4UK8AA-8EKRS Socket 939 NVIDIA nForce4 Ultra ATX AMD Motherboard. I am only getting sound from the side satellites and not from the center or the back satellites as well as not from the subwoofer. Has anyone encountered such problems?
Any kind of help would be greatly apprieciated.
The speakers work fine with WindowsXP.
From the foxconn website i see that your motherboard has Realtek ALC850 chipset for sound.
What kernel version are you using ?
Do you use the "hda" ALSA driver ?

If yes, in many cases (including mine) the autodetection doesn't work, so you only get stereo sound (left-right).
You can load the module with the option "model=5stack"
I have the cmedia chipset, so i had to look in the driver's source for the realtek chipset. If i am correct this is the right option.

if you run "speaker-test -c 6" you must get sound (noise if you prefer) from all the speakers.
You need to put this in a file in order for it to load after a reboot.
i think you put the modules in "/etc/modules" in debian but i am not sure.
 
Old 08-22-2005, 11:21 AM   #3
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
I am embarrased to ask, but can you please give me a walk through. I am a newbie in Linux. Which module are you refering to?
Kernel :2.6.11
And I use the hda ALSA driver.
Sorry for the bother.
-s
 
Old 08-22-2005, 04:34 PM   #4
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 426

Rep: Reputation: 99
Quote:
Originally posted by sakya_trips
I am embarrased to ask, but can you please give me a walk through. I am a newbie in Linux. Which module are you refering to?
Kernel :2.6.11
And I use the hda ALSA driver.
Sorry for the bother.
-s
Do you use the hda driver compiled in the kernel or as a module ?
run "lsmod" and see what is says.
if you see "snd_hda_codec" and others then you load it as a module.

you just put "option=5stack" to the config file of debian
i think it is "/etc/modules" but i can't remember.
It's been long since i had debian.
 
Old 09-04-2005, 03:46 PM   #5
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
On lsmod I get

Code:
snd_intel8x0           33216  3
snd_ac97_codec         75640  1 snd_intel8x0
snd_pcm_oss            52256  0
snd_mixer_oss          19328  2 snd_pcm_oss
snd_pcm                90628  4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26116  1 snd_pcm
snd                    57444  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10848  2 snd
snd_page_alloc         10756  2 snd_intel8x0,snd_pcm
I dont have a 'snd_hda_codec'
Does it mean it doesnt load in modules?

-sakya
 
Old 09-04-2005, 04:35 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,594

Rep: Reputation: 97
Quote:
Originally posted by sakya_trips
On lsmod I get

Code:
snd_intel8x0           33216  3
snd_ac97_codec         75640  1 snd_intel8x0
snd_pcm_oss            52256  0
snd_mixer_oss          19328  2 snd_pcm_oss
snd_pcm                90628  4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26116  1 snd_pcm
snd                    57444  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10848  2 snd
snd_page_alloc         10756  2 snd_intel8x0,snd_pcm
I dont have a 'snd_hda_codec'
Does it mean it doesnt load in modules?

-sakya
Yes that means the module is not loaded try using modprobe snd_hda_intel although it looks like you may have to recompile a kernel to do it, this is the output from my self-built kernel which I just used the original 2.6.8 config file for with no changes on a 2.6.12 and it was not set.

Code:
>$ grep -i snd_hda /boot/config-2.6.12.5
# CONFIG_SND_HDA_INTEL is not set
 
Old 09-05-2005, 04:27 AM   #7
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 426

Rep: Reputation: 99
Quote:
Originally posted by sakya_trips
On lsmod I get

Code:
snd_intel8x0           33216  3
snd_ac97_codec         75640  1 snd_intel8x0
snd_pcm_oss            52256  0
snd_mixer_oss          19328  2 snd_pcm_oss
snd_pcm                90628  4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26116  1 snd_pcm
snd                    57444  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10848  2 snd
snd_page_alloc         10756  2 snd_intel8x0,snd_pcm
I dont have a 'snd_hda_codec'
Does it mean it doesnt load in modules?

-sakya
Hm. weird
You have the "intel8x0" module loaded which is for intel sound cards but based on ac97 codec and not hda codec.
Normally it shouldn't load this.
 
Old 09-25-2005, 09:24 PM   #8
shellshock
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
imitheos:

Just to be clear, am I understanding you correctly that you have 5.1 surround sound enabled on your system and you are using a soundcard that's integrated with your motherboard?

I have a Realtek ALC850 soundchip integrated on my motherboard, and someone told me that it's not possible to have surround sound in Linux with this hardware. I'm trying to confirm whether or not this is true.
 
Old 09-26-2005, 07:41 AM   #9
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 426

Rep: Reputation: 99
Quote:
Originally posted by shellshock
imitheos:

Just to be clear, am I understanding you correctly that you have 5.1 surround sound enabled on your system and you are using a soundcard that's integrated with your motherboard?

I have a Realtek ALC850 soundchip integrated on my motherboard, and someone told me that it's not possible to have surround sound in Linux with this hardware. I'm trying to confirm whether or not this is true.
Yes, enabled and working fine.
I have a 7.1 soundcard integrated in my m/b but i have 5.1 speakers.
My chipset is ICH6R and the module i use is "snd_hda_intel"

I watch movies with mplayer and everything works ok.
I have recently watched star wars and you could easily notice that 5.1 sound was working.

I believe whoever told you that you can't get surround sound was wrong.

sakya_trips was right though about the ac97 codec. You don't use the "hda" driver as i do.
i believe ALC880 uses the hda and not ALC850. ALC850 uses the ac97 codec.
the correct driver for you is "Intel/SiS/nVidia/AMD/ALi AC97 Controller"

Maybe it is some autodetection problem that doesn't allow you to use surround sound.
MODULE_PARM_DESC(index, "Index value for Intel i8x0 soundcard.");
MODULE_PARM_DESC(id, "ID string for Intel i8x0 soundcard.");
MODULE_PARM_DESC(enable, "Enable Intel i8x0 soundcard.");
MODULE_PARM_DESC(ac97_clock, "AC'97 codec clock (0 = auto-detect).");
MODULE_PARM_DESC(ac97_quirk, "AC'97 workaround for strange hardware.");
MODULE_PARM_DESC(buggy_semaphore, "Enable workaround for hardwares with problematic codec semaphores.");
MODULE_PARM_DESC(buggy_irq, "Enable workaround for buggy interrupts on some motherboards.");
MODULE_PARM_DESC(xbox, "Set to 1 for Xbox, if you have problems with the AC'97 codec detection.");
These are the options the module accepts.

I guess maybe "index" or "id" or "xbox" will help but i am not sure since i haven't used this driver.

Also, there is another thing you can try. run "alsaconf". It is a dialog-based shell script which tries to automatically find
and configure your soundcard. It has worked for many people.

As i said in my other post you can test the sound with "speaker-test -c 6"
 
Old 09-26-2005, 09:09 AM   #10
FliesLikeABrick
Member
 
Registered: Aug 2005
Location: NY,USA
Distribution: Debian, Gentoo, Ubuntu
Posts: 103

Rep: Reputation: 15
this happened to me when i first set up my desktop.


The solution is easy:

open the alsa mixer and turn up the volumes on the satellites, they are off by default
 
Old 09-26-2005, 04:57 PM   #11
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 426

Rep: Reputation: 99
Quote:
Originally posted by FliesLikeABrick
this happened to me when i first set up my desktop.


The solution is easy:

open the alsa mixer and turn up the volumes on the satellites, they are off by default
Yes, the ALSA mixer has all the channels muted be default.
you must run "alsamixer" and unmute the channels.

FliesLikeABrick, maybe i am wrong though but he led me to understand that he has stereo sound working. He can't
make 5.1 surround sound work, so it isn't about the mixer.
 
Old 09-26-2005, 04:59 PM   #12
FliesLikeABrick
Member
 
Registered: Aug 2005
Location: NY,USA
Distribution: Debian, Gentoo, Ubuntu
Posts: 103

Rep: Reputation: 15
oh, so he is getting sound out of the satellites?

My situation was that the satellites were muted, and i had to raise the levels on them. If he is getting stereo sound out of all speakers but not surround, that's beyond my wisdom, sry
 
Old 03-28-2006, 07:08 PM   #13
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
I am still stuck with the problem.... Any input??
 
Old 03-28-2006, 07:54 PM   #14
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
All Linux programs will only output 2 channels unless the source has encoded 6 channels. Outputting to 6 channels all the time will not work because each program have their way of handling ALSA requests. To make it even worst, your on-board sound can only handle one PCM stream at a time, so you have to use artd or esound to play multiple PCM streams at the same time.

An example to output 6 channels.
mplayer -ao alsa:device=surround51 -channels 6 dvd://

Outputting 6 channels all the time screws the quality of sound when hearing a two channel sound file. Audiophilies normally hear from only two channels.
 
Old 03-28-2006, 09:00 PM   #15
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
I use amarok. How do I do so that it outputs 6 channels? any idea??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
debain good for.... invizioN Debian 7 11-08-2004 10:18 AM
debain AGilley007 Debian 7 07-18-2004 06:55 PM
debain bookdisk bruj3w Debian 1 07-18-2004 05:10 PM
Can't install Debain kjp_72 Linux - Distributions 2 04-21-2003 01:49 PM
debain and xfree86 crashmeister Linux - Distributions 3 06-07-2002 05:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration