Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 09-09-2004, 10:48 PM   #1
LQ Newbie
Registered: Sep 2004
Posts: 9

Rep: Reputation: 0
Question 5.1 Channel Surround Edio PCI sound card not working

I installed the driver for the sound card:
SC3000D (CMI8738LX)
C-Media Electronics Inc.
driver named cmpci. yes it is a pci card of course.

I then reconfigured the Kernel.
Linux will recognize the card (CM8738) and the driver (CMPCI) under the Hardware Browser and will show an extra tab on the Volume Control panel, but no matter what I do
I cannot get anything other than the CD player, which is hooked directly into the card, to play.
I'm using Red Hat 9.0 Linux version 2.4, and I'am confused,
here is the copy of the instructions:


1. Backup the and Makefile in the sound driver directory


The provide help when you config driver in step

4, please backup the original one (/usr/src/linux/Document) and

copy this file.

The cmpci is document for the driver in detail, please copy it

to /usr/src/linux/Document/sound so you can refer it. Backup if

there is already one.

2. Extract the tar file by 'tar xvzf cmpci-xx.tar.gz' in the above


3. Change directory to /usr/src/linux

4. Config cm8338 driver by 'make menuconfig', 'make config' or

'make xconfig' command.

5. Please select Sound Card (CONFIG_SOUND=m) support and CMPCI

driver (CONFIG_SOUND_CMPCI=m) as modules. Resident mode not tested.

For driver option, please refer 'DRIVER PARAMETER'

6. Compile the kernel if necessary.

7. Compile the modules by 'make modules'.

8. Install the modules by 'make modules_install'



1. Before first time to run the driver, create module dependency by

'depmod -a'

2. To install the driver manually, enter 'modprobe cmpci'.

3. Driver installation for various distributions:

a. Slackware 4.0

Add the 'modprobe cmpci' command in your /etc/rc.d/rc.modules you can start the driver automatically each time booting.

b. Caldera OpenLinux 2.2

Use LISA to load the cmpci module.

c. RedHat 6.0 and S.u.S.E. 6.1

Add following command in /etc/conf.modules:

alias sound cmpci

When I got to number 7, it gave me this:

make[1]: *** [cpufreq.o] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.20-8/kernel'
make: *** [_mod_kernel] Error 2

...and of course from there nothing worked. so If I've overlooked something, or if anyone has any suggestions as to what to do, please help. it will be greatly appreciated. Thank you for your time.

Joshua M. Hull
Old 09-09-2004, 11:28 PM   #2
LQ Guru
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Try using ALSA drivers. Read the instructions to compile for your sound chipset.
Old 09-10-2004, 12:13 AM   #3
LQ Veteran
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
p3_141597i -- Welcome to LQ! What problem exactly are you trying to solve? Are you having a problem installing a driver, recompiling the kernel, or is it just that you can't get the sound to work? You've done a nice job describing your setup but I'm not sure you have made the problem clear.

To add to what Electro said, by default, the volume leves are muted. You may need to run "alsamixer" to raise them to an audible level -- J.W.
Old 09-10-2004, 12:42 AM   #4
LQ Newbie
Registered: Sep 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Wink Gottcha

Wow you guys are quick!
Thanks for your input, maybe I didn't explain the problem clearly enough, sorry about that this is my first time on the forum.
Mainly the sound is not audible, but the volume does adjust, I can hear the static getting louder when I put the volume up. I think the kernel is having problems compiling, a problem I hope to fix when I finish upgrading to Fedora Core 2.
But I'll try this ALSA driver, if I can find it somewhere, but it will be a problem I'll have to fix tomorrow, I have to repartition my HD right now, so that will take priority over sound. But thanks again for everyone who has replied, it will be helpful.
Thanks again.

Joshua M. Hull
Old 09-11-2004, 02:24 AM   #5
LQ Newbie
Registered: Sep 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Question ALSA driver

Ok, I downloaded the libraries, drivers, etc from the ALSA web page,
I followed the instructions listed on this page:

When I got to the part to add modules to the kernel, "Now insert the modules into the kernel.

modprobe snd-cmipci;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss"

This i perfomed as such:

sbin]# ./modprobe snd-cmipci;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss

/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol schedule_work
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.20-8/kernel/sound/acore/snd.o failed
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod snd-cmipci failed
bash: modprobe: command not found
bash: modprobe: command not found
bash: modprobe: command not found

So I'am stuck at this point, because Alsamixer won't run either.

Addtional Information:
What I got from modinfo as listed to perform on the installation instructions.

sbin]# ./modinfo soundcore
filename: /lib/modules/2.4.20-8/kernel/drivers/sound/soundcore.o
description: "Core sound module"
author: "Alan Cox"
license: "GPL"

Any suggestions???
Thanks for your help,
Joshua M. Hull

# ./modinfo soundcore
filename: /lib/modules/2.4.20-8/kernel/drivers/sound/soundcore.o
description: "Core sound module"
author: "Alan Cox"
license: "GPL"
Old 09-11-2004, 04:15 PM   #6
LQ Guru
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The errors comes up because sound modules were already loaded. You can type "service sound restart" as root or su. It should look at /etc/modules.conf and reload the sound modules. Also you may want to type "service alsa start". You will have to remove the kernel module (OSS) to load ALSA modules. Post your /etc/modules.conf file.

I hope you did not use the semicolon because compiling will fail if there is any errors. I suggest && instead of semicolon because if one command fails it will then stop. Semicolons do not stop at errors. It continues onto the next group of commands.
Old 09-28-2004, 03:05 PM   #7
LQ Newbie
Registered: Sep 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Center/ LFE (Subwoofer) channel not responding

I did figure how to load to module, thanks for all your guy's help.

Though I think something is wrong, because I can use mplayer to play the 5.1 channels "mplayer -channels 6 file.mpg"
but the Center and Sub woofer channel won't have any sound coming out, I checked the cables but there doesn't seem to be a problem there. So what I have so far is something capable of supporting 4 channels from an AC3 codec or 5.1 audio stream from a DVD.... Does anyone know why might I be having a problem with the Center/Sub channels is there something under ALSA I can check for that or is this possibly requiring more research into possible hardware malfunction???

Thanks for your time and help, it is most appreciated.

Joshua M. Hull
Old 09-28-2004, 04:55 PM   #8
LQ Guru
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Run alsamixer and scroll all the way towards the right using right arrow keys. You should see subwoofer and center settings although not all modules (drivers) have these settings. If you do not then it is time to put a bug report at ALSA site.

You should use something like:
mplayer -ao alsa:device=surround51 -channels 6 file.mpg

Instead of:
mplayer -channels 6 file.mpg
Old 02-08-2005, 09:39 PM   #9
Registered: Jul 2003
Location: NC
Distribution: Fedora,Mepis,Debian
Posts: 84

Rep: Reputation: 15
I have the same card and there is a teeny jumper on the card itself which has something to with the center channel and whether you select that to be line-in or center woofer.??? i just bought it so I don't yet have it working. I appreciate your thread and efforts.
Old 02-09-2005, 12:31 PM   #10
LQ Newbie
Registered: Sep 2004
Posts: 9

Original Poster
Rep: Reputation: 0
The card jumper

Yes there is a Tiny jumper there, I did configure that from what I remember it shouldn't matter how you configure that when you have everything hooked up sub I think plugs into the mic jack and my center is line-in. and when you run alsamixer you can change weather you want mic on or as center and line in as sub channel or not. But I figured out it seems that the alsa driver will only support the 4 channel sound mixer it seems. Which is for this card some type of surround sound mixer that will simulate a 4/5.1 channel output. To get the the 4.1 output you have to turn on the 4 channel option under alsamixer (way at the right end). and select your 5.1 input on your reciever, run your mplayer or whatever in 4 channel mode, this should give you a 4.1 output, it seems to work nicely, but I got fed up with trying to work with alsa driver and installed windows as a dual boot, and now running the real cmpci driver through windows and I created a vfat partition that I can temporarly copy movies to to watch then boot into windows and watch them with the windows version of mplayer in REAL 5.1 which is supported under the windows driver. I have submitted some info to Alsa about this problem, but I haven't heard anything back. But it seems I'm not the only one to have problems. Hope you find a solution. Cheers


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Surround Sound and Audigy Card Memzback Linux - Newbie 4 12-01-2004 04:03 PM
Channel 6 Not Working With TV Card kerbe6 Linux - Software 2 11-25-2004 03:01 AM
My 6.1 Surround Sound stopped working GiZiM Linux - Software 5 10-05-2004 06:00 AM
Surround Sound Speakers not fully working Norin311 Linux - Software 2 09-12-2004 08:02 PM
HowTo get surround sound (4.1/5.1) working Wynand1 Linux - Newbie 1 03-05-2004 10:58 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:56 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration