-   Linux - Hardware (
-   -   3d won't initialize with radeon 5470 and debian lenny with custom kernel (

icon269 05-13-2010 06:45 PM

3d won't initialize with radeon 5470 and debian lenny with custom kernel
Hey there am a bit of a newb but learn and follow directions very well so please bear with me.

I recently got a new dell studio 1558 with radeon hd 5470 video card. So far have had lot of small problems and such but been able to fix the via google and a lil luck but now I'm stumped with this one and decided to try and turn here for some possible help. Now on to the details.

Distro - Debian lenny with custom kernel
propriatory lgrfx 10.4 drivers installed direct from ati (installed no problem)

after compiling the kernel and installing the drivers from ATI my card IS recognized and X will boot up with the proper resolution, but that's where all the problems start. I can no longer switch to virtual terminals (ctrl-alt-F1,F2,F3,F4 etc) and graphics performance in X is extremely poor due to the fact that 3D fails to initialize, and catalyst control fails to load (it tries to but then just disappears)

now for the little info I've been able to gather I hope it helps.

cat /var/log/Xorg.0.log | grep '(WW)'


        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Hasn't establisted DRM connection
(WW) fglrx(0): No DRM connection for driver fglrx.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)            *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(WW) fglrx(0): Textured Video not supported without DRI enabled.
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used

cat /var/log/Xorg.0.log | grep '(EE)'

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) fglrx(0): Hasn't establisted DRM connection
(EE) fglrx(0): Hasn't establisted DRM connection
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) fglrx(0): XMM failed to open CMMQS connection.


X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  132 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  13
  Current serial number in output stream:  13

cat /etc/X11/xorg.conf


Section "ServerLayout"
        Identifier    " Configured"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        RgbPath      "/etc/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/X11/misc"
        FontPath    "/usr/share/fonts/X11/cyrillic"
        FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/Type1"
        FontPath    "/usr/share/fonts/X11/100dpi"
        FontPath    "/usr/share/fonts/X11/75dpi"
        FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

Section "Module"
        Load  "record"
        Load  "dbe"
        Load  "xtrap"
        Load  "GLcore"
        Load  "glx"
        Load  "dri"
        Load  "extmod"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID      "PCI:2:0:0"

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24

modprobe -v fglrx

FATAL: Module fglrx not found.
dpkg -l |grep fglrx

rc  fglrx-atieventsd                      1:8-12-4                            external events daemon for the non-free AMD/
rc  fglrx-control                        1:8-12-4                            control panel for the non-free AMD/ATI r5xx,
rc  fglrx-driver                          1:8-12-4                            non-free AMD/ATI r5xx, r6xx, r7xx display dr
rc  fglrx-glx                            1:8-12-4                            proprietary libGL for the non-free AMD/ATI r
rc  fglrx-modules-2.6.26-2-686            2.6.26+8-12-2+lenny1                Display driver for AMD/ATI Radeon and FireGL
rc  fglrx-modules-2.6.26-2-686-bigmem    2.6.26+8-12-2+lenny1                Display driver for AMD/ATI Radeon and FireGL

and that's about as far as I've gotten. At this point I'm at a complete loss and majority of google searches I've done have come up with very outdated information, or seperate problems.
On a side note before I installed Debian I has installed ubuntu lucid to test things out and video and everything seemed to work fine with minor tearing issues here and there. So it does seem to be entirely possible to run this car din X, just a matter of figuring out what I am doing wrong or where the problem exists.
Please let me know if there is any more additional info needed.

adamk75 05-13-2010 07:34 PM

Apparently the kernel module was never compiled against Did you get some error saying that the kernel module failed to build when you installed the driver?


icon269 05-13-2010 08:02 PM

thanks for the reply adam

from what I saw driver gave no errors at all when it installed. Just used the ati .run installer. Should I uninstall and see if I can reinstall via command line to try and spot any errors?

as I said I am still pretty new to linux (have only mildly played with it over the years. This is first true attempt to run i as a main OS) any idea what would cause the kernel module not to compile against it? and any ways to check/fix? I only ask because I just compiled the new kernel recently after some reading pointed to needing the new kernel in order to run the card and was my first time doing it in many years (think last time was the old 3.5 inch floppy install of debian back in the 90's heh) Followed a wiki guide and had little to no real problems. and I did try to meticulously make sure anything I would need was either enabled or at the very least modularized (assuming modularized meant could use/call on it later easily).

installed the graphics driver the next day after compiling the kernel (twice after double checking all previous fglrx files were gone) both times it SEEMED to install without any issues

also after some more research I came across this while I did not use the package installed (got driver directly from ati since it was the most recent) I was curious if it may be a similar issue? I'll admit when it comes to patches and most fixes posted in bugs unless it shows step by step or says what to edit directly I'm at a complete loss as to where to even begin or what to do.

adamk75 05-13-2010 08:12 PM

Actually, newer kernels are generally a bad idea when it comes to fglrx. I haven't touched Debian in years, and wouldn't use such an old distribution as Lenny, but I that it's possible to create distribution specific packages for many distributions using the --buildpkg argument when running the .run file from AMD. You can use --listpkg to see if Debian Lenny is listed and then build the the packages and install them with dpkg. Then, I believe you can use module-assistant ( to build the kernel module (assuming they will compile against 2.6.33 without extra patching).


icon269 05-13-2010 09:10 PM

alright after looking into it more this definitely seems to be a large part of if not the issue, now just trying to figure out how to fix it. I loaded up module assistant and tried to build the lgrfx kernel module but it gives me an error saying that the kernel headers for target kernel could not be found, and tell me I can install them with my custom header package via update, I do that and it just keeps giving the same errors when I try to build. So I'm guessing that means I need to find or make a patch and then figure out how to apply it as well? or is it a matter of editing a simple file somewhere to include the -custom heading I gave the kernel when I compiled?

icon269 05-13-2010 10:59 PM

ok well after some trial and error and playing around it looks like the header problem comes from utsversion.h and some other files being moved to /lib/modules/2.6*/build/include/generated from */include/linux I tried just copying the files back and as you can guess it didn't work (did get past the errors just to have a entire slew of other errors). Anyway at this point I don't know I think I'm about to give up at this poit, this stuff seems way over my head and I seem to be causing more harm then good to my system. At least from what I've seen I'm not the only person having issues with fglrx and so maybe I'll just wait till .4 and hope it's fixed then. And as for the newer kernel, I generally never would have even bothered to update it if I hadn't found documentation saying it was needed in order to use the 5740 card with fglrx. maybe i'll try taking a step back and seeing if anyone has gotten it running on 2.6.32

adamk75 05-14-2010 04:51 AM

Waiting for isn't going to change anything. Newer fglrx drivers will be the only thing that's going to get fglrx working on 2.6.33.* without patch. However, there are definitely patches to get fglrx to compile against 2.6.33:

But, yes, I believe fglrx works on 2.6.32 without any patching involved.


icon269 05-14-2010 02:42 PM

alright well after some extensive looking and trying to go with 33.4 kernel I came across a bug report which turns out that the kernel package file for debian lenny has an old version of libc6 which is what was causing utsversion errors and not being found. So got a deb to istall the newest version, kernel compiled no problem and am hoping it fixes the issue of the kernel module not installing, at this point I'm optimistic and don't see why it wouldn't. (also I don't think I enabled a few things needed on the last compile). Will post again to update if it worked or now.

Thanks again for all your help Adam, sometimes just a push in the right direction is all someone needs to narrow an issue down, before this post I had no real idea what kernel modules were and I really did learn a lot. So here's hoping it works!

All times are GMT -5. The time now is 02:28 PM.