LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-22-2003, 12:15 AM   #1
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Rep: Reputation: 15
rpm modem drivers not loading


i have rh9 dual boot with winxp pro, trying to get my modem to work with rh9, it's a bitch. i go to hardware management, it lists all the hardware i have on my computer, my modem is not listed as being there, ethernet card is though...

all i know is it's a 3com modem v90 56k. i read somewhere that 90% of PCI internal modems are compatible with linux (i read that in a linux for dummies book actually...), and i cant figure it out. what do i do? it's in "com 3" which is ... ttsy3 ... or something like that. anyways...ive gone through the "internet connection wizard" and set it up...tried to activate it, and it has activated it...then when i try to dial a connection, the dialogue that says "making a connection, please wait" (or something) just sits there forever...what's up with that? any help is greatly appreciated.

thanks in advance

Last edited by warheros; 06-22-2003 at 06:37 PM.
 
Old 06-22-2003, 12:24 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 253Reputation: 253Reputation: 253
Is it a winmodem? If it is, there is a slight chance that it might not work.. to find out if it is supported, that's if its a winmodem, check out this site for more information.. www.linmodems.org
 
Old 06-22-2003, 12:28 AM   #3
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
yea, but it says that no 3com drivers were available as of may 2001, kind of old and i would've thought that there would be some by now...and i cant find a more updated list.
 
Old 06-22-2003, 12:29 AM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 253Reputation: 253Reputation: 253
What's the model number of your card? Maybe someone here might be able to find an updated list, etc for support.
 
Old 06-22-2003, 12:34 AM   #5
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
how do i figure that out
 
Old 06-22-2003, 12:46 AM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 253Reputation: 253Reputation: 253
Either with the original box/manual/drivers disks maybe for windows.. etc.
Or you can maybe do a lspci from within Linux to find out possibly if its recognizing it at all.
 
Old 06-22-2003, 12:54 AM   #7
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
i opened my machine and took out the card and read what was on it, this is what i found:

on a chip it said this, in this order:

conexant
RH56D-PCI
R6795-12
E138292.1
0126

and this is what a representative from dell sent me regarding my modem:

Conexant HCF V.90 56K Data Fax PCI Modem

is this any help?
 
Old 06-22-2003, 02:37 AM   #8
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
i opened this file:

/proc/ioports

and among others, i saw this in there:

dcd8-dcdf : Conexant HCF 56k Data/Fax Modem

so im assuming it knows there is a modem there...or am i wrong??

Last edited by warheros; 06-22-2003 at 02:41 AM.
 
Old 06-22-2003, 02:57 AM   #9
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
ok so i found drivers for it, they're SUPPOSED to be drivers for it, i download them, double-click on them to start the setup, and it starts, then the dialogue disappears and nothing happens, hence, nothing is installed. what's up with that?

Last edited by warheros; 06-22-2003 at 08:07 AM.
 
Old 06-22-2003, 06:38 PM   #10
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
*bump*
 
Old 06-22-2003, 06:42 PM   #11
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 253Reputation: 253Reputation: 253
Quote:
Originally posted by warheros
ok so i found drivers for it, they're SUPPOSED to be drivers for it, i download them, double-click on them to start the setup, and it starts, then the dialogue disappears and nothing happens, hence, nothing is installed. what's up with that?
Where did you get the drivers from? And what kind of files are they, like tar.gz, .bin or rpm?
 
Old 06-22-2003, 11:42 PM   #12
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
the best matched driver was a *.rpm, then i tried the one you try when the first one doesnt work, that was also an *.rpm, then their last resort file was a *.tar.gz. none of them worked. i got them all from the conexant site, which i guess is partnered with linuxant for the use of downloading their drivers.

i hope that helps in some way?
 
Old 06-23-2003, 01:27 PM   #13
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Original Poster
Rep: Reputation: 15
*bump*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3com mini pci network card problems NCAussie Linux - Networking 0 07-08-2005 12:57 PM
3com 10/100 Mini PCI Problems NCAussie Linux - Networking 0 05-26-2005 12:01 PM
3Com Homeconnect ADSL Modem PCI NicoLinux Linux - Hardware 1 02-05-2005 04:36 PM
PCI modem problems ToothlessRebel Linux - Hardware 4 09-20-2004 09:08 AM
Linux 7.0 RHat doesn't see my PCI 3com modem bhedberg Linux - General 3 08-20-2001 02:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration