LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-13-2004, 04:24 AM   #1
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 872

Rep: Reputation: 124Reputation: 124
Unhappy 3c905c ethernet card not working with 2.6 kernel, MDK10; tried all other forums


Hi, everybody.

I've recently installed Mandrake 10 Community on my system, and have come upon a real stumper of a problem with my ethernet card. eth0 always fails to load, which makes sense because according to 3COM's web site, the driver that comes with the distrobution (3c50x) is incompatible with my card, the 3c905C-TX. I have downloaded all their drivers and scoured the internet for more, but have come to a brick wall in that I can't get them to install properly.

During the module process there are many pages of error messages and finally when I go to load the module ("insmod 3c90x.o", according to their instructions), it says it's an "invalid module format." With some of the other drivers I've tried they simply won't compile at all, though I *think* I've executed their instructions exactly. I've inserted the alias "eth0 3c90x" into the /etc/modules file, but it persists in loading the version that doesn't work, 3c50x.

Any help you can render would be immensly appreciated. Thanks!

--Dane
 
Old 05-13-2004, 09:39 AM   #2
slimjim
Member
 
Registered: Apr 2004
Location: east midlands, england
Distribution: Ubuntu 9.04
Posts: 56

Rep: Reputation: 15
(as root) try:

modprobe 3c90x

.. if that works, add

alias eth0 3c90x

to /etc/modprobe.conf
 
Old 05-13-2004, 01:49 PM   #3
tsw
Member
 
Registered: May 2004
Location: Colorado
Distribution: Mandrake 10 power-pack
Posts: 74

Rep: Reputation: 15
Hey DaneM,
I have the exact same problem with exact ethernet card. Kernel 2.6.** does not like it. I am very much a newbie, so I am still finding my way around. I was able to get the card configured properly with the 2.4.25-2mdk kernel that came with the installation. However, I, like you, would like to run the 2.6.*.*mdk kernel. It is just so very robust on my other machine.

Have you found anything that works yet. I have yet to try the possible solution above as I have just discovered this thread. I'll power down and reboot into the 2.6 kernel and give it a try. I am glad I am not the only one with this problem. Good luck.

tsw
 
Old 05-13-2004, 02:53 PM   #4
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 872

Original Poster
Rep: Reputation: 124Reputation: 124
Hi, everybody! Thanks very much for the responses. I'll give your suggestion a try, slimjim. I just got another reply from somebody in another thread, and have yet to try that. Here's the link: http://www.linuxquestions.org/questi...471#post931471

I'll let you all know if I manage to get this working and post my solution!

Thanks!

--Dane
 
Old 05-13-2004, 04:06 PM   #5
mermxx
Member
 
Registered: Apr 2004
Location: Wales
Distribution: rh9, winxp
Posts: 411

Rep: Reputation: 30
Have u tried the `man ifconfig` pages to see if they can help u?
 
Old 05-13-2004, 09:13 PM   #6
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
If anyone's searching for the drivers, you should be able to find them here: http://support.3com.com/infodeli/too...uxdownload.htm -- J.W.
 
Old 05-13-2004, 10:43 PM   #7
LavaDevil94
LQ Guru
 
Registered: Jul 2003
Distribution: Gentoo 2004.2: Who needs exmmpkg when you have emerge?
Posts: 1,795

Rep: Reputation: 47
The .o module format has been deprecated by the new module format in the 2.6 kernels (I believe its .ko). Youll have to find a 2.6 kernel module, or compile the module from sources.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot seem to get ethernet card working. Help!! MikeyS Linux - Newbie 7 08-18-2005 07:46 AM
ethernet card not working joshyjosh1289 Linux - Hardware 5 02-21-2005 03:48 PM
ethernet card not working Dasc Linux - Hardware 3 08-13-2004 11:21 AM
Radeon 9600 XT in MDK10 (no 3d) - tried all other forums DaneM Linux - Hardware 18 06-10-2004 05:26 AM
NFS and Samba shares not working on MDK10, kernel 2.6.6 server DaneM Linux - Software 1 05-29-2004 09:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration