LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-08-2003, 02:00 AM   #1
PalluX
LQ Newbie
 
Registered: Jun 2003
Posts: 4

Rep: Reputation: 0
25 sec. pause when booting, help!


ok, i have Suse 8.2 and a intel d845pebt2 mobo w/ on board serial ATA(which i don't use)
When booting linux trys to find drives on ide2 and ide3(the serial ide's). it the reports an invalid response. the whole thing wastes like 25-30 seconds. how can i fix this? btw, there's no option in the bios to disable the serial ata
 
Old 06-08-2003, 03:35 AM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I'm not sure if I understand your problem... In Redhat, we have a tool called "services" located at:

/usr/bin/redhat-config-services

That you can run from command line with "redhat-config-services"... With this tool, you can choose which "services" are going to be used at the boot up. I'm sure there might be a similar tool to Suse, but I don't know how it's called...
Well, I wish you good luck.
 
Old 06-08-2003, 05:57 AM   #3
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 7
Posts: 1,257

Rep: Reputation: 61
What you want is YAST2 -> System -> Runlevel Editor

It's fairly self-explanitory.
I don't have this hardware so i don't know which init.d script is being used to load it. If you get stuck, you can post a short section leading up to where it hangs and we can try and make an educated guess.
 
Old 06-08-2003, 01:01 PM   #4
PalluX
LQ Newbie
 
Registered: Jun 2003
Posts: 4

Original Poster
Rep: Reputation: 0
i checked out the run level editor and still don't know what to change. here is the prob. The no response part:

<6>ICH4: chipset revision 2
<6>ICH4: not 100%% native mode: will probe irqs later
<6> ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hdaMA, hdbMA
<6> ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdcMA, hddMA
<6>SiI3112 Serial ATA: IDE controller at PCI slot 02:06.0
<6>SiI3112 Serial ATA: chipset revision 1
<6>SiI3112 Serial ATA: not 100%% native mode: will probe irqs later
<6> ide2: MMIO-DMA at 0xf8817c00-0xf8817c07, BIOS settings: hdeio, hdfio
<6> ide3: MMIO-DMA at 0xf8817c08-0xf8817c0f, BIOS settings: hdgio, hdhio
<4>hda: Maxtor 6Y080P0, ATA DISK drive
<4>hdb: WDC WD1200JB-75CRA0, ATA DISK drive
<4>blk: queue c03ac0c0, I/O limit 4095Mb (mask 0xffffffff)
<4>blk: queue c03ac214, I/O limit 4095Mb (mask 0xffffffff)
<4>hdc: JLMS DVD-ROM LTD163D, ATAPI CD/DVD-ROM drive
<4>hdd: LITE-ON LTR-52246S, ATAPI CD/DVD-ROM drive
<4>hde: no response (status = 0xfe)
<4>hdg: no response (status = 0xfe)
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<4>ide1 at 0x170-0x177,0x376 on irq 15
<4>hda: attached ide-disk driver.
<4>hda: host protected area => 1
 
Old 06-08-2003, 08:22 PM   #5
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 7
Posts: 1,257

Rep: Reputation: 61
Try disabling boot.md and boot.lvm - just select that line and remove the check from the B box at the bottom then save and reboot and see what happens. boot.md is for raid and boot.lvm is for logical volumes. I think boot.md is the one that will do it for you.

HTH

I just wanted to add that if neither of these options works, you could try disabling harware scan on boot (from the run level editor as well). I didn't suggest it before because it seems like you're hanging prior to that point. It's a good thing to disable anyway - especially if you aren't changing your hardware.

Last edited by Franklin; 06-08-2003 at 08:45 PM.
 
Old 06-08-2003, 08:44 PM   #6
PalluX
LQ Newbie
 
Registered: Jun 2003
Posts: 4

Original Poster
Rep: Reputation: 0
thanks, but it didn't do anything
 
Old 06-08-2003, 08:46 PM   #7
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 7
Posts: 1,257

Rep: Reputation: 61
see my edit.
 
Old 06-08-2003, 08:53 PM   #8
PalluX
LQ Newbie
 
Registered: Jun 2003
Posts: 4

Original Poster
Rep: Reputation: 0
nope, still doesn't do it
 
Old 06-08-2003, 09:30 PM   #9
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 7
Posts: 1,257

Rep: Reputation: 61
Theres a thread at alt.os.linux.suse that is asking the same question. You may want to follow it.

Also, there is a new web forum at this address. It's very new and not too active yet, but you may get some leads here. Just SuSE.

http://www.suseforums.com/support/

The only other thing i can suggest is passing an option to the kernel at boot along the lines of ACPI=OFF for disabling acpi. But I have no idea what that would be.

Sorry I couldn't be of more help.
 
Old 06-09-2003, 07:44 PM   #10
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, Windows 7
Posts: 1,257

Rep: Reputation: 61
I just wanted to give you a heads-up on that alt.os.linux.suse thread.

They resolved your problem by passing a kernel option through grub.

hdx=none I believe it was. If you haven't checked it out do so. If you don't have usenet access let me know and I'll post the relevent threads.

regards

steve
 
Old 08-26-2003, 03:00 PM   #11
istvan
LQ Newbie
 
Registered: Jul 2003
Location: Switzerland
Posts: 1

Rep: Reputation: 0
I've a Gigabyte "GA-7VAXP ultra" Board and had absolutely the same problem with SuSE 8.2 installation as PalluX.
I could install suse with "safe settings". So I had no real problems with the installation.

My System: "GA-7VAXP ultra" / hda, hdb, DVD on IDE2 / hde, hdf, hdg, hdh on IDE 2&3 (second controller only as supplementary hd-controller used - not as raid) / sda, sdb, SCSI burner, SCSI CD-ROM / SATA not used.

For the moment suse works, but...
on booting IDE0, IDE1, IDE2 and IDE3 are recognized with all harddisks, DVD-ROM too.
then about 30 seconds nothing, then the response
hda : no response (status 0fxe)
then about 30 seconds nothing, then
hdb : no response (status 0fxe)

After booting and logging in, I get a working system but the installation of SuSE 8.2 on hda5 and all partitions of hda are listed up as hde-partitions.
So root is on hde5 instead of hda5 - as it is in reality!
Up to now i've no connection to the IDE2 and IDE3 harddisks.
With Knoppix 3.2 I have no problems - all disks and partitions are present as installed !?!?

Do you know more about this problem? Ideas of solutions? Internetlinks?

Thanks and regards
Istvan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10 Internet very slow (<1kb/sec) while windows got 50k/sec SafeTechs Mandriva 13 09-01-2006 04:07 PM
more complaints to the SEC jailbait General 1 06-22-2004 03:00 PM
Windows 98 sec the best? Mannyakatheman General 24 11-19-2003 07:03 PM
RH & HP4050N PCL - page, pause, page, pause, page andguent Linux - Hardware 0 11-10-2003 08:35 AM
hdparm 64MB in 19.68 sec=3.25 MB/sec illtbagu Linux - General 11 06-26-2003 07:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration