-   Linux - Hardware (
-   -   2.6 built-in alsa doesn't work (

simopal6 03-01-2007 02:04 PM

2.6 built-in alsa doesn't work
First of all, some info:


00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller (rev 21)
00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller (rev 21)
00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:01.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:01.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
02:02.0 Network controller: Intel Corp.: Unknown device 4220 (rev 05)

I'm running a Slackware distro with 2.6.19 linux kernel.

This is my story: some time ago, I installed alsa from source (alsa-lib, alsa-driver, alsa-utils). I've had problems with applications trying to play sounds simultaneously, so I look for information about dmix, and found out that it is automatically enabled on the alsa version I had installed. Then I checked whether my applications used alsa, and found out that, for example, XMMS didn't use the alsa library but OSS's one, and it worked (except for the mixing problem). I configured xmms to use alsa, but if i tried to play something a window would pop up telling me to check the soundcard. I unistalled alsa (with 'make uninstall' on the three packages: driver, lib, utils) and decided to use the kernel built-in alsa support. I recompiled the kernel, built alsa as a module, built oss compatibilty modules too, and rebooted. Now, xmms with oss doesn't work anymore and the alsa library isn't even shown in the list of available plugins. If i try to play sounds with OSS, xmms seems to be working but doesn't output any sound and it says:
Code: cannot open shared object file: No such file or directory
Also, i've read i should run alsaconf, alsamixer, etc. but i can't find them!

Can you help me please??
Thanks to anyone

weibullguy 03-01-2007 03:10 PM

All you installed was the ALSA driver. You still need the ALSA libraries and ALSA utilities (alsaconf and alsamixer).

simopal6 03-01-2007 04:16 PM

Thanks you, sounds work again now.

Just one doubt, how do i tell applications that they must use alsa and not oss? I still have the mixing problem, and i think that the cause might be the fact that there are applications which still use oss.

For example:

Gaim: the sound section wants a command to use when gaim need to play a sound. Defauly is 'play', but it uses oss, doesn't it? When i run 'play', xmms (which uses alsa) tells me to check whether another application is blocking the device, which i think is /dev/dsp.

TeamSpeak: sound driver to use can be set to:
- default (oss /dev/dsp)
- default network (8780:L, don't know what this means)
- other (there is a text field whose value is /dev/dsp).

Thanks for your help!

simopal6 03-05-2007 05:02 AM

Mixing works now, but only if applications use alsa.
Can you help me?

simopal6 03-05-2007 05:35 AM

There is the command 'aplay' which plays sounds using alsa, so the problem with gaim is solved. But what driver do i have to use to play sounds with alsa??

All times are GMT -5. The time now is 06:45 AM.