-   Linux - Hardware (
-   -   1920x1080 and 1280x1024 (dual head) on AGP Matrox parhelia or Sapphire Radeon HD (

bennyt 02-06-2012 07:18 AM

1920x1080 and 1280x1024 (dual head) on AGP Matrox parhelia or Sapphire Radeon HD

I'm banging my head against a daft problem because I won't let my Pentium 3 go. Running slackware 12.2 (yes it prob needs updating but has served me well for years). Gfx cards below are AGP.

Problem: I have an HD screen and a 19" screen that I want to run simultaneously. My matrox parhelia (driver courtesy of the amazing seems not to want to run 1920x1080 AND 1280x1024 (claiming the pixel clock must be the same for each screen). Otherwise it works brilliantly and I think would do 1920x1080 dual head, if only I had two HD screens. (It does dual 1280x1024 no probs)

I also have a Sapphire Radeon HD 3650 (dual head) that just will not run properly with the catalyst (fglrx) drivers. I've updated the kernel (from my current to and tried various versions. The only driver that works at all (8.12 I think from the AMD website) does not run well, providing no xv playback, and incorrectly identifies my version of xorg as 7.1 when in fact it is 6.9 (though newer versions of catalyst do identify the xorg version correctly but either don't build or build and cause the system to hard crash). I'm not even sure the drivers will be fully functional on the Sapphire (proprietary) card.

Sooooo, if anyone has experience running a Sapphire Radeon card on an older build (or knows how to force the Matrox to do different resolutions, that it claims to do) I'd be delighted to hear from you!

Many thanks

ps I am considering a full OS update to 13.1 but prefer to avoid it as the aging Matrox driver will not compile and I'll be forced to either use the Radeon (which might not work anyway) or replace the system (which I could but costs more time and money, and I lose my beloved P3 :) )

bennyt 02-08-2012 07:25 PM

Three kernel builds and a boat load of catalyst driver builds to no avail. I think maybe my xorg modules and build got a bit messed up when I originally got the Matrox working, that and slackware 12.2 is just too old.

At any rate, I found a spare hard disk and did a fresh install of 13.3. Fired up instantly, standard kernel radeon driver (no horrible fglrx build) all working, xv and glx extensions, lurvely (except the mplayer crash after it was on pause for ages).

So anyway my bad ass P3 system seems to have a new lease of life!

Will mark as solved.

All times are GMT -5. The time now is 12:41 AM.