LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-15-2006, 09:41 AM   #1
Ian D
Member
 
Registered: Aug 2005
Location: Solihull, UK
Distribution: Fedora 26
Posts: 140

Rep: Reputation: 15
1280x1024 Flat Screen Monitor


Background
I HAD a CRT monitor connected via a KVM switch to a number of computers. The screen worked fine except with my work Laptop (running Windows XP) when it would jitter from side to side. It was suggested to me that the problem was actually in the Monitor and this was confirmed by putting a different screen on the laptop.

Problem
I bought a new 1280x1024, 19" Samsung Flatscreen monitor and this works fine with the laptop. However, when I connect it to my Linux (FC5) machine, I get problems.
The POST comes up OK.
Then I get a graphical screen telling me that it will boot Linux in 3 seconds.
Then I get a text based screen as it boots Linux - but the first 3 characters of each line are missing.
Then I get a warning from the monitor that the ideal resolution is 1280x1024 which floats around the screen and eventually I get to log in.
I log in as root (because I want to go and change the display characteristics), but I get about as far as "System|Preferences" and the screen goes blank. (I don't get to see anything to change.)
The only thing that makes an obvious difference then is the computer power button.
If I switch back to the old monitor, it is fine and does come up in 1280x1024 resolution.
The documentation that came with the monitor says that I should run X86Config - and the instructions look as though they would probably make sense if I could see anything.

Question
Any ideas as to what I am supposed to do? If I need to start the system is some other mode, please take a moment to tell me how.

Thanks
 
Old 12-15-2006, 11:00 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Try booting once more with the FC5 system.........

When the grub splash screen is displayed press the 'Esc' key
Select the Linux boot choice and press the 'e' key
Select the line the begins with kernel and press the 'e' key
At the end of the line add a space followed by vga=793 3
example: kernel /vmlinuz-2.6.19.1 ro root=LABEL=/1 rhgb quiet vga=793 3

When done press the 'Enter' key followed by the 'b' key

Log on as root and either edit the /etc/X11/xorg.conf file to reflect the monitors resolution of 1280x1024 or try typing something like;

system-config-display --set-resolution=1280x1024 --set-depth=16
 
Old 12-15-2006, 12:30 PM   #3
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,247
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
Sounds to me like the issue with the original monitor and the new screen are both related to improper refresh rates..

I hooked my Linux box to a LCD the other day and brought it up in 1280x1024 @ 75 hz and it shimmied from side to side pretty bad, a quick tweak of the refresh rates in xorg.conf to force it down to 60hz at that resolution and the image is flawless..
 
Old 12-15-2006, 12:39 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,110

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
This works fine for my 1280x1024 LCD monitor
Excerpt from xorg.conf:
Code:
Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        HorizSync       28-64
        VertRefresh     43-60
EndSection
For badly-behaving text screens, you either need to pass vga= some number to your kernel as it boots (as Lenard suggested), or (and the only option that works for me) is to add vga=normal to your kernel boot line.
 
Old 12-15-2006, 12:49 PM   #5
Ian D
Member
 
Registered: Aug 2005
Location: Solihull, UK
Distribution: Fedora 26
Posts: 140

Original Poster
Rep: Reputation: 15
I did as Lenard suggested - but hte screen went blank as soon at the booting process began (i.e. after I had pressed 'b').

I could use the old CRT to make modifications to any file required - so I could add lines to xorg.conf. Would I be able to find out from my Window XP machine the identifier to put into xorg.conf in place of "Generic Monitor"?

Where can I read about the options (e.g. DPMS)

Also HorizSync?

I guess thatVertRefresh is just the recommended Refresh Rate.

Thanks
 
Old 12-15-2006, 12:55 PM   #6
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,247
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
The proper HorizSync and VertRefresh rates for you monitor should be listed in the manual for the monitor. Or you can find them on the manufacturers website.


DPMS
http://linuxreviews.org/howtos/power/xorg_dpms/
http://unixhelp.ed.ac.uk/CGI/man-cgi?xset+1
 
Old 12-15-2006, 04:41 PM   #7
Ian D
Member
 
Registered: Aug 2005
Location: Solihull, UK
Distribution: Fedora 26
Posts: 140

Original Poster
Rep: Reputation: 15
Thanks for your help.

I found that when the screen went blank, if I powered it off and on again, it restored and I could get in and modify things. I guess that the monitor was on a timer and thought "If you ignore my warning about resolution for too long - I'll just switch off."

Anyway, with the picture restored, I was able to change the display to something close to the actual screen and then get into xorg.conf and limit the refresh rate to the recommended value and it works. At least the GUI part works.

It still drops the first 3 characters of every line when in 'text mode' - but hey.
 
Old 12-15-2006, 05:58 PM   #8
teyster2
LQ Newbie
 
Registered: Nov 2006
Location: Luverne, AL
Distribution: Kubuntu
Posts: 11

Rep: Reputation: 0
Had a similar problem with mt Sceptre 19" wide. May I suggest you try this: As root - dpkg-reconfigure -phigh xserver-xorg
It works great and you select the video card and any numerous resolutions you desire to use.
Please reboot after reconfiguring.
 
Old 12-15-2006, 09:42 PM   #9
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,247
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
You shouldn't have to reboot.. this is Linux after all. Just restart the X server. CTRL+ALT+BACKSPACE should cause the X server to shutdown if your system is running gdm, kdm or xdm (all the debian based distros do by default.. not sure about others ) X should restart automatically using the new settings. if it doesn't restart automatically then startx should do the trick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Thin client, flat screen monitor power consumption. schopel General 1 05-18-2006 01:37 PM
Problem w/ Flat Screen Monitor lyar1031 Linux - Newbie 2 01-24-2006 05:54 PM
Flat-screen monitor? etcetera Linux - Hardware 2 09-04-2005 06:40 PM
Getting my monitor to go to 1280x1024(instead of 1280x960) fibbi Linux - Hardware 3 08-16-2004 03:57 PM
Flat Screen Monitor rstrass Linux - General 1 02-10-2002 08:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration