LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   10/100/100 Mbps D-link NIC on fc5 (https://www.linuxquestions.org/questions/linux-hardware-18/10-100-100-mbps-d-link-nic-on-fc5-601208/)

abhishekrahel 11-20-2007 02:39 PM

10/100/100 Mbps D-link NIC on fc5
 
Hi

I have a problem that i am working on FC5 but D-link 10/100/1000 Mbps
NIC is not detected.I tried to install driver for that.But i
am facing problem like this


Create tmp dir (/tmp/Sk98ICrYTkYKhMkibgUeQjmIh) [ OK ]
Check user id (0) [ OK ]
Check kernel version (2.6.15-1.2054_FC5smp) [ OK ]
Check kernel symbol file (/proc/kallsyms) [ OK ]
Check kernel type (SMP) [ OK ]
Check number of CPUs (4) [ OK ]
Check architecture (found) [ OK ]
Set architecture (i386) [ OK ]
Check compiler (/usr/bin/gcc) [ OK ]
Check mcmodel flags (none) [ OK ]
Check module support (/sbin/insmod) [ OK ]
Check make (/usr/bin/make) [ OK ]
Check archive file (sk98lin) [ OK ]
Check kernel gcc version (4.1.0) (Kernel:4.1.0 == gcc:4.1.0) [ OK ]
Check sk98lin driver availability (not loaded) [ OK ]
Check kernel header files (not found) [ failed ]
Kernel header not found. Please install the linux header files
development package or crate a symbolic link from the
/usr/src/KERNEL_VERSION directory to linux
Example: ln -s /usr/src/KERNEL_VERSION /usr/src/linux

Installation of sk98lin driver module failed.
Delete temp directories./install.sh: line 1933: cd: /root/Desktop/Linux: No such file or directory
(done) {OK}



So please try to give me the way to solve this.
Thanks in advance.

Joebie 11-21-2007 07:13 AM

kernel-header
 
It says the kernel headers aren't installed have you checked if they're installed? You can check by rpm -q kernel-headers if it exists it will reply with kern-headers.xxx-yyy.rpm or something if it doesn't exist you can install it by the following command: yum install kernel-headers

abhishekrahel 11-22-2007 02:18 AM

Oh thanks for your response but when i tried to install kernel-headers
using the command as given below I got this:->

yum install kernel-headers
Error: Cannot find a valid baseurl for repo: extras
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
extras [1/3]
Cannot find a valid baseurl for repo: extras
Error: Cannot find a valid baseurl for repo: extras

Now can you Please help me what to do?


All times are GMT -5. The time now is 03:56 PM.