-   Linux - Hardware (
-   -   [Ubuntu 6.06] Setting up DWL-G120 - Recognized, Can't grab IP (

barrmulio 06-07-2006 09:51 PM

[Ubuntu 6.06] Setting up DWL-G120 - Recognized, Can't grab IP
started over with a fresh ubuntu dapper desktop install and formatted everything - so...
- Dapper updated to latest files, included network-manager, ndisgtk, ndiswrapper
- Dapper finds the device on boot !! auto-setup as eth2

- In network manager, i see all the wireless networks around me
- However, the link is never established, my router never sees the device even attempting to connect

- In ndisgtk, I can install my driver (prisma02) but it says no hardware present
- With ndiswrapper -l, I get a prisma02 invalid driver error
- In networking, the device is there, tried with both dhcp and static and nothing

- Router is setup without encryption for easier troubleshooting, note that i tried some other non encrypted networks around me and I still can't connect. :cry:

I feel I must be close...please help!

thanks in advance!!

note, i've looked at
- ubuntuforusm for dwl-g120 (many threads w/o a solution)
- linuxquestions forums (mainly on older distros - none of the solutions worked)
- and obviously google for any keyword combination

beagle2 06-07-2006 11:51 PM

If your usbid matches that on the then it looks pretty straightforward - no problems reported on the ndiswrapper site. When you say the card is recognised at boot can you activate the connection like here ? Seems to me if there is a driver already being loaded for your card then no need for ndiswrapper - if it doesnt work then make sure its not loaded before trying ndiswrapper in case of conflicts.

barrmulio 06-08-2006 12:46 AM

thanks for the reply:
yes, the card is found like on the wiki - as eth2 and active, however, configuring to either static or dhcp doesn't made a difference. The logs on the router don't even show any attempt at a connection. iwconfig log shows AP invalid, link light on the device never goes on (power is one however)

my card is on that link too - a G120 B1 - it mentions a different set of cobranded drivers, which i'll try to dig up

beagle2 06-08-2006 01:02 AM

If thats the Prism_GT then looks well documented - good luck!

barrmulio 06-08-2006 08:42 PM

everything looks great now - i just cant figure out the last mile here's where I'm at:

iwlist scan - I see all the access points around me!
iwconfig eth2 - mode managed, channel 6, no wep, essid = Gecko, access point is there too

still no link....ugh
when i'm in Network Tools, won't show as it having grabbed a IP

sudo dhclient eth2 gets me no working links in database

beagle2 06-08-2006 09:33 PM

Only thing I can suggest now is to make sure you disable any unused/unwanted connections in the System-->Administration-->Networking menu if you havent already.Also this may help

All times are GMT -5. The time now is 10:09 PM.