LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   [TV]no signal in saa7133 (https://www.linuxquestions.org/questions/linux-hardware-18/%5Btv%5Dno-signal-in-saa7133-296322/)

sathia 03-01-2005 12:53 PM

[TV]no signal in saa7133
 
hi all, i think i installed correctly this card (asus tv fm saa7133).
in fact dmesg tells everything is ok. and i can read its name in the log.


i'm under slackware, and i had to create the device under /dev, the filesystem assigned is 81.

i don't know why tvtime and others progs can't get a single wave, tvtime give a blue screen of almost death in which there's written "no signal"

cat /dev/video0 answers correctly
cat /dev/video0 file.mpg
mplayer file.mpg gives errors about /dev/rtc.


what has to be done for this?

Any help will be appreciated.


Regards



Sat_

Electro 03-01-2005 06:16 PM

First of all, doing

cat /dev/video0 file.mpg
or
cat /dev/video0 > file.mpg

does nothing because it is not an MPEG-1/2 encoder card. Why you think that it would work? The SAA7133 is not an encoder. It is a video capture chip that captures raw information.

When using SAA7133 chips and kernel version 2.4.x, you need to use xawtv. If you dowloaded kernel version 2.6.10 or higher stable kernel version, the card will work with out any problems.

Ignore the error that mplayer can not read /dev/rtc because it is normal.

Post what is in /sbin/lsmod and dmesg logs.

sathia 03-01-2005 06:24 PM

thank you for your reply

this is what dmesg says after

# mknod /dev/video0 c 81 0
# modprobe saa7134 card=25 tuner=0 automute=1 audiomux=0,1 gbuffers=4 autoload=1

Linux video capture interface: v1.00
saa7134: Unknown parameter `automute'
saa7130/34: v4l2 driver version 0.2.12 loaded
saa7133[0]: found at 0000:00:0d.0, rev: 240, irq: 5, latency: 64, mmio: 0xf9c00000
saa7133[0]: subsystem: 1043:4845, board: ASUS TV-FM 7133 [card=25,insmod option]
saa7133[0]: board init: gpio is 0
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: dsp access wait timeout [bit=WRR]
saa7133[0]: i2c eeprom 00: 43 10 45 48 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 ff e2 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 02 03 01 01 04 08 ff 00 89 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tda9885/6/7: chip found @ 0x96
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0

Electro 03-02-2005 02:54 AM

Change the tuner in the tuner list in the kernel documentation. Also take out automute because it does not have that option. Read the tda988x or SAA713x documentation to figure out the audiomux because I do not know how to setup PAL version.

Use xawtv first. If it works, it should work with other programs. For the 2.4.x kernel you need to run xawtv first to get sound and then you can run other programs.

BTW, it works better on the kernel version 2.6.10 or higher stable kernel version.


All times are GMT -5. The time now is 11:42 AM.