-   Linux - Hardware (
-   -   [SOLVED]--Printer will not print, Ubuntu 12.0.4, cups 1.5.3 (

lgoldma 11-04-2012 08:03 AM

[SOLVED]--Printer will not print, Ubuntu 12.0.4, cups 1.5.3
I am trying to set up a VM for 12.0.4 and have it successfully loaded via VirtualBox. I have allowed access to the usb port with my Brother MFC printer and loaded the appropriate drivers.

When I open CUPS, I can add the printer but no test page is able to be printed. The message i see says "Waiting for Printer to become available"

usblp is loaded according to modprobe. When the brother driver was installed it created the printer on /dev/usb/lp0. However a ls for the dev results in the message 'No such file of directory'

What is the URI for a usb printer on Ubuntu? I checked the usblp doc and it notes that the device nodes can be found with:

ls -tr /dev/usb_prnt* /dev/usblp*
However, when I try the 'ls' I get the same message that these don't exist.

How do I get cups to print?
Thanks in advance.

camorri 11-04-2012 10:15 AM

Do you have Guest Additions installed? Have you gone to Devices-->USB Devices ? Does the printer show up there? Is there a check mark beside the printer?

lgoldma 11-04-2012 10:46 AM

Thank you for replying. All excellent questions. Yes, Guest addition is installed and the printer shows up in Devices-->USB devices. Yes, there is a check mark. Now you know why I am so frustrated. As far as I can tell, I have the correct settings in VirtualBox, and yet Ubuntu does not recognize the printer. I was wondering if there is some setting in Ubuntu that needs to be fixed to recognize a usb printer. When I add the printer there is no 'usb' choice for local printers only hp.
Thanks again. If you have further ideas, I'm open to hearing them.

camorri 11-04-2012 11:03 AM

What is the host system? Does the printer work on the host system?

The Ubuntu system, is it a 32 bit system, or a 64 bit system?

What model of printer? I know its a Brother. Did you use the Brother drivers?

lgoldma 11-04-2012 12:28 PM

64 bit system. model is Brother MFC J6710DW and I used the drivers from the Brothers linux site per their instructions
Printer is not working on host system at the moment because of a cups issue. It did before cups became inoperable. If I boot into an alternate OS (I have Mandriva 2010_2 on another partition and can boot into it via grub) then the printer works fine. I was hoping to be able to use the printer directly from the usb port on the guest Ubuntu VM.

I'll keep looking
thank you

camorri 11-04-2012 02:55 PM

I don't think it can work on the guest, until it works on the host system. As I understand it, the guest builds the print file, and passes it to the host for the printing. So if the host can not print....

On the guest, since it is 64 bit, did you follow these instructions :


Pre-required Procedure (5)
Related distributions
Debian 64 bit version, Ubuntu 64 bit version
Related products/drivers
printer/PC-FAX drivers
ia32-libs or lib32stdc++ is required to be installed.
Basically, this is a 32 bit driver, that needs compatibility libs to work.

lgoldma 11-04-2012 07:02 PM

Thanks I will check on those tomorrow. Still a work in progress. I will let you know after I have time to spend on it.

lgoldma 11-05-2012 05:19 AM

Thank you for your suggestions. Checked and the library was not installed to I did that. Then I edited the /lib/udev/rules.d files as suggested in this post

Then went back into CUPS and modified the printer URI. This time CUPS offered the Brother printer as a choice so I chose it and not the /dev/usp/lp0 which was there. Once I did all that the printer is working from the Ubuntu VM.

Thanks for your help.

camorri 11-05-2012 08:26 AM

Good stuff, could you mark this thread 'Solved'? Only the original poster can do that. ( Under thread tools at the top. )

All times are GMT -5. The time now is 03:12 PM.