-   Linux - Hardware (
-   -   [Solved] installing the Rosewill RNX-EasyN1 driver (

carltm 12-03-2010 04:24 PM

[Solved] installing the Rosewill RNX-EasyN1 driver
Rather than cover the things I tried that didn't work, here is the
way to get it to work with CentOS. These steps should also work
with other distros, I just haven't tested them.

1) Uninstall any remnants of previous drivers or firmware.

2) Download the rnx-easyn1_linux_v.2.1.1.bz2 file from

3) cd /usr/local/src and tar xvf rnx-easyn1_linux_w.2.1.1..bz2

4) cd 2009_0525_RT3070_Linux_STA_v2.1.1.0

5) configure the driver to use the OS's wpa_supplicant:
sed -i "s/WPA_SUPPLICANT=n/WPA_SUPPLICANT=y/" os/linux/

6) make; make install

7) mv /etc/Wireless/RT3070STA /etc/Wireless/RT2870STA

8) vi /etc/Wireless/RT2870STA/RT2870STA.dat
set the ESSID and any other needed values

9) modprobe rt3070sta; dhclient ra0

If step 9 works and you'd like the interface to come up
automatically in Red Hat or CentOS, run these commands:

echo "alias ra0 rt2870sta" >> /etc/modprobe.d/ra0
echo "DEVICE='ra0'" > /etc/sysconfig/network-scripts/ifcfg-ra0
echo "ONBOOT='yes'" >> /etc/sysconfig/network-scripts/ifcfg-ra0
echo "BOOTPROTO='dhcp'" >> /etc/sysconfig/network-scripts/ifcfg-ra0


All times are GMT -5. The time now is 12:53 PM.