-   Linux - Hardware (
-   -   [multihead] second video card hangs computer at startx (

geeksunny 10-11-2004 08:05 PM

[multihead] second video card hangs computer at startx
OK, I am really at a loss here. I have been working on flushing my computer and getting it running almost nonstop for the past 24 hours. I even called in sick to work today:( I hope someone here can at least help me figure out what is going wrong.

So the top pretty much outlines the problem I am addressing in this post (although there are about two or three other ones but they belong in different categories). There is going to be a lot of stuff that I'm going to put here, I want to provide everything that I know about what has happened.

The box is a 500mhz PIII with 256mb ram
(just in case that might be needed, though i doubt it.)
a ATi Radeon 7000VE with two VGA heads and 16mb of ram
a Trident TVGA something (i'm not sure of the model number but I can get it if needed) with 4mb of ram

Ok, the system had been running a Slackware10 install directly from the CD's since 10.0 was released near the end of June (just three days before my birthday - best present ever!) I hadn't done much of anything to the system, and i was just running the dual-head card until July 4th when I added in the second card with the third monitor. Everything worked perfectly.

I don't remember everything that I did to the system but I do remeber that I...
- never recompiled the kernel. I used the stock 2.4.26 from the CD.
- installed the DRI binaries for my radeon.

Everything worked perfectly and I decided that it was time for a flush because I wanted to start over with a clean slate and begin using the 2.6.x kernel package in the testing/ directory. I formatted, re-installed, installed the new kernel, and got everything configured. Now when I run start my screens turned black and my computer hangs. CTRL-ALT-BACK and CTRL-ALT-F2 and the sorts don't bring it back, the only thing i can do is CTRL-ALT-DELETE and wait for it to reboot. I've also flushed it out again and just used the stock install with my configurations and it does the same thing.

I am completely positive that its the video card that is causing the hang. I've started and used my WM with startx -- -layout single and startx -- -layout dual and it booted up fine with the radeon card. I also changed the single-display layout to use the Trident and when i used startx it hangs just like the tri-display layout. I kept the xorg.conf that I used before, and then I re-made it to make it a lot cleaner and to see if something was left over that was messing it up. I have both files accessable on my webspace, links below.

That being said - Just incase its worth noting - I know its not the kernel or the newer version of X11 that I installed with Dropline-Gnome after the flush. Before I formatted, I installed both kernel and Dropline-Gnome 2.8 and it was still working perfectly. This problem didn't come up until after I formatted and reinstalled Slackware.

I have looked all over for a solution to this. The post in the URL above seemed to be pretty much the same problem but its a SiS card - I haven't been able to find any place that I can try out new Trident drivers. Of course, I could be totally misunderstanding that situation and it might be entirly different than this one. :(

this is my original xorg.conf file from before formatting my harddrive.
this is my current xorg.conf that I am using - a rewritten cleaned up version of the file above.
this is my Xorg.0.log from my /var/log directory.

Well, that is pretty much it for now. Thank you for actually reading through all of's a lot. If there is anything that I have forgotten but remember later, I will come back and add it. If there is any information or any files or commands that I should run, please let me know. I hope that someone can at least help me figure out what the problem is.

Sorry for not making the URL's hyperlinks. I can't post them with less than five posts. :( Just replace the X's with the appropriate characters. :(

Thanks again! :)

geeksunny 10-12-2004 10:03 PM

just a little bump. :)

I still haven't figured this out. It baffles me to no end. :(

geeksunny 10-12-2004 11:56 PM

OK, problem solved.

I just took the video card out, re-installed slack, and then put the card back in. Lo-and-behold it works now! I guess having it in the box at the time of installation might have messed up a configuration or something? Linux is crazy that way I suppose :\

Just in case anybody else has this problem, that might be a good thing to try out!

All times are GMT -5. The time now is 08:57 PM.