LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-22-2015, 06:47 PM   #1
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
[kinda solved i guess]Installing nvidia drivers for gtx970 on linux mint 17 cinnamon


So I got this to work while writing this, but maybe someone can tell me where I went wrong.

my thing:
Code:
inxi -Fx
System:    Host: roman-All-Series Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: Gnome Distro: Linux Mint 17.1 Rebecca
Machine:   System: ASUS product: All Series
           Mobo: ASUSTeK model: Z97-A version: Rev 1.xx Bios: American Megatrends version: 1304 date: 07/11/2014
CPU:       Quad core Intel Core i5-4690K CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28564.2 
           Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz
Graphics:  Card: NVIDIA Device 13c2 bus-ID: 01:00.0 
           X.Org: 1.15.1 drivers: nvidia,fbdev,vesa,nouveau Resolution: 1920x1080@0.0hz 
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card-1: VIA ICE1712 [Envy24] PCI Multi-Channel I/O Controller driver: snd_ice1712 ports: d040 d070 d060 d000 bus-ID: 04:01.0
           Card-2: NVIDIA Device 0fbb driver: snd_hda_intel bus-ID: 01:00.1
           Card-3: Intel Device 8ca0 driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card: Intel Ethernet Connection (2) I218-V driver: e1000e ver: 2.3.2-k port: f040 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 38:2c:4a:b5:a2:cc
Drives:    HDD Total Size: 1250.3GB (0.5% used) 1: id: /dev/sda model: SAMSUNG_HD103UJ size: 1000.2GB temp: 26C 
           2: id: /dev/sdb model: Samsung_SSD_840 size: 250.1GB temp: 0C 
Partition: ID: / size: 222G used: 6.0G (3%) fs: ext4 ID: swap-1 size: 8.53GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 183 Uptime: 11 min Memory: 1130.6/7928.6MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4
linux-firmware-nonfree is installed
I tried to install the nvidia drivers with the driver manager first, but it's just a grey box with no options. Then I downloaded the binary from nvidia.com, but when I stop mdm I just get a blank screen and I can't log in. Same thing if I try to switch tty with ctrl-alt-Fn - before or after stopping mdm.
Next step was installing nvidia-common with the software manager, but then cinnamon boots into fallback mode which looks like 2005 gnome. The good thing about this is that I can now log into tty! So let's init 1, right? Nope, big red FAIL, no response, crash, reboot. This time it boots straight to tty! Awesome. Now I can install the nvidia driver binary thing. It exits after compiling saying installation failed (lies!). Reboot, and now the driver is installed.

Ok so this is now fixed I guess, but I don't know why. If someone can shed me some light on this I'd be really happy, but if you can't be bothered, I don't blame you.
<3
 
Old 03-23-2015, 04:22 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Hi...

I don't know either but what does glxinfo say you're running?

Regards...
 
Old 03-24-2015, 01:33 AM   #3
seasons
Member
 
Registered: Dec 2014
Distribution: siduction
Posts: 260

Rep: Reputation: 57
I usually recommend this PPA for Ubuntu users: https://launchpad.net/~mamarley/+archive/ubuntu/nvidia

If you didn't have dkms package installed, then your video will almost surely be broken the next time you update the kernel (maybe the error was the installer complaining it couldn't register with dkms?).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Nvidia proprietary driver 343 on Ubuntu (Unity)/Linux Mint (Cinnamon) x64 TheDickens Linux - Newbie 20 03-28-2015 04:45 PM
[SOLVED] Installing mate on cinnamon mint 13 Dazhann Linux - Newbie 4 01-14-2014 01:14 AM
NVIDIA Display issues uing Mint 14 and Cinnamon 1.6 graffy76 Linux - Newbie 1 01-26-2013 03:36 PM
to install nvidia drivers on linux mint 8 Helena rhklinux Linux - Newbie 1 01-16-2010 12:45 AM
Mint 7 - Installing NVIDIA drivers xkermit Linux - Newbie 1 07-27-2009 01:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration